User Tools

Site Tools


toh:mikrotik:rb750gl

Mikrotik RouterBoard RB750GL

Small SOHO router with five independent Gigabit Ethernet ports and optional switch chip functionality.

Supported Versions

Hardware Highlights

Installation

Using a Linux workstation

Here is a simple guide to flash OpenWrt/LEDE on your RB750GL from your Linux workstation…

Get these files (available here for the OpenWrt/LEDE 17.01 release):

lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs.elf
lede-17.01.4-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin
lede-17.01.4-ar71xx-mikrotik-nand-64m-squashfs-sysupgrade.bin

Connect your Linux workstation directly to the first port (1) of the device to your wired interface (directly to make sure that there won't any other DHCP server interfere).

Set a static ip on your wired interface (if you use NetworkManager or a similar tool use its capabilities or turn off the interface so that it won't interfere):

$ sudo ip addr add 192.168.1.200/24 dev eth0

Start Dnsmasq (DHCP+TFTP server):

$ sudo dnsmasq --no-daemon --port=0 --dhcp-range="192.168.1.50,192.168.1.150,12h" --enable-tftp --bootp-dynamic --dhcp-boot="lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs.elf" --tftp-root="/path/to/downloaded/files"

Press the RES button on the device and connect it to power. Wait for ~15s you will that device is using BOOTP to fetch the file in the dnsmasq output. At this point release the button and close dnsmasq using Ctrl+C:

$ sudo dnsmasq --no-daemon --port=0 --dhcp-range="192.168.1.50,192.168.1.150,12h" --enable-tftp --bootp-dynamic --dhcp-boot="lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs.elf" --tftp-root="/home/user/path/to/file"
dnsmasq: started, version 2.79 DNS disabled
dnsmasq: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify
dnsmasq-dhcp: DHCP, IP range 192.168.1.50 -- 192.168.1.150, lease time 12h
dnsmasq-tftp: TFTP root is /home/user/path/to/file
dnsmasq-dhcp: BOOTP(enp0s25) 192.168.1.78 d4:ca:6d:e3:f5:b7 
dnsmasq-tftp: sent /home/user/path/to/file/lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs.elf to 192.168.1.78
^C

OpenWrt/LEDE will boot from RAM. It will use Port 2-5 as LAN by default where it is available at the IP 192.168.1.1. Connect to the second ethernet port (2) and wait until the device responds to ICMP echo requests:

$ ping 192.168.1.1
...
From 192.168.1.200 icmp_seq=15 Destination Host Unreachable
64 bytes from 192.168.1.1: icmp_seq=16 ttl=64 time=0.767 ms

After a short while ssh daemon should be up too, and you should be able to login using ssh:

$ ssh root@192.168.1.1
...
BusyBox v1.25.1 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (17.01.4, r3560-79f57e422d)
    \________\/    -----------------------------------------------------------

=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@LEDE:~#

Check the NAND size by looking at the kernel log output:

root@LEDE:~# dmesg | grep nand
[    4.692579] nand: device found, Manufacturer ID: 0x98, Chip ID: 0xf1
[    4.699024] nand: Toshiba NAND 128MiB 3,3V 8-bit
[    4.703668] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64

In this case it is a device with 128MiB flash and a page size of 2048 bytes.

Next we will use the …sysupgrade.bin file to flash OpenWrt/LEDE to flash. Depending on the page size use:

  • Page size 512: lede-17.01.4-ar71xx-mikrotik-nand-64m-squashfs-sysupgrade.bin
  • Page size 2048: lede-17.01.4-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin

You can use the web interface to flash the device. Point your browser to http://192.168.1.1/ and login as root. Since OpenWrt/LEDE is now running from RAM, this installation won't be persistent. You can also see under System → Software that there is no flash available yet.

To flash OpenWrt/LEDE to NAND go to System ⇒ Backup/Flash Firmware. Choose the correct …sysupgrade.bin according to page size. Deselect “Keep settings”. Now press “Flash image…”, this will load another page. Check the Checksums and press “Proceed”. After a short while the router will reboot and be reachable on ethernet port 2-5 at the default IP address 192.168.1.1 via ssh or http again. This time the router started from flash, hence changes are now persistent.

References of older instructions

For more details and alternative method, see Eric Conrad's blog Installing OpenWRT on a RouterBOARD 750GL

With the help of another openwrt router

See the steps for the routerboard 493g: rb493g

Basic configuration

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

Specific Configuration

Network interfaces

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN 192.168.1.1/24
eth0.1 Ports (2 to 5) None
eth0.2 Port 1 DHCP

Switch

Default after openwrt installation

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

Every port as single port

config interface 'lan'
        option ifname 'eth0.2 eth0.3 eth0.4 eth0.5'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

#port 1/Poe
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1'

#Ethernet 2
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 2'

#Ethernet 3
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'

#Ethernet 4
config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 4'
        
#Ethernet 5
config switch_vlan
        option device 'switch0'
        option vlan '5'
        option ports '0t 5'        

Hardware

General
Brand MikroTik
Model RB750GL
Versions
Device Type Single Board Computer
Availability Discontinued 2015
Comments - general Early versions only had 64 MB NAND, use 64MB sysupgrade image instead for those devices.
OpenWrt Support
Supported Since Revision
Supported Since Release 12.09
Supported Current Release 18.06.1
Unsupported
Hardware
Instruction set MIPS32
Sub Instruction Set MIPS32 24K/E series
bootloader RouterBOOT
Target ar71xx
System-On-Chip
CPU MHz 400
Flash MB 128NAND
RAM MB 64
Network
Ethernet 100M ports -
Ethernet Gbit ports 5
switch Atheros AR8327
Modem -
VLAN Yes
Comments - network ports
Wireless
WLAN 2.4GHz -
WLAN 5.0GHz -
WLAN Hardware
Detachable Antennas -
Comments - WLAN
Interfaces
USB ports -
SATA ports -
Serial No
JTAG No
Comments - USB & SATA ports
Misc
LED count 1
Button count 1
Power supply
Links
Forum Topic URL
WikiDevi URL https://wikidevi.com/wiki/MikroTik_RouterBOARD_750GL
OEM device homepage URL http://routerboard.com/RB750GL
Firmware OEM Stock URL
Firmware OpenWrt Install URL http://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/mikrotik/openwrt-18.06.1-ar71xx-mikrotik-vmlinux-initramfs.elf
Firmware OpenWrt Upgrade URL http://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/mikrotik/openwrt-18.06.1-ar71xx-mikrotik-nand-large-squashfs-sysupgrade.bin
Edit the underlying data View/Edit data

Photos

Photos of PCB (circa May 2014). Note that there appear to be testpoints for a serial port connection along with 3.3V power. In addition you can see the spot where USB could be, but the connector and power supply apear to de-populated. The back side was very uninteresting.

Tags

toh/mikrotik/rb750gl.txt · Last modified: 2018/04/29 11:37 by tmomas