TP-Link EAP615-Wall v1

The EAP615-Wall v1 is an IEEE 802.11ax gigabit PoE+ (802.3af/at) MediaTek-based wall-mount access point. The reverse (back) side of the device has a single PoE+ input ethernet jack. The bottom has three additional ethernet jacks with one providing pass-through PoE output.

This is one of the few access points available that is Wi-Fi_6 capable.

ModelVersionSoCCPU MHzFlash MBRAM MBWLAN HardwareWLAN2.4WLAN5.0100M portsGbit portsModemUSB
EAP615-Wallv1MediaTek MT7621AT88016128MediaTek MT7905DAN, MediaTek MT7975DNb/g/n/axa/n/ac/ax-4-¿

Installing OpenWrt is relatively trivial. Turning off certificate verification via the device CLI (typical for newer TP-Link devices) is the only necessary requirement. Otherwise, upload the OpenWrt image via the TP-Link GUI.

  1. Configure a static IP connection to the device over the PoE port. The device IP is 192.168.0.254.
  2. Turn on SSH in the management options for the TP-link web GUI.
  3. SSH to the device and run:
    cliclientd stopcs
  4. Upload the OpenWrt …squashfs-factory.bin binary to the firmware update page on the TP-link web GUI.
  5. Reconfigure your static IP to talk to OpenWrt on 192.168.1.1 (the OpenWrt default).
  1. Solder TTL header. Pinout: 1: TX, 2: RX, 3: GND, 4: VCC, with pin 1 closest to ETH1. Baud rate 115200
  2. Interrupt boot process by holding a key during boot
  3. Boot the OpenWrt initramfs
      # tftpboot 0x84000000 openwrt-ramips-mt7621-tplink_eap615-wall-v1-initramfs-kernel.bin
      # bootm
  4. Copy openwrt-ramips-mt7621-tplink_eap615-wall-v1-squashfs-sysupgrade.bin to /tmp and use sysupgrade to install it

The device has four switch ports. See the Photos section below for images.

Port Switch Port
ETH0 (PoE-in) lan0
ETH1 lan1
ETH2 lan2
ETH3 (PoE-out) lan3

Because this device is only supported by newer versions of OpenWrt, you need to use the newer DSA-based VLAN switch_configuration if you plan to use VLANs. For example:

# Setup a bridge (switch) for all 4 ports:
config device
        option name 'br-router'
        option type 'bridge'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan3'
        list ports 'lan4'
        option vlan_filtering '1'

# Setup an internal VLAN for talking to the router on the default (untagged) VLAN:
config bridge-vlan
        option device 'br-router'
        option vlan '2'
        list ports 'lan0:u'
        
# Get a DHCP address for the WAP from the router:
config interface 'router'
        option device 'br-router.2'
        option proto 'dhcp'

# Setup a VLAN 3 for an SSID:
config bridge-vlan
        option device 'br-router'
        option vlan '3'
        list ports 'lan0:t'

# Setup the interface for the SSID, DHCP provided by the router:
config interface 'wifi'
        option device 'br-router.3'
        option proto 'none'

The radios support WiFi 6. That requires a newer htmode (not yet documented on the wiki) to enable. For example:

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option country US

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option country US

The htmode uses the new HE prefix. HE20 indicates a 20MHz channel width. Some channels are not permitted by the hardware without setting the country code. This has been confirmed for devices sold and used in the USA.

General
Brand TP-Link
Model EAP615-Wall
Versions v1
Device Type WiFi AP
Availability Available 2021
Comments - general
OpenWrt Support
Supported Since Commit https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=a1b8a4d7b3ff3fa671623e2bccafd43a3c141e07
Supported Since Release
Supported Current Release snapshot
Unsupported
Hardware
Bootloader U-Boot
Target ramips
System-On-Chip MediaTek MT7621AT
CPU MHz 880
Flash MB 16
RAM MB 128
Network
Ethernet 100M ports -
Ethernet Gbit ports 4
Switch -
Modem -
VLAN Yes
Comments - network ports -
Wireless
WLAN 2.4GHz b/g/n/ax
WLAN 5.0GHz a/n/ac/ax
WLAN Hardware MediaTek MT7905DAN, MediaTek MT7975DN
Detachable Antennas -
Comments - WLAN MU-MIMO
Interfaces
USB ports ¿
SATA ports -
Serial ¿
JTAG No
Comments - USB & SATA ports
Misc
LED count 1
Button count 2
Power supply PoE 802.3at
Links
Forum Topic URL
WikiDevi URL
OEM device homepage URL https://www.tp-link.com/us/business-networking/omada-sdn-access-point/eap615-wall/
Firmware OEM Stock URL https://www.tp-link.com/us/support/download/eap615-wall/
Firmware OpenWrt Install URL
Firmware OpenWrt Upgrade URL
Edit the underlying data View/Edit data

eap615-wall-scale.jpg eap615-wall-obverse.jpg eap615-wall-reverse.jpg eap615-wall-bottom.jpg eap615-wall-top.jpg

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2022/05/03 15:52
  • by tmomas