Radxa Rock Pi 4

ROCK Pi 4 is a Rockchip RK3399 based SBC. It features a six core ARM processor, 64bit dual channel 3200Mb/s LPDDR4. USB 3 Port, GbE LAN, 802.11 ac WIFI, Bluetooth 5.0.

It is available in 3 different models (A, B, C) with 1 / 2 / 4 GB ram.

The newer versions are called Rock Pi 4 plus and they come also as model A, B, C. They have a little bit faster processor, RK3399 OP1 - dual Cortex-A72 (up to 2.0Ghz) plus quad Cortex-A53 (up to 1.5Ghz).

Model CPU
Rock Pi 4 RK3399
Rock Pi 4 plus RK3399 OP1

releases / 21.02.2 / targets / rockchip / armv8 / radxa_rock-pi-4-ext4-sysupgrade.img.gz

  1. Download the image for your Rock Pi version and desired OpenWrt branch.
  2. Flash the image to a micro SD card using a disk imager, or via dd command on Linux.
  3. Once complete, insert the SD card into your Rock Pi and you're done. It will boot OpenWrt.

It might be a bit tricky to connect via Ethernet for the first time. By default the DHCP client is disabled but the IP address is configured as static 192.168.1.1
After having flashed OpenWrt like described above, you can reach the OpenWrt via Ethernet by using the IP address 192.168.1.1

Enable DHCP

Another approach is to boot once, remove the SD card and edit the configuration, to enable DHCP.

Edit /etc/config/network and add the following lines:

config interface 'wan'
  option proto 'dhcp'
  option device 'eth0'

Since you want to access it via WAN port, you also need to open the firewall. In this configuration, it could be dangerous, if it is directly accessible from outside your network! /etc/config/firewall

config rule
  option name 'Allow-web'
  option src 'wan'
  option proto 'tcp'
  option dest_port '443'
  option target 'ACCEPT'
  option family 'ipv4'
  option enabled '1'

config rule
  option name 'Allow-ssh'
  option src 'wan'
  option proto 'tcp'
  option dest_port '22'
  option target 'ACCEPT'
  option family 'ipv4'
  option enabled '1'

It has support for dual band 2,4 / 5GHz wifi.

The newer Rock Pi 4 plus versions come with an onboard uFL connector, which makes it ideal to use it with an external antenna as a wifi hotspot. The wifi module is able to be used as AP.

Wifi and bluetooth is provided by a AMPAK AP6256 chip. But the needed firmware (brcmfmac-firmware-43456) is currently not included in OpenWrt.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2022/03/10 10:44
  • by camarelli