GnuBee Personal Cloud One

Under Construction!
This page is currently under construction. You can edit the article to help completing it.

The GnuBee Personal Cloud 1 (GB-PC1) is a network-attached storage (NAS) device specifically engineered to run free, libre, open source software

Generic Router

OpenWRT layout:

dev size erasesize name

mtd0: 00030000 00010000 “u-boot” mtd1: 00010000 00010000 “u-boot-env” mtd2: 00010000 00010000 “factory” mtd3: 01fb0000 00010000 “firmware” mtd4: 00245520 00010000 “kernel” mtd5: 01d6aae0 00010000 “rootfs” mtd6: 01ac0000 00010000 “rootfs_data”

Neil Brown's builds mtd table:

dev size erasesize name
mtd0 00030000 00010000 u-boot
mtd1 00010000 00010000 u-boot-env
mtd2 00010000 00010000 factory
mtd3 01fb0000 00010000 firmware

GnuBee already comes with a preinstalled version of OpenWRT. However, original maintainer does not maintain it's OpenWRT builds, so it's safe to use official OpenWRT builds, as it is officially supported by the community.

Two methods are available: * Install via existing Openwrt: install/reinstall/upgrade via web interface or CLI. * Install via USB key: See below

  • Grab USB key, and format it in `vfat`
  • Copy `gnubee-5.15.12-gbpc1.bin` firmware into usb key root dir, a file called: `gnubee.bin`
  • Plug the usb key close to the power button.
  • Reboot GnuBee. If the device find an usb key with a `gnubee.bin` file, it will execute it.
  • Wait firmware to be copied. You can check into serial port if everything goes well: screen /dev/ttyUSB0 57600. The led should be blinking until process is over. Once over, the led is plain green.
  • Remove usb key then reboot device
  • The device should be available on any ethernet port on http://192.168.1.1/

Neil Brown's builds are available here: http://neil.brown.name/gnubee/. There are some documentation provided with those builds. Actually, this image can helps to troubleshoot, fix and install other OS. Worth mention it.

This image is also capable to boot other systems: * Simply create a partition with a GNUBEE-ROOT label to boot it. You can choose any of micro-sd, internal drive, md array or LVM. You can have different partitions with different OS, and swap labels if you want to change boot OS.

  • For ext3/ext4 with sde1 partition: tune2fs -l /dev/sde1 | grep GNUBEE-ROOT || e2label /dev/sde1 GNUBEE-ROOT
  • For fat: exfatlabel /dev/sda3 GNUBEE-ROOT

This include sdcard, disks or anything. It's worth nothing you need to install openwrt first then move its root partitions. Just follow the usual procedure: extroot_configuration

generic.flashing.tftp

This seems possible via the bootloader, but not tested yet.

generic.sysupgrade

Official procedure from existing OpenWRT variants: https://github.com/gnubee-git/GnuBee_Docs/wiki/Install-OpenWRT

FIXME These are generic instructions. Update with your router's specifics.

  • Browse to http://192.168.1.1/cgi-bin/luci/mini/system/upgrade/ LuCI Upgrade URL
  • Upload image file for sysupgrade to LuCI
  • Wait for reboot

If you don't have a GUI (LuCI) available, you can alternatively upgrade via the command line. There are two command line methods for upgrading:

  • sysupgrade
  • mtd

Note: It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

sysupgrade

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

mtd

If sysupgrade does not support this router, use mtd.

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
mtd write /tmp/xxx.abc linux && reboot

generic.debrick

GnuBee is provided with a Serial USB cable. From a Linux computer, you can get into the serial consol with: screen /dev/ttyUSB0 57600

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN 192.168.1.1/24
lan1 LAN1 BLACK None
lan2 LAN2 BLUE None

Since this device may not really be used as router, it may be useful to configure it as DHCP client on both interface. Here we also override MAC addresses for example:

# cat /etc/config/network 
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdf9:b66d:e4a2::/48'

config interface 'brblack'
        option proto 'dhcp'
        option device 'lan1'
        option macaddr '18:B5:51:AB:AB:15'

config interface 'brblue'
        option proto 'dhcp'
        option device 'lan2'
        option macaddr '18:B5:51:AB:AB:16'

Then apply changes:

/etc/init.d/network restart

Then check on your DHCP server which IP took the device to be able to reconnect. It can be useful to assign a static IP to those macaddresses.

FIXME Please fill in real values for this device, then remove the EXAMPLEs

Numbers 0-3 are Ports 1-4 as labeled on the unit, number 4 is the Internet (WAN) on the unit, 5 is the internal connection to the router itself. Don't be fooled: Port 1 on the unit is number 3 when configuring VLANs. vlan0 = eth0.0, vlan1 = eth0.1 and so on.

Port Switch port
Internet (WAN) EXAMPLE 4
LAN 1 EXAMPLE 3
LAN 2 EXAMPLE 2
LAN 3 EXAMPLE 1
LAN 4 EXAMPLE 0

hardware.button on howto use and configure the hardware button(s).

The GnuBee Personal Cloud One has the following buttons:

BUTTON Event
EXAMPLE Reset reset
General
Brand GnuBee
Model Personal Cloud One
Versions
Device Type NAS
Availability Available 2019
Comments - general
OpenWrt Support
Supported Since Commit https://git.lede-project.org/?p=source.git;a=commit;h=77645ffcd9ad767be02ea6d5cfe042928a3565d1
Supported Since Release 18.06.0
Supported Current Release 22.03.0
Unsupported
Hardware
Bootloader U-Boot
Target ramips
System-On-Chip MediaTek MT7621A
CPU MHz 880
Flash MB 32
RAM MB 512
Network
Ethernet 100M ports -
Ethernet Gbit ports 2
Switch ¿
Modem -
VLAN Yes
Comments - network ports
Wireless
WLAN 2.4GHz -
WLAN 5.0GHz -
WLAN Hardware -
Detachable Antennas -
Comments - WLAN
Interfaces
USB ports 1x 3.0, 2x 2.0
SATA ports 6
Serial Yes
JTAG No
Comments - USB & SATA ports 2.5"
Misc
LED count 4
Button count 1
Power supply 12 VDC, 3.0 A
Links
Forum Topic URL
WikiDevi URL
OEM device homepage URL https://www.crowdsupply.com/gnubee/personal-cloud-1
Firmware OEM Stock URL
Firmware OpenWrt Install URL
Firmware OpenWrt Upgrade URL https://downloads.openwrt.org/releases/22.03.0/targets/ramips/mt7621/openwrt-22.03.0-ramips-mt7621-gnubee_gb-pc1-squashfs-sysupgrade.bin
Edit the underlying data View/Edit data

Front:
Insert photo of front of the casing

Back:
Insert photo of back of the casing

Backside label:
Insert photo of backside label

Note: This will void your warranty!

FIXME Describe what needs to be done to open the device, e.g. remove rubber feet, adhesive labels, screws, …

  • To remove the cover and open the device, do a/b/c

Main PCB:
Insert photo of PCB

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device:
Insert photo of PCB with markings for serial port

FIXME Replace EXAMPLE by real values.

Serial connection parameters
for GnuBee Personal Cloud One
EXAMPLE 115200, 8N1, 3.3V

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device:
Insert photo of PCB with markings for JTAG port

COPY HERE THE BOOTLOG WITH THE ORIGINAL FIRMWARE


U-Boot 1.1.3 (Jul 9 2017 - 14:14:05)

Board: MediaTek APSoC DRAM: 512 MB

Config XHCI 40M PLL MediaTek SPI flash driver, SPI clock: 32MHz spi device id: ef 40 19 0 find flash: W25Q256FV

MediaTek U-Boot Version: 5.0.1.0-6


ASIC MT7621A DualCore (MAC to MT7530 Mode) DRAM_CONF_FROM: Auto-Detection DRAM_TYPE: DDR3 DRAM bus: 16 bit Xtal Mode=3 OCP Ratio=1/3 Flash component: SPI Flash Date:Jul 9 2017 Time:14:14:05

icache: sets:256, ways:4, linesz:32, total:32768 dcache: sets:256, ways:4, linesz:32, total:32768

#### The CPU freq = 900 MHZ #### estimate memory size = 512 Mbytes

Reset MT7530 set LAN/WAN WLLLL (Re)start USB… USB0: mtk-xhci: init hccr be1c0000 and hcor be1c0020 hc_length 32 Register 300010f NbrPorts 3 Starting the controller USB XHCI 0.96 scanning bus 0 for devices… 2 USB Device(s) found

     scanning bus for storage devices... 0 Storage Device(s) found

No USB Storage found. Upgrade FW failed!

Please choose the operation:

 1: Load system code to SDRAM via TFTP.
 2: Load system code then write to Flash via TFTP.
 3: Boot system code via Flash (default).
 4: Enter boot command line interface.
 5: Load system code then write to Flash via USB Storage.
 6: Load system code then write to Flash via Httpd.
 9: Load U-Boot code then write to Flash via TFTP.                                                                0

3: System Boot system code via Flash. ## Checking image at bc050000 …

 Image Name:   Linux-5.1.4+
 Image Type:   MIPS Linux Kernel Image (uncompressed)
 Data Size:    16852848 Bytes = 16.1 MB
 Load Address: 80001000
 Entry Point:  8063b0c0
 Verifying Checksum ... OK

OK No initrd


Space for additional notes, links to forum threads or other resources.

FIXME Add tags below, then remove this fixme.

How to add tags

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2022/08/10 18:52
  • by mrjk