EnGenius EAP1300

The Engenius EAP1300 is a fairly powerful WiFi access point that supports Power over Ethernet (PoE). Marketed as a “business” device, it does 2.4Ghz and 5Ghz and is engineered to be mounted on the ceiling.

ModelVersionSoCCPU MHzFlash MBRAM MBWLAN HardwareWLAN2.4WLAN5.0100M portsGbit portsModemUSB
EAP1300Qualcomm Atheros IPQ401871732256Qualcomm Atheros IPQ4018b/g/na/n/ac-1--

The OEM firmware for this device is based on OpenWRT and runs a custom version of LuCI. It is thus possible to install OpenWRT by uploading a sysupgrade image in the web UI. Only specific firmware versions will let you upgrade this way though.

1. Download the OEM firmware version 3.5.3.5 (sha256sum: 28840da6ff0a8ddd808a6513af69e12aa3a742cda2251bbb13e28d640db0549a). It can be retrieved on the OEM's website. A copy is also available on archive.org if that file were to be removed.

2. In the web UI, go to System Manager > Firmware > Firmware Upgrade, and upgrade the firmware.

Warning!
This section describes actions that might damage your device or firmware. Proceed with care!

3. Once the device has rebooted and is on OEM firmware version 3.5.3.5, upgrade the firmware as described before, using the latest openwrt-ipq40xx-engenius_eap1300-squashfs-sysupgrade.bin sysupgrade image. BEWARE! You should use the sysupgrade image and not the install image (ipq40xx-generic-engenius_eap1300-initramfs-fit-uImage.itb), as otherwise you will brick your device.

You will need a serial adapter to perform the following steps. To set up the flash memory environment, do the following:

1. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters:

  • 115200bps
  • 8N1

2. Confirm that the PC is connected to the board using one of the Ethernet ports. Set a static ip 192.168.99.8 for Ethernet that connects to board. The PC must have a TFTP server launched and listening on the interface to which the board is connected. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown.

U-BOOT> set serverip 192.168.99.8 && set ipaddr 192.168.99.9 && tftpboot 0x84000000 openwrt.itb && bootm

FIXME Find out flash layout, then add the flash layout table here (copy, paste, modify the example).

Please check out the article Flash layout. It contains examples and explanations that describe how to document the flash layout.

  • Browse to http://192.168.1.1/cgi-bin/luci/mini/system/upgrade/ LuCI Upgrade URL
  • Upload image file for sysupgrade to LuCI
  • Wait for reboot

If you don't have a GUI (LuCI) available, you can alternatively upgrade via the command line. There are two command line methods for upgrading:

  • sysupgrade
  • mtd

Note: It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

sysupgrade

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

mtd

If sysupgrade does not support this router, use mtd.

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
mtd write /tmp/xxx.abc linux && reboot

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

To use this device as an access point:

1. Disable the DCHP server on the device.

2. Use a network configuration that looks like this:

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd57:4798:2621::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.60'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ip6assign '60'
	option device 'br-lan'
	list dns '192.168.1.1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

The EnGenius EAP1300 has the following buttons:

BUTTON Event
Reset reset
General
Brand EnGenius
Model EAP1300
Versions
Device Type WiFi AP
Availability Available 2018
Comments - general
OpenWrt Support
Supported Since Commit https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=2b4ac79a791d9451f601d494dde2e71864174358
Supported Since Release 19.07.0
Supported Current Release 21.02.3
Unsupported
Hardware
Bootloader U-Boot
Target ipq40xx
System-On-Chip
CPU MHz 717
Flash MB 32
RAM MB 256
Network
Ethernet 100M ports -
Ethernet Gbit ports 1
Switch Qualcomm Atheros QCA8072
Modem -
VLAN ¿
Comments - network ports
Wireless
WLAN 2.4GHz b/g/n
WLAN 5.0GHz a/n/ac
WLAN Hardware Qualcomm Atheros IPQ4018
Detachable Antennas -
Comments - WLAN
Interfaces
USB ports -
SATA ports -
Serial Yes
JTAG ¿
Comments - USB & SATA ports
Misc
LED count 5
Button count 1
Power supply 12 VDC, 1.0 A, PoE 802.3af
Links
Forum Topic URL
WikiDevi URL
OEM device homepage URL https://www.engeniustech.com/engenius-products/enturbo-11ac-wave-2-indoor-wireless-access-point-ac1300/
Firmware OEM Stock URL https://www.engeniustech.com/firmware-updates.html
Firmware OpenWrt Install URL https://downloads.openwrt.org/releases/21.02.3/targets/ipq40xx/generic/openwrt-21.02.3-ipq40xx-generic-engenius_eap1300-initramfs-fit-uImage.itb
Firmware OpenWrt Upgrade URL https://downloads.openwrt.org/releases/21.02.3/targets/ipq40xx/generic/openwrt-21.02.3-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
Edit the underlying data View/Edit data

Front:

Back:

Inside cover 1:

Inside cover 2:

Note: This will void your warranty!

1. Remove the 4 Phillips 1 screws at the back of the case that secure the 2 pieces of the white plastic shell together.

2. Remove the 2 Phillips 1 screws that hold the PCB to the white plastic shell. Note that those screws are also used to ground the metal shielding to the rest of the device.

Main PCB:

Shielding:

The serial port on this device is fairly accessible and consists of 4 through-holes:

4 3 2 1 J1
Serial connection parameters
for EnGenius EAP1300
115200, 8N1
PIN RESISTANCE (UNPLUGGED) VOLTAGE (PLUGGED)
1 1000 ohm to GND 3.27 V
2 0 ohm to GND 0 V
3 10 kilo ohm to GND 3.26 V
4 600 ohm to GND 0 V

COPY HERE THE BOOTLOG WITH THE ORIGINAL FIRMWARE


COPY HERE THE BOOTLOG ONCE OPENWRT IS INSTALLED AND RUNNING


Space for additional notes, links to forum threads or other resources.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2022/04/08 13:55
  • by pollo