D-Link DSL-584T
This router is an Annex B version of D-Link DSL-524T.
Installation
OEM "easy" installation
The installation procedure is almost the same as for D-Link DSL-524T, so use the link above for the full installation procedure. The main differences are:
- Both username and password for ADAM2 bootloader are adam2, not ADAM2. The bootloader of my device listens by default on port 5.8.8.8 at startup.
- Flashing router on Linux (kernel 2.6.35-24) was EXTREMELY slow. (Put “debug” command before “put ...” command during installation procedure and you may see.) I tried Windows 7 Home edition, but a connection error appeared. At last, FTP client in Windows XP Professional did the job - it took only about 3 minutes to put the firmware on the router. So I recommend you to use this OS, but I hope that it is an issue of my device or someone will find another way to do a sucessful flash.
I use Backfire 10.03.1-rc4 and it works like a charm -- it's uptime is in weeks. My unit has been modified by adding heatsinks on chips.
Changing Annex A to Annex B
If you use generic firmware “openwrt-ar7-squashfs.bin”, you may have to add Annex B support to it - it contains only Annex A module. However, it is very easy to do this job: find a package with “kmod-sangam-atm-annex-b” in its name in /package subdirectory of the release you have used. On your router, remove original “kmod-sangam-atm-annex-a” package (using opkg or web interface) and activate dropbear-sshd - telnet into your router and insert new root password using passwd command. Then put “annex-b” package to your router by scp and install it using opkg.
You may compile your own firmware with Annex B support or use Imagebuilder tool, too.
PPPoE configuration
Edit your /etc/config/network using this stub:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option type bridge
option ifname eth0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
option nat 1
config atm-bridge
option unit 0
option encaps llc
option vpi 8
option vci 35 # In Czech Republic it's quite common to use value 48 instead of 35.
config interface wan
option ifname nas0
option proto pppoe
option username “my_username”
option password “my_password”
For more info, see thread http://forum.openwrt.org/viewtopic.php?id=25702 on OpenWRT forum. For Czech speaking people, this thread may be useful: http://www.abclinuxu.cz/poradna/linux/show/263485.