User Tools

Site Tools


toh:comfast:cf-wr800n

COMFAST CF-WR800N

This device is NOT RECOMMENDED for future use with OpenWrt due to low flash/ram.
DO NOT BUY DEVICES WITH 4MB FLASH / 32MB RAM if you intend to flash an up-to-date and secure OpenWrt version (18.06 or later) onto it! See 4/32 warning for details.

1) This device does not have sufficient resources (flash and/or RAM) to provide secure and reliable operation.
This means that even setting a password or changing simple network settings might not be possible any more, rendering the device effectively useless. See OpenWrt on 4/32 devices what you can do now.

2) OpenWrt support for this device will end after 2019.
19.07 will be the last official build for 4/32 devices. After 19.07, no further OpenWrt images will be built for 4/32 devices. See OpenWrt on 4/32 devices what you can do now.

The Comfast CF-WR800N is wall-plug wireless router based on the MediaTek MT7620A chip with one Ethernet port and a 802.11n 2T/2R 2.4 GHz 300Mbps wireless interface. It comes with OpenWrt as the stock firmware, with a custom web interface to configure the device as AP, WiFi repeater amplifier, etc.

Supported Versions

Hardware Highlights

Installation

Install OpenWrt (generic explanation)

  1. Download sysupgrade.bin as shown above to to /tmp.
  2. sysupgrade
    root@COMFAST:/tmp# sysupgrade -v -n openwrt-15.05-ramips-mt7620-cf-wr800n-squashfs-sysupgrade.bin 
    killall: watchdog: no process killed
    Sending TERM to remaining processes ... mbox-config uhttpd ntpd ubusd askfirst logd netifd dnsmasq 
    Sending KILL to remaining processes ... askfirst 
    Switching to ramdisk...
    Performing system upgrade...
    Unlocking firmware ...
    
    Writing from <stdin> to firmware ...     
    Upgrade completed
    Rebooting system...
  3. After reboot the device is accessible on 192.168.1.1

Hardware

Info

Architecture MIPS 24KEc V5.0 (ramips)
Vendor MediaTek
Bootloader U-boot 1.1.3
System-On-Chip MediaTek MT7620N
CPU Speed 580MHz
RAM memory 32 MB DDR
Flash memory 8 MB
Flash chip MX25L6405D
Wired network 1x Ethernet 100 Mbps (switched)
Ethernet chip MediaTek MT7530 (SoC)
Ethernet switch MediaTek MT7530 (integrated)
Wireless network 2.4 GHz 802.11n MiMo 2×2:2
Wireless chip MediaTek 7620 (RF), 5390 (RT) (SoC)
Wireless antennas 2 x sticker antennae
USB No
Serial port Yes (TTL pins)

Serial connection

The serial port of the Comfast CF-WR800N can be accessed using the TTL pins shown in the image below. The pins are clearly labeled on the board. A voltage level converter (such as a CP2102 TTL-USB dongle) is required.

The communication settings are: 115200 bps 8N1.

GPIO

Stock firmware

The Comfast CF-WR800N devices are shipped with OpenWrt:

BusyBox v1.22.1 (2014-11-14 15:31:55 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, unknown)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@COMFAST:/# 

Stock network settings

The Ethernet port is connected to port #4 of the switch. In the stock firmware, it belongs to eth0.2, which is in the br-lan and wan6 networks (but not in the wan).

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:cba4:51b8::/48'

config interface 'lan'
        option force_link '1'
        option macaddr '41:45:ee:d7:89:63'
        option ifname 'eth0.1 eth0.2'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config eth0.1 'def_lan'

config interface 'wan'
        option force_link '1'
        option macaddr '41:45:ee:d7:89:64'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config eth0.2 'def_wan'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

Stock firmware login

The stock firmware has a web interface accessible via http://192.168.10.1 (user/password: admin). The telnet server is also active, without password:

telnet 192.168.10.1
Trying 192.168.10.1...
Connected to 192.168.10.1.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-11-14 15:31:55 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.
[...]
root@COMFAST:/# 

U-boot bootlog

U-Boot 1.1.3 (Nov 21 2014 - 10:27:22)

Board: Ralink APSoC DRAM:  32 MB
relocate_code Pointer at: 81fb8000
enable ephy clock...done. rf reg 29 = 5
SSC disabled.
******************************
Software System Reset Occurred
******************************
spi_wait_nsec: 29 
spi device id: c2 20 17 c2 20 (2017c220)
find flash: MX25L6405D
raspi_read: from:30000 len:1000 
*** Warning - bad CRC, using default environment

============================================ 
Ralink UBoot Version: 4.2.1.0
-------------------------------------------- 
ASIC 7620_MP (Port5<->None)
DRAM component: 256 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 32 MBytes
Flash component: SPI Flash
Date:Nov 21 2014  Time:10:27:22
============================================ 
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768 

 ##### The CPU freq = 580 MHZ #### 
 estimate memory size =32 Mbytes

Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial. 
   9: Load Boot Loader code then write to Flash via TFTP. 

You choosed 4

Bootlogs

Stock OpenWrt bootlog

3: System Boot system code via Flash. ## Booting image at bc050000 ... raspi_read: from:50000 len:40 Image Name: MIPS OpenWrt Linux-3.14.18 Image Type: MIPS Linux Kernel Image (lzma compressed) Data Size: 1062289 Bytes = 1 MB Load Address: 80000000 Entry Point: 80000000 raspi_read: from:50040 len:103591 Verifying Checksum ... OK Uncompressing Kernel Image ... OK No initrd ## Transferring control to Linux (at address 80000000) ... ## Giving linux memsize in MB, 32 Starting kernel ... [ 0.000000] Linux version 3.14.18 (jiangyaohui@zhuyufang-02241341) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 unknown) ) #3 Thu Nov 20 17:13:48 CST 2014 [ 0.000000] Board has DDR1 [ 0.000000] Analog PMU set to hw control [ 0.000000] Digital PMU set to hw control [ 0.000000] SoC Type: Ralink MT7620N ver:2 eco:6 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 00019650 (MIPS 24KEc) [ 0.000000] MIPS: machine is Comfast CF-WR800N [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 02000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x00000000-0x01ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x00000000-0x01ffffff] [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. [ 0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128 [ 0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2 [ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes) [ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes) [ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes) [ 0.000000] Writing ErrCtl register=000151d4 [ 0.000000] Readback ErrCtl register=000151d4 [ 0.000000] Memory: 29152K/32768K available (2317K kernel code, 121K rwdata, 456K rodata, 168K init, 180K bss, 3616K reserved) [ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 [ 0.000000] NR_IRQS:256 [ 0.000000] CPU Clock: 580MHz [ 0.000000] systick: running - mult: 214748, shift: 32 [ 0.000000] genirq: Flags mismatch irq 7. 00014600 (timer) vs. 00014600 (systick) [ 0.000000] Calibrating delay loop... 766.77 BogoMIPS (lpj=3833856) [ 0.040000] pid_max: default: 32768 minimum: 301 [ 0.040000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.040000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.050000] pinctrl core: initialized pinctrl subsystem [ 0.050000] NET: Registered protocol family 16 [ 0.060000] bio: create slab <bio-0> at 0 [ 0.060000] rt2880_gpio 10000600.gpio: registering 24 gpios [ 0.070000] rt2880_gpio 10000600.gpio: registering 24 irq handlers [ 0.070000] rt2880_gpio 10000638.gpio: registering 16 gpios [ 0.070000] rt2880_gpio 10000638.gpio: registering 16 irq handlers [ 0.070000] rt2880_gpio 10000688.gpio: registering 1 gpios [ 0.080000] rt2880_gpio 10000688.gpio: registering 1 irq handlers [ 0.080000] Switched to clocksource systick [ 0.080000] NET: Registered protocol family 2 [ 0.090000] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.090000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.090000] TCP: Hash tables configured (established 1024 bind 1024) [ 0.110000] TCP: reno registered [ 0.110000] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.110000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.110000] NET: Registered protocol family 1 [ 0.130000] rt-timer 10000100.timer: maximum frequency is 2441Hz [ 0.130000] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.150000] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.160000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.170000] msgmni has been set to 56 [ 0.180000] io scheduler noop registered [ 0.180000] io scheduler deadline registered (default) [ 0.180000] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled [ 0.200000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a 16550A [ 0.200000] console [ttyS0] enabled [ 0.200000] console [ttyS0] enabled [ 0.200000] bootconsole [early0] disabled [ 0.200000] bootconsole [early0] disabled [ 0.220000] m25p80 spi32766.0: found mx25l6405d, expected w25q128 [ 0.230000] m25p80 spi32766.0: mx25l6405d (8192 Kbytes) [ 0.230000] 4 ofpart partitions found on MTD device spi32766.0 [ 0.240000] Creating 4 MTD partitions on "spi32766.0": [ 0.250000] 0x000000000000-0x000000030000 : "u-boot" [ 0.250000] 0x000000030000-0x000000040000 : "u-boot-env" [ 0.260000] 0x000000040000-0x000000050000 : "factory" [ 0.270000] 0x000000050000-0x000000800000 : "firmware" [ 0.270000] 0x0000001535d1-0x000000800000 : "rootfs" [ 0.280000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only [ 0.300000] mtd: device 4 (rootfs) set to be root filesystem [ 0.300000] 1 squashfs-split partitions found on MTD device rootfs [ 0.300000] 0x000000510000-0x000000800000 : "rootfs_data" [ 0.320000] ralink_soc_eth 10100000.ethernet: Enabling TSO [ 0.320000] gsw: setting port4 to ephy mode [ 0.320000] (unregistered net_device): port 4 link up (100Mbps/Full duplex) [ 0.340000] ralink_soc_eth 10100000.ethernet: loaded mt7530 driver [ 0.340000] eth0: done loading [ 0.340000] rt3xxx-usbphy usbphy.3: loaded [ 0.340000] rt2880_wdt 10000120.watchdog: Initialized [ 0.360000] TCP: cubic registered [ 0.360000] NET: Registered protocol family 17 [ 0.360000] Bridge firewalling registered [ 0.360000] 8021q: 802.1Q VLAN Support v1.8 [ 0.380000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4. [ 0.400000] Freeing unused kernel memory: 168K (802d6000 - 80300000) procd: Console is alive procd: - watchdog - procd: - preinit - [ 6.140000] random: mktemp urandom read with 73 bits of entropy available Press the [f] key and hit [enter] to enter failsafe mode Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level jffs2 is ready jffs2 is ready [ 9.530000] jffs2: notice: (268) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 7 of xref (0 dead, 0 orphan) found. switching to overlay procd: - early - procd: - watchdog - procd: - ubus - procd: - init - Please press Enter to activate this console. [ 12.700000] NET: Registered protocol family 10 [ 13.090000] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 13.190000] u32 classifier [ 13.200000] input device check on [ 13.210000] Actions configured [ 13.210000] Mirror/redirect action on [ 13.220000] nf_conntrack version 0.5.0 (458 buckets, 1832 max) [ 13.230000] Loading modules backported from Linux version master-2014-09-26-0-g25e3efa [ 13.240000] Backport generated by backports.git backports-20140905-1-gde42785 [ 13.260000] Ebtables v2.0 registered [ 13.270000] ip_tables: (C) 2000-2006 Netfilter Core Team [ 13.280000] lib80211: common routines for IEEE802.11 drivers [ 13.350000] xt_time: kernel timezone is -0000 [ 13.390000] cfg80211: Calling CRDA to update world regulatory domain [ 13.390000] cfg80211: World regulatory domain updated: [ 13.400000] cfg80211: DFS Master region: unset [ 13.400000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 13.420000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 13.420000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 13.420000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A) [ 13.440000] cfg80211: (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A) [ 13.440000] cfg80211: (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s) [ 13.460000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s) [ 13.460000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) [ 13.470000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A) [ 13.520000] PPP generic driver version 2.4.2 [ 13.530000] NET: Registered protocol family 24 [ 13.620000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0500 detected [ 13.630000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected [ 20.450000] random: nonblocking pool is initialized [ 21.320000] device eth0.1 entered promiscuous mode [ 21.320000] device eth0 entered promiscuous mode [ 21.350000] br-lan: port 1(eth0.1) entered forwarding state [ 21.360000] br-lan: port 1(eth0.1) entered forwarding state [ 21.420000] device eth0.2 entered promiscuous mode [ 21.430000] br-lan: port 2(eth0.2) entered forwarding state [ 21.440000] br-lan: port 2(eth0.2) entered forwarding state [ 23.130000] cfg80211: Calling CRDA for country: CN [ 23.140000] cfg80211: Regulatory domain changed to country: CN [ 23.140000] cfg80211: DFS Master region: FCC [ 23.140000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 23.160000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 23.160000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2300 mBm), (N/A) [ 23.180000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s) [ 23.180000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A) [ 23.180000] cfg80211: (57240000 KHz - 59400000 KHz @ 2160000 KHz), (N/A, 2800 mBm), (N/A) [ 23.180000] cfg80211: (59400000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4400 mBm), (N/A) [ 23.180000] cfg80211: (63720000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 2800 mBm), (N/A) [ 23.500000] br-lan: port 1(eth0.1) entered forwarding state [ 23.510000] br-lan: port 2(eth0.2) entered forwarding state procd: - init complete - [ 27.770000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 27.770000] device wlan0 entered promiscuous mode [ 27.780000] br-lan: port 3(wlan0) entered forwarding state [ 27.790000] br-lan: port 3(wlan0) entered forwarding state [ 27.790000] br-lan: port 3(wlan0) entered disabled state [ 27.840000] br-lan: port 3(wlan0) entered forwarding state [ 27.840000] br-lan: port 3(wlan0) entered forwarding state [ 27.850000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 30.050000] br-lan: port 3(wlan0) entered forwarding state BusyBox v1.22.1 (2014-11-14 15:31:55 CST) built-in shell (ash) Enter 'help' for a list of built-in commands. _______ ________ __ | |.-----.-----.-----.| | | |.----.| |_ | - || _ | -__| || | | || _|| _| |_______|| __|_____|__|__||________||__| |____| |__| W I R E L E S S F R E E D O M ----------------------------------------------------- CHAOS CALMER (Bleeding Edge, unknown) ----------------------------------------------------- * 1 1/2 oz Gin Shake with a glassful * 1/4 oz Triple Sec of broken ice and pour * 3/4 oz Lime Juice unstrained into a goblet. * 1 1/2 oz Orange Juice * 1 tsp. Grenadine Syrup ----------------------------------------------------- root@COMFAST:/#


OpenWrt bootlog

This is a log using OpenWrt CHAOS CALMER (Bleeding Edge, r43977)

U-Boot 1.1.3 (Jan 3 2014 - 09:12:42) MAX Board: Ralink APSoC DRAM: 64 MB relocate_code Pointer at: 83fb4000 enable ephy clock...done. rf reg 29 = 5 SSC disabled. ****************************** Software System Reset Occurred ****************************** spi_wait_nsec: 29 spi device id: 1c 30 17 1c 30 (30171c30) find flash: EN25Q64 raspi_read: from:30000 len:1000 raspi_read: from:30000 len:1000 ============================================ Ralink UBoot Version: 4.1.1.0 -------------------------------------------- ASIC 7620_MP (Port5<->None) DRAM component: 512 Mbits DDR, width 16 DRAM bus: 16 bit Total memory: 64 MBytes Flash component: SPI Flash Date:Jan 3 2014 Time:09:12:42 ============================================ icache: sets:512, ways:4, linesz:32 ,total:65536 dcache: sets:256, ways:4, linesz:32 ,total:32768 ##### The CPU freq = 580 MHZ #### estimate memory size =64 Mbytes Please choose the operation: 1: Load system code to SDRAM via TFTP. 2: Load system code then write to Flash via TFTP. 3: Boot system code via Flash (default). 4: Entr boot command line interface. 7: Load Boot Loader code then write to Flash via Serial. 9: Load Boot Loader code then write to Flash via TFTP.  4  3  2  1  0 3: System Boot system code via Flash. ## Booting image at bc050000 ... raspi_read: from:50000 len:40 Image Name: MIPS OpenWrt Linux-3.14.28 Image Type: MIPS Linux Kernel Image (lzma compressed) Data Size: 1164568 Bytes = 1.1 MB Load Address: 80000000 Entry Point: 80000000 raspi_read: from:50040 len:11c518 Verifying Checksum ... OK Uncompressing Kernel Image ... OK No initrd ## Transferring control to Linux (at address 80000000) ... ## Giving linux memsize in MB, 64 Starting kernel ... [ 0.000000] Linux version 3.14.28 (openwrt@gb-10) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r43977) ) #1 Fri Jan 16 16:33:53 UTC 2015 [ 0.000000] Board has DDR1 [ 0.000000] Analog PMU set to hw control [ 0.000000] Digital PMU set to hw control [ 0.000000] SoC Type: Ralink MT7620N ver:2 eco:6 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 00019650 (MIPS 24KEc) [ 0.000000] MIPS: machine is Nexx WT3020 [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 04000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x00000000-0x03ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x00000000-0x03ffffff] [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. [ 0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256 [ 0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2 [ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes) [ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) [ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) [ 0.000000] Writing ErrCtl register=00017df8 [ 0.000000] Readback ErrCtl register=00017df8 [ 0.000000] Memory: 61316K/65536K available (2549K kernel code, 134K rwdata, 508K rodata, 192K init, 188K bss, 4220K reserved) [ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 [ 0.000000] NR_IRQS:256 [ 0.000000] CPU Clock: 580MHz [ 0.000000] systick: running - mult: 214748, shift: 32 [ 0.000000] genirq: Flags mismatch irq 7. 00014600 (timer) vs. 00014600 (systick) [ 0.010000] Calibrating delay loop... 766.77 BogoMIPS (lpj=3833856) [ 0.050000] pid_max: default: 32768 minimum: 301 [ 0.050000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.060000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.060000] pinctrl core: initialized pinctrl subsystem [ 0.070000] NET: Registered protocol family 16 [ 0.080000] bio: create slab <bio-0> at 0 [ 0.080000] rt2880_gpio 10000600.gpio: registering 24 gpios [ 0.090000] rt2880_gpio 10000600.gpio: registering 24 irq handlers [ 0.090000] rt2880_gpio 10000660.gpio: registering 32 gpios [ 0.100000] rt2880_gpio 10000660.gpio: registering 32 irq handlers [ 0.100000] rt2880_gpio 10000688.gpio: registering 1 gpios [ 0.110000] rt2880_gpio 10000688.gpio: registering 1 irq handlers [ 0.110000] Switched to clocksource systick [ 0.120000] NET: Registered protocol family 2 [ 0.120000] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.140000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.150000] TCP: Hash tables configured (established 1024 bind 1024) [ 0.170000] TCP: reno registered [ 0.170000] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.170000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.200000] NET: Registered protocol family 1 [ 0.200000] rt-timer 10000100.timer: maximum frequency is 2441Hz [ 0.220000] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.240000] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.260000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.280000] msgmni has been set to 119 [ 0.280000] io scheduler noop registered [ 0.300000] io scheduler deadline registered (default) [ 0.300000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled [ 0.320000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a 16550A [ 0.350000] console [ttyS0] enabled [ 0.350000] console [ttyS0] enabled [ 0.350000] bootconsole [early0] disabled [ 0.350000] bootconsole [early0] disabled [ 0.380000] m25p80 spi32766.0: found en25q64, expected w25q64 [ 0.380000] m25p80 spi32766.0: en25q64 (8192 Kbytes) [ 0.400000] 4 ofpart partitions found on MTD device spi32766.0 [ 0.410000] Creating 4 MTD partitions on "spi32766.0": [ 0.420000] 0x000000000000-0x000000030000 : "u-boot" [ 0.440000] 0x000000030000-0x000000040000 : "u-boot-env" [ 0.440000] 0x000000040000-0x000000050000 : "factory" [ 0.460000] 0x000000050000-0x000000800000 : "firmware" [ 0.490000] 2 uimage-fw partitions found on MTD device firmware [ 0.510000] 0x000000050000-0x00000016c558 : "kernel" [ 0.510000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only [ 0.540000] 0x00000016c558-0x000000800000 : "rootfs" [ 0.550000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only [ 0.580000] mtd: device 5 (rootfs) set to be root filesystem [ 0.590000] 1 squashfs-split partitions found on MTD device rootfs [ 0.600000] 0x000000340000-0x000000800000 : "rootfs_data" [ 0.620000] ralink_soc_eth 10100000.ethernet (unregistered net_device): port 0 link up (100Mbps/Full duplex) [ 0.640000] ralink_soc_eth 10100000.ethernet: loaded mt7620 driver [ 0.650000] ralink_soc_eth 10100000.ethernet eth0: ralink at 0xb0100000, irq 5 [ 0.670000] rt3xxx-usbphy usbphy.3: loaded [ 0.670000] rt2880_wdt 10000120.watchdog: Initialized [ 0.690000] TCP: cubic registered [ 0.690000] NET: Registered protocol family 17 [ 0.700000] Bridge firewalling registered [ 0.710000] 8021q: 802.1Q VLAN Support v1.8 [ 0.730000] VFS: Mounted root (squashfs filesystem) readonly on device 31:5. [ 0.750000] Freeing unused kernel memory: 192K (80320000 - 80350000) procd: Console is alive procd: - watchdog - [ 5.370000] usbcore: registered new interface driver usbfs [ 5.390000] usbcore: registered new interface driver hub [ 5.390000] usbcore: registered new device driver usb [ 5.410000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver [ 5.430000] ehci-platform: EHCI generic platform driver [ 5.830000] rt3xxx-usbphy usbphy.3: remote usb device wakeup disabled [ 5.850000] rt3xxx-usbphy usbphy.3: UTMI 16bit 30MHz [ 5.850000] ehci-platform 101c0000.ehci: EHCI Host Controller [ 5.870000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1 [ 5.890000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000 [ 5.910000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00 [ 5.910000] hub 1-0:1.0: USB hub found [ 5.930000] hub 1-0:1.0: 1 port detected [ 5.930000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver [ 5.950000] ohci-platform: OHCI generic platform driver [ 5.960000] ohci-platform 101c1000.ohci: Generic Platform OHCI controller [ 5.980000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2 [ 5.980000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000 [ 6.070000] hub 2-0:1.0: USB hub found [ 6.070000] hub 2-0:1.0: 1 port detected procd: - preinit - [ 6.950000] 8021q: adding VLAN 0 to HW filter on device eth0 [ 6.990000] random: mktemp urandom read with 65 bits of entropy available Press the [f] key and hit [enter] to enter failsafe mode Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level jffs2 is ready No jffs2 marker was found [ 10.640000] jffs2: notice: (310) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 6 of xref (0 dead, 0 orphan) found. switching to overlay procd: - early - procd: - watchdog - procd: - ubus - procd: - init - Please press Enter to activate this console. [ 13.590000] NET: Registered protocol family 10 [ 13.610000] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 13.630000] Loading modules backported from Linux version master-2014-11-04-0-gf3660a2 [ 13.650000] Backport generated by backports.git backports-20141023-2-g4ff890b [ 13.670000] ip_tables: (C) 2000-2006 Netfilter Core Team [ 13.690000] nf_conntrack version 0.5.0 (961 buckets, 3844 max) [ 13.730000] xt_time: kernel timezone is -0000 [ 13.770000] cfg80211: Calling CRDA to update world regulatory domain [ 13.780000] cfg80211: World regulatory domain updated: [ 13.800000] cfg80211: DFS Master region: unset [ 13.800000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 13.820000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 13.840000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 13.860000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A) [ 13.860000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) [ 13.890000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) [ 13.910000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s) [ 13.910000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) [ 13.940000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A) [ 13.940000] PPP generic driver version 2.4.2 [ 13.940000] NET: Registered protocol family 24 [ 13.940000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0500 detected [ 13.940000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected procd: - init complete - [ 19.730000] 8021q: adding VLAN 0 to HW filter on device eth0 [ 19.760000] device eth0.1 entered promiscuous mode [ 19.770000] device eth0 entered promiscuous mode [ 19.780000] br-lan: port 1(eth0.1) entered forwarding state [ 19.800000] br-lan: port 1(eth0.1) entered forwarding state [ 21.800000] br-lan: port 1(eth0.1) entered forwarding state [ 21.800000] ralink_soc_eth 10100000.ethernet eth0: port 0 link down [ 22.120000] br-lan: port 1(eth0.1) entered disabled state [ 28.150000] random: nonblocking pool is initialized


Tags

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
toh/comfast/cf-wr800n.txt · Last modified: 2019/10/03 08:33 by tmomas