Caswell CAD-0208

Caswell CAD-0208 (also known as AppNeta m30 and probably by a few other names) is a four-port network appliance. It was designed to work as a network monitor in digital telephony applications, so its designers made a couple of non-mainstream choices to fit the design to purpose. Specifically:

  • The device has four Ethernet ports grouped into two pairs. Each pair can be configured (in BIOS) to work in the bypass mode. This is something that needs to be addressed before installing OpenWrt (see BIOS Settings below).
  • The Wi-Fi card is Intel 6230, meaning, it does not support the access point mode (wireless access was probably intended for administrative use only). As a result, the device in its original form cannot be used as a wireless router, but can conceivably be used as a wireless bridge. However, the Wi-Fi card is removable, and its mount accepts both half-size and full-size cards, so it should be possible to replace the Intel card with something that supports at least the N standard (AC and AX should be possible as well).

In terms of administrative access, the CAD-0208 is pretty spartan; the only option is the RJ-45 console. The console is well-behaved, so a USB-to-RJ-45 console cable can be used.

Power-wise, the device expects 12V / 3.33 A over a 5.5-mm barrel connector.

Hardware components include an Intel Atom D510 processor (located on the bottom side of the main board), a stick of RAM (the test unit came with strangely generous 4 GB, so it is possible this was an upgrade done by the previous owner), an Intel 82583V Ethernet controller, and an Intel 6230 Wi-Fi controller. Primary storage can be a CF card (there is a slot for it on the main board) or a SATA drive (there's a set of SATA connectors and a set of standoffs, but a mounting tray may or may not be present).

Before attempting OpenWrt installation, you should make sure that bypass settings are not going to interfere with OpenWrt operation. To do that, open a console connection at 19200 bps, boot the device, and press the Tab key repeatedly until you get the main BIOS screen. Once there, press the right arrow key once; this will get you to the Advanced screen that will look like this:

  Main    Advanced    PCIPnP    Boot    Security    Chipset    Exit
********************************************************************************
* Advanced Settings                                   * Configure CPU.         *
* *************************************************** *                        *
* WARNING: Setting wrong values in below sections     *                        *
*          may cause system to malfunction.           *                        *
*                                                     *                        *
* * CPU Configuration                                 *                        *
* * IDE Configuration                                 *                        *
* * SuperIO Configuration                             *                        *
* * Hardware Health Configuration                     *                        *
* * ACPI Configuration                                *                        *
* * AHCI Configuration                                *                        *
* * ASF Configuration                                 *                        *
* * MPS Configuration                                 * *    Select Screen     *
* * PCI Express Configuration                         * **    Select Item      *
* * Smbios Configuration                              * Enter Go to Sub Screen *
* * Remote Access Configuration                       * F1    General Help     *
* * Trusted Computing                                 * F10   Save and Exit    *
* * USB Configuration                                 * ESC   Exit             *
* Bypass A Power On setting      [Normal]             *                        *
* Bypass B Power On setting      [Normal]             *                        *
********************************************************************************
            v02.61 (C)Copyright 1985-2006, American Megatrends, Inc.

Verify that both Bypass A Power On setting and Bypass B Power On setting in the bottom part of the screen are set to Normal. If not, use arrow keys and Enter to navigate to those fields and set them to Normal.

If you had to change anything, use the right arrow key to get to the Exit screen, then select the Save and Exit option.

This device has been verified as working with OpenWrt 22.03.2. Please note that the stock Wi-Fi card (Intel 6230) does not support the access point (AP) mode, so to make this device a workable wireless router, the Wi-Fi card should be replaced with one that supports the AP mode.

The device will run either an x86-64-generic-ext4-combined or an x86-64-generic-squashfs-combined image.

Download the image of your choice, write it onto a CF card (which can be as small as 128 MB) or a SATA drive, install the card or drive into the device, and it should boot with no issues. In the unlikely case wired networking doesn't work out of the box, install the kmod-e1000e package; this should fix the problem.

Note that the 64-bit OpenWrt expects to communicate over the console connection at 115200 bps, which is different from the connection speed expected by BIOS. So you should connect at 19200 bps if you want to get into BIOS, but at 115200 is you intend to manage OpenWrt.

Once OpenWrt is up and running and you still have a console connection, edit the network configuration file (/etc/config/network) to create a desired configuration. Leave the beginning sections (interface 'loopback' and config globals 'globals') unchanged; edit the remainder of the file, The example below shows a configuration in which three ports (eth0, eth1, and eth2) are bridged into a single LAN while eth3 is the WAN port expecting to work with a DHCP server on an upstream device.

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'
        list ports 'eth2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth3'
        option proto 'dhcp'

When you're done editing, reboot the device to ensure that everything works correctly.

FIXME Find out flash layout, then add the flash layout table here (copy, paste, modify the example).

Please check out the article Flash layout. It contains examples and explanations that describe how to document the flash layout.

FIXME The instructions below are for Broadcom devices and only serve as an example.
Remove / modify them if they do not apply to this particular device!

This section deals with

  • How you install OpenWrt from a device freshly opened
  • The steps required such as reset to factory defaults if the device has already been configured

Note: Reset router to factory defaults if it has been previously configured.

  • Browse to http://192.168.1.1/Upgrade.asp
  • Upload .bin file to router
  • Wait for it to reboot
  • Telnet to 192.168.1.1 and set a root password, or browse to http://192.168.1.1 if LuCI is installed.

Specific values needed for tftp

FIXME Enter values for “FILL-IN” below

Bootloader tftp server IPv4 address FILL-IN
Bootloader MAC address (special) FILL-IN
Firmware tftp image Latest OpenWrt release (NOTE: Name must contain “tftp”)
TFTP transfer window FILL-IN seconds
TFTP window start approximately FILL-IN seconds after power on
TFTP client required IP address FILL-IN

generic.sysupgrade

FIXME These are generic instructions. Update with your router's specifics.

  • Browse to http://192.168.1.1/cgi-bin/luci/mini/system/upgrade/ LuCI Upgrade URL
  • Upload image file for sysupgrade to LuCI
  • Wait for reboot

If you don't have a GUI (LuCI) available, you can alternatively upgrade via the command line. There are two command line methods for upgrading:

  • sysupgrade
  • mtd

Note: It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

sysupgrade

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

mtd

If sysupgrade does not support this router, use mtd.

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
mtd write /tmp/xxx.abc linux && reboot

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

FIXME Please fill in real values for this device, then remove the EXAMPLEs

The default network configuration is:

Interface Name Description Default configuration
br-lan EXAMPLE LAN & WiFi EXAMPLE 192.168.1.1/24
vlan0 (eth0.0) EXAMPLE LAN ports (1 to 4) EXAMPLE None
vlan1 (eth0.1) EXAMPLE WAN port EXAMPLE DHCP
wl0 EXAMPLE WiFi EXAMPLE Disabled

FIXME Please fill in real values for this device, then remove the EXAMPLEs

Numbers 0-3 are Ports 1-4 as labeled on the unit, number 4 is the Internet (WAN) on the unit, 5 is the internal connection to the router itself. Don't be fooled: Port 1 on the unit is number 3 when configuring VLANs. vlan0 = eth0.0, vlan1 = eth0.1 and so on.

Port Switch port
Internet (WAN) EXAMPLE 4
LAN 1 EXAMPLE 3
LAN 2 EXAMPLE 2
LAN 3 EXAMPLE 1
LAN 4 EXAMPLE 0

hardware.button on howto use and configure the hardware button(s). Here, we merely name the buttons, so we can use them in the above Howto.

FIXME Please fill in real values for this device, then remove the EXAMPLEs

The Caswell CAD-0208 has the following buttons:

BUTTON Event
EXAMPLE Reset reset
EXAMPLE Secure Easy Setup ses
EXAMPLE No buttons at all. -

FIXME

  1. This table is automatically generated, once the correct filters for Brand and Model are set.
  2. If you see “Nothing.” instead of a table, please edit this section and adjust the filters with the proper Brand and Model. Just try, it's easy.
  3. If you still don't see a table here, or a table filled with '¿': Is there already a Techdata page available for Caswell CAD-0208 ? If not: Create one.
  4. If you see a table with the desired device data, everything is OK and you can delete this text and the <WRAP> that encloses it.
  5. If it still doesn't work: Don't panic, calm down, take a deep breath and contact a wiki admin (tmomas) for help.

Front:
Insert photo of front of the casing

Back:
Insert photo of back of the casing

Backside label:
Insert photo of backside label

Note: This will void your warranty!

FIXME Describe what needs to be done to open the device, e.g. remove rubber feet, adhesive labels, screws, ...

  • To remove the cover and open the device, do a/b/c

Main PCB:
Insert photo of PCB

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device:
Insert photo of PCB with markings for serial port

FIXME Replace EXAMPLE by real values.

Serial connection parameters
for Caswell CAD-0208 @@Version@@
EXAMPLE 115200, 8N1, 3.3V

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device:
Insert photo of PCB with markings for JTAG port

None so far.

COPY HERE THE BOOTLOG WITH THE ORIGINAL FIRMWARE


COPY HERE THE BOOTLOG ONCE OPENWRT IS INSTALLED AND RUNNING


Space for additional notes, links to forum threads or other resources.

  • ...

FIXME Add tags below, then remove this fixme.

How to add tags

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2024/02/12 11:13
  • by 127.0.0.1