User Tools

Site Tools


toh:asiarf:awm-evb

AsiaRF AP2620

This device is NOT RECOMMENDED for future use with OpenWrt due to low flash/ram.
DO NOT BUY DEVICES WITH 4MB FLASH / 32MB RAM if you intend to flash an up-to-date and secure OpenWrt version (18.06 or later) onto it! See 4/32 warning for details.

1) This device does not have sufficient resources (flash and/or RAM) to provide secure and reliable operation.
This means that even setting a password or changing simple network settings might not be possible any more, rendering the device effectively useless. See OpenWrt on 4/32 devices what you can do now.

2) OpenWrt support for this device will end after 2019.
19.07 will be the last official build for 4/32 devices. After 19.07, no further OpenWrt images will be built for 4/32 devices. See OpenWrt on 4/32 devices what you can do now.

MediaTek Wireless MIPS IC MT7620 Test board IoT Home Automation Sever WiFi 11n MT7620 High Speed Multi-Functions Router Board AP2620-P Main Chipset MT7620 with 580MHz High Speed MIPS CPU rate.

With all interfaces (I2C, I2S, PCM, MII, SPI, JTAG, UART) can let designer do any application as wish to.

Support MESH, OpenWrt, OpenMESH.

This product supports AP/Bridge mode. Ideal device for multi-purpose installation to share wireless connections. Supporting 64/128-bits WEP, TKIP, WPA,WPA2 and WPS, helps protect your data and privacy during transmission. This module could be mounted on system board like IPTV, STB, Media Player, Femto,XDSL, Cable Modem, Industrial PC, Ethernet Switch, Printer Server, Connected TV….

With MII, 2 Ethernet, USB, PCI-E, UART, SPI, JTAG, I2C, I2S, GPIOs. Dimension: 120mm x 80mm

Product page: AP2620-P IoT Home Automation Sever WiFi 11n MT7620 High Speed Multi-Functions Router Board

Photos

AsiaRF AWM-EVB, AWM002, AWM003

This is not a router product, but a router module designed by AsiaRF. ARM002 is a low-cost embedded UART-ETH-WIFI module (serial port - Ethernet - Wireless network). This product is an embedded module with USB, built-in TCP/IP protocol stack, serial port, Ethernet, wireless network (wifi) interface, I2S/PCM, JTAG, I2C.

This module is very small - 25mm x 35mm

Product page:

Hardware Highlights

  • Tiny size: 25mm x 35mm
  • Low operation temperature!
  • Hardware optimized!
  • Interface pins out: USB, I2C, I2S, PCM, UART, LED, RJ45 LAN ports and GPIOs
Model CPU Ram Flash Network WLAN Standard
802.11
USB Serial JTag
AWM002 RT5350@360MHz 32MB 4MB 2x100BASE-TX 802.11n/g/b 1xUSB2.0 1xuartlite + 1xuartfull YES
AWM002 RT5350@360MHz 32MB 8MB 2x100BASE-TX 802.11n/g/b 1xUSB2.0 1xuartlite + 1xuartfull YES
AWM002 RT5350@360MHz 32MB 16MB 2x100BASE-TX 802.11n/g/b 1xUSB2.0 1xuartlite + 1xuartfull YES
AWM003 RT5350@360MHz 64MB 8MB 2x100BASE-TX 802.11n/g/b 1xUSB2.0 1xuartlite + 1xuartfull YES
AWM003 RT5350@360MHz 64MB 16MB 2x100BASE-TX 802.11n/g/b 1xUSB2.0 1xuartlite + 1xuartfull YES

Compile

Follow the guide to compile Openwrt. http://wiki.openwrt.org/doc/howto/buildroot.exigence

after running make, you should have the following:

  ~/openwrt/openwrt/bin/ramips$ ls
      md5sums                                                   
      openwrt-ramips-rt305x-awm002-evb-8M-squashfs-sysupgrade.bin  
      openwrt-ramips-rt305x-uImage-initramfs.bin  
      openwrt-ramips-rt305x-vmlinux-initramfs.bin
      openwrt-ramips-rt305x-awm002-evb-4M-initramfs-uImage.bin  
      openwrt-ramips-rt305x-root.squashfs                          
      openwrt-ramips-rt305x-vmlinux.bin           
      openwrt-ramips-rt305x-vmlinux-initramfs.elf
      openwrt-ramips-rt305x-awm002-evb-8M-initramfs-uImage.bin  
      openwrt-ramips-rt305x-uImage.bin                             
      openwrt-ramips-rt305x-vmlinux.elf           
      packages

Installing on AsiaRF module via TFTP

A stock asiaRF module should have u-boot and a default linux image installed. To setup TFTPD on a debian/ubuntu system:

  apt-get install tftpd-hpa

Copy the binary you want to deploy on the asiarf into the tftp directory:

  cp openwrt-ramips-rt305x-awm002-evb-8M-squashfs-sysupgrade.bin /var/lib/tftpboot/asiarf.bin

Connect a serial cable up to the AWM002-EVB TX and RX lines. Bring up a terminal at 57600 baud. Power cycle the board and press option 2 before the boot delay expires.

  1: Load system code to SDRAM via TFTP. 
  2: Load system code then write to Flash via TFTP. 
  3: Boot system code via Flash (default).
  4: Entr boot command line interface.
  7: Load Boot Loader code then write to Flash via Serial. 
  9: Load Boot Loader code then write to Flash via TFTP. 

Option 2 will program the flash with OpenWrt.

  Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N)

Hit 'Y'

Then enter in some unused IP address on your subnet (and plug the asiaRF board into your LAN)

  Input device IP (192.168.128.33) ==:192.168.128.33
  

Enter the IP address of the tftp server:

  Input server IP (192.168.128.109) ==:192.168.128.109
  

And the name of the file you want to download and flash:

  Input Linux Kernel filename (asiarf.bin) ==:asiarf.bin

Then it will print out a lot of “##########################” while it works. Eventually (about 1 min) it will stop and reboot into openwrt.

Getting ethernet to work

See this discussion: https://lists.openwrt.org/pipermail/openwrt-devel/2013-September/021286.html

There is a problem getting ethernet to work with VLANs turned off. Use the following for `/etc/config/network` to get it working:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd59:3f8d:cb3a::/48'

    config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.85'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

    config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

    config switch
    option name 'rt305x'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'rt305x'
    option vlan '1'
    option ports '1 2 3 4 6t'

    config switch_vlan
    option device 'rt305x'
    option vlan '2'
    option ports '0  6t'

Photos

AWM-EVB

Tags

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
toh/asiarf/awm-evb.txt · Last modified: 2019/02/12 22:13 by tmomas