Dumb AP / Access Point Only

Ez a dokumentum leírja, hogyan állíthatsz be egy “csak Access Point” funkcionalítású eszközt. Az Access Point - továbbiakban AP - lehetővé teszi hogy felhasználók csatlakozhassanak az AP-hez wireless, vagy ethernet kapcsolaton keresztül, ezálltal csatlakozva a hálózathoz. Ez azt jelenti, hogy az AP nem végez útválasztást - routing -, nem nyújt DHCP támogatást, vagy egyéb funkciokat. Ez a beállíáts akkor lehet előnyös, ha már egyéb eszköz biztosítja a hálózaton ezeket a szolgáltatásokat.

A felhasználó szemszögéből ez így működik:

  • Csatlakozunk az APhez - mely wireless esetében titkosított is lehet, így jelszó szükséges.
  • Ha az életben lévő hálózati beállítások lehetővé teszik - pl MAC blacklist - hálózati hozzáférést kap a felhasználó.

Ez a szócikk nem foglalkozik a 'Static DHCP' beállítással.

A vezeték nélküli hálózat konfigurációja után elkezdődhet az AP konfigurációja a webes felületen keresztül.

  1. Lépj be a Network majd azon belül az Interfaces menübe, és válaszd ki a Lan interfészt.
  2. Állíts be egy fix címet, ami eltér a többi hálózati elem címétől, és kívül esik a DHCP tartományán (Pl. 192.168.1.1 a router, DHCP 192.168.1.100 címmel kezd, válassz egy tetszőleges IP-t .1 és .100 között például: 192.168.1.2)
  3. Görgess a lap aljára, és válaszd ki az “Ignore interface: Disable DHCP for this interface.” checkboxot.
  4. Lépj be a System, azon belül a Startap menübe, és tiltsd le a tűzfal - Firewall - automatikus indítását.
  5. Kattints a “Save and Apply” gombra. Amennyiben az eszköz ezek után nem kommunikál, indítsd újra.
  6. Csatlakozz az eszközhöz az új IP címen, majd ellenőrizd, hogy a Lan interfész beállításai megegyeznek-e a korábban beállítottakal.
  7. Ezek után csatlakoztasd az AP-t a routered egy tetszőleges portjához ethernet kábellel, és kész.

The changes below assume an OpenWrt default configuration, the relevant files are:

Edit /etc/config/network and change the interface section:

For switch-less devices, e.g. Alix Board, wr1043nd v2

On switchless devices, simply bridge all ethernet interfaces together, remove the existing WAN interface - if any.

config interface lan option type 'bridge' option ifname 'eth0 eth1' # Bridges lan and wan option proto 'dhcp' # Change as appropriate

For devices with switch and dedicated WAN, e.g. WNDR3700, WR1043ND v1, WR741ND v2.4

On devices with a separate WAN interface, bridge the LAN VLAN together with the WAN interface, remove the existing WAN interface - if any.

config interface lan option type 'bridge' option ifname 'eth0.1 eth1' # Bridges vlan 1 and wan option proto 'dhcp' # Change as appropriat

Switch configuration on WR1043ND (barrier breaker):

config switch_vlan option device 'switch0' option vlan '1' option ports '0 1 2 3 4 5t' # 1. add 0 in here #config switch_vlan # 2. comment out or delete the whole vlan 2 section # option device 'switch0' # option vlan '2' # option ports '0 5t'

For devices with switch only, e.g. WRT54GL

On devices where WAN and LAN are separated by switch config, reconfigure the LAN VLAN to cover all ports, remove the existing WAN interface and its related VLAN - if any.

config switch_vlan eth0_1 option vlan '1' option ports '0 1 2 3 4 5t' # Might vary depending on the device config interface lan option type 'bridge' option ifname 'eth0.1' option proto 'dhcp' # Change as appropriate

Edit /etc/config/wireless, and don't worry about most of it, things that might need changes are commented.

config 'wifi-device' 'radio0' option type 'mac80211' option channel '11' option macaddr '12:e4:4a:b3:83:1a' option htmode 'HT20' list ht_capab 'SHORT-GI-20' list ht_capab 'SHORT-GI-40' list ht_capab 'TX-STBC' list ht_capab 'RX-STBC1' list ht_capab 'DSSS_CCK-40' config 'wifi-iface' option device 'radio0' option network 'lan' # Set to the name of the bridged interface option mode 'ap' option ssid 'ap_myaccesspoint' option encryption 'psk2' # Change as appropriate option key 'ap_password'

If you still need dnsmasq running for something else (e.g. TFTP server) you can do:

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq restart
/etc/init.d/firewall disable
/etc/init.d/firewall stop

Reloading the network config should be enough, it should automatically restart if necessary.

/etc/init.d/network reload

If you would like your AP to receive IPv6 as a host only and not for routing you have to tell dhcp6c not to request prefix deligation. If you do not do this the AP will reject basic IPv6 addresses.

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option reqprefix no

Multicast forwarding is necessary for DLNA and UPnP clients to work properly. For example PS3, xbox, TVs and stereos use DLNA to detect, communicate with and stream audio/video over the network. Since multicasting is turned off (multicast snooping is turned on) by default in newer OpenWrt releases, it must be activated. This would forward any multicast packets to all ports allowing your TV to find your DLNA capable NAS with movies. In large networks, this could cause some overhead which may not be desirable.

Add this into /etc/rc.local

echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping

Replace br-lan with your actual bridge interface, sometimes also called br0.

This will forward all multicast packets to all ports on your bridge, making igmpproxy or udpxy proxies unnecessary.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2018/06/09 05:16
  • by tmomas