User Tools

Site Tools


faq:serial_connection_garbled_characters

Serial connection garbled characters

Issue: When connected via serial to my device, I can see only garbled output and strange characters in putty.

Example:

my▒--!#▒▒▒▒▒▒▒▒▒▒▒▒R▒▒럣▒▒▒▒▒▒E▒#7!%▒▒9▒-#-▒7!#5▒▒H▒▒▒▒▒▒▒E▒#7!%▒▒▒▒#7!%▒=▒▒▒%-57▒75▒!▒5'-%--#1▒▒R
▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒%=9▒▒s-▒S5▒▒▒▒▒▒▒▒▒▒▒ ▒▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒%=9▒▒{-'7▒W-%5▒▒▒▒▒
▒▒▒▒▒▒▒▒▒▒▒▒▒R▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒▒R▒▒뛣▒▒▒▒▒▒E▒)%!7'!=75▒7!#5▒'!=7-#1▒)5'▒%!7'5▒3▒59▒%!7'5
▒7▒▒▒▒R▒▒۟▒▒▒▒▒▒▒E▒;'=#▒▒!▒▒5/▒▒▒▒▒5#57▒;'!9)-#1▒=5▒▒R▒▒۟▒▒▒▒▒▒▒E▒;'=#▒▒!▒▒5/▒▒▒▒▒5#57▒7-=;'57▒=5▒▒R▒▒۟
▒▒▒▒▒▒▒E▒75-95▒5/▒▒▒▒5#57▒!▒%!75▒▒▒▒▒▒▒▒▒E▒75-95▒5▒▒5#57▒!▒%!75▒▒R▒▒۝▒▒▒▒▒▒▒▒▒R▒▒۝▒▒▒▒▒▒▒E▒m_▒▒▒}ww[
yacs▒cuWwuSAyo}cqu▒▒▒;'=#▒▒'-#)▒;59!%5▒=7▒5#57▒3!-#1▒=5▒▒R▒▒۝▒▒▒▒▒▒▒E▒m_▒▒▒}ww[yacs▒cuWwuSAU_▒▒▒;'=#

Root causes:

  1. Faulty GND connection
  2. Faulty other connection
  3. Wrong serial connection settings (e.g. wrong speed)
  4. Wrong voltage level (e.g. 5V i/o 3.3V)

Solutions:

  1. Make sure your connections are right, e.g. properly soldered.
  2. Try different settings, e.g. all speeds from 9600 up to 115200
  3. Use serial adapter with correct voltage level for your device

Links:

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
faq/serial_connection_garbled_characters.txt · Last modified: 2019/09/11 15:36 by tmomas