开发版本 / snapshots

开发分支可以包含正在积极开发中的实验代码,不应将其用于生产环境. Snapshot 映像可能支持其他硬件;但是,它是实验性的,被认为是不稳定的,有时无法编译.

预构建的快照映像不带有任何Web界面或GUI. 您将需要使用命令行和远程shell连接安装 → 请参阅如何安装LuCI使用SSH连接到Internet并安装Luci Web界面

  • snapshots 默认情况下不包含 LuCI GUI. 它需要由用户安装.
  • snapshots 未经测试. 只是自动构建最新的源代码和软件包. 尽管快照通常可以使用,但它们有时可能包含严重的错误, 这些错误会导致无法正确启动设备,甚至无法轻松地将其系统升级到新版本.
  • snapshots 是每天生成的, 它设置了使用opkg安装新软件包的时间限制. 由于内核版本校验和, 您只能从完全相同的snapshot版本中安装 “kmod” 内核模块和其他依赖于内核版本的模块. 因此, 刷新固件几个小时后,您可能无法再使用opkg安装新模块 (因为下一个snapshot已内置在下载存储库中并且具有不同的校验和). 请参阅下面的软件包可用时间限制.
Who What 构建频率 预期可用性 示例
Phase 1 images buildbot kmods 每日 建置后3个月 https://downloads.openwrt.org/snapshots/targets/x86/64/kmods/
Phase 1 images buildbot 定位特定的程序包 1) 每日 直到下一次构建为止2) https://downloads.openwrt.org/snapshots/targets/x86/64/packages/
Phase 2 packages buildbot 普通包装 每日 没有具体的有效期 https://downloads.openwrt.org/snapshots/packages/x86_64/
  • OpenWrt主要来源和每个软件包的最新可用版本
  • 支持自上次稳定发行分支以来已添加的新设备
  • 您绝对需要 GUI 并且您无法通过 ssh/commandline 自行安装 LuCI
  • 您对Linux完全没有经验并且不知道 ssh 是什么. 对于您和所有其他相关人员来说,引导您完成安装过程并返回库存固件很可能会很麻烦.
  • 您认为, 总是因为任何时候都需要随时拥有最新的最新软件. 可能出现的问题 (从开始预编译的snapshot 映像中的LuCI不可用) 可能使您不堪重负,并可能促使您重新安装库存固件.
  • 您期望对固件进行无误且100%有效的编译, 安装和使用. Snapshots 是实验性的, 任何时候都可能出现任何奇怪的问, 今天有效的方法, 明天不一定有效.
  • 您对Linux很有经验,并且知道如何管理任何意外的问题 (根本不启动, bootloops, 没有网络连接, …)
  • 没有其他选择,即没有其他可用的稳定版本。对于新添加的设备或支持尚不成熟的设备(称为稳定设备),可能就是这种情况.
  • 稳定版本的性能不佳,如果由于提高了稳定性而在论坛中明确建议使用snapshot,则可以提高稳定性,更好的wifi或解决的$whatever_problem.
  • 您可以在没有GUI的情况下生活,或者如果您有足够的经验自行安装LuCI.

1)
也可以包括 kmods
2)
能没有更改,因此可能会更长时间使用.
This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2021/04/17 21:40
  • by guyezi