User Tools

Site Tools


zh:releases:19.07:notes-19.07.4

OpenWrt 19.07.4 - 服务版本 - 2020 年 9 月 10 日

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.4, r11208-ce6496d796
 -----------------------------------------------------

OpenWrt社区在此非常自豪地宣布 OpenWrt 19.07 的第四个服务版本的发行,此版本增强了稳定性并增加了支持的设备。

关于 OpenWrt

OpenWrt是一个为嵌入式设备设计的一款Linux操作系统,它可以用于替换庞大数量的无线路由器 以及非网络设备的原厂固件。查看硬件支持表格获取更多 关于硬件支持的信息。如果你想知道更多关于OpenWrt项目的细节,可以查看 关于OpenWrt的页面

你可以在此下载到 OpenWrt 固件: https://downloads.openwrt.org/releases/

关于新版本和安全更新的公告

想要第一时间接收到固件更新和安全更新灯重大更改的通知吗?

我们创建了一个通知此事件的邮件列表和RSS订阅,请查看 重要更新通知 页面。

自 OpenWrt 19.07.3 的变更

仅在下面列出重要变更,详细的变更请参见 changelog-19.07.4

安全更新

提示: 软件包相关的安全修复可以直接升级对应的软件包,而不必重新安装新的固件。你可以直接使用网页界面或输入 opkg update; opkg upgrade the_package_name 升级对应软件包。

尽管如此,我们希望所有的用户在可能的情况下将设备升级至 OpenWrt 19.07.4。

主要缺陷修复

  • libubox: 回退可能会导致procd在某些设备上无法启动或重启的版本 (FS#3177)
  • musl: 修正锁同步缺陷
  • kernel: 修正硬件流量重载
  • firewall: 修正 TCP MSS 钳制只能应用于单向流量的问题 (FS#3231)

设备支持

新设备

  • 为以下 ath79 的 4/32 设备 向后移植: TP-Link TL-WR802N v1/v2, TL-WR940N v3/v4/v6, TL-WR941ND v6, TL-MR3420 v2, TL-WA701ND v1, TL-WA730RE v1, TL-WA830RE v1, TL-WA801ND v1/v3/v4, TL-WA901ND v1/v4/v5
  • 为以下 ath79 设备提供支持: TP-Link TL-WR710N v2.1

现存设备

  • 为 WNDR3700, WNDR3800 修正 wifi 范围和吞吐量 (FS#3088)
  • 修正硬件支持TP-Link TL-WR902AC v1 (FS#3118), Pirelli A226M-FWB, Linksys EA8500, brcm63xx (Huawei EchoLife HG556a, Livebox, BCM6348/BCM6358 FS#2202)
  • 修正网络挂死:所有的 ipq4018 和 ipq4019 设备,这是由于 IPv6 下硬件TCP分片有BUG导致的。
  • 修正工厂安装:Ubiquiti WA/XC、TP-Link Archer C6 v2
  • 增强SATA稳定性oxnas 设备
  • 修正USB设备检测所有的 rt305x 设备
  • 其他修正 for ELECOM WRC-1900GST and WRC-2533GST, GL.inet GL-AR150, Netgear DGND3700 v1, Netgear DGND3800B, Netgear WNR612 v2, TP-Link TL-WR802N v1/v2, TP-Link TL-MR3020, TP-Link TL-WR841ND v8, TP-Link CPE210 v3, Linksys WRT610N v2, mt7621 设备, ZyXEL P-2601HN-Fx, Astoria Networks ARV7518PW and ARV7510PW22, Arcor 802, Pogoplug v4, Fritzbox 3370, Fritzbox 7360, Fritzbox 7362, Xiaomi MiWiFi Mini, ZyXEL NBG6616, WIZnet WizFi630S, ClearFog Base/Pro, Arduino Yun, UniElec U7623
  • 默认为 TP-Link 的 4MB 设备禁用构建,因其无法放下完整的默认软件包。(这些设备在之前的 19.07.x 版本也无法通过编译)

其他修复增强

  • 构建: 现在会创建一个包含镜像信息的JSON文件了。这将对于固件助手等一系列需要读取镜像列表的工具很有用 (TODO: 在这里放个文档)
  • wolfssl: 修正一些非常耗时并且会导致 WPA3/SAE 超时的运算。
  • 修正使用 broadcom-wl 调用 /etc/init.d/network 时出现的锁问题

查看 此页面 获取完整的修复列表。

LuCI 管理界面

  • 在安装 LuCI 软件包后重载 ACL 规则
  • 倒退渲染方式,以修正一项菜单渲染中的问题,其表现形式是在安装完新的软件包后需要注销/重启设备才能让新的菜单显示出来 (GH#4077)
  • 允许主题修改 sysauth.htm 模板以实现自定义鉴权的功能
  • weblate 更新翻译
  • 更多 修正与变更……

核心部件

  • 将 Linux 内核从 4.14.180 更新至 4.14.195
  • 将 mac80211 从 4.19.120 更新至 4.19.137
  • 将 mbedtls 从 2.16.6 更新至 2.16.8
  • 将 wolfssl 从 4.3.0 更新至 4.5.0
  • 将 wireguard 更新至 1.0.20200611
  • 更新 ath10k-ct-firmware

降级

暂时无已知降级。

已知问题

  • 迁移至 ath79: 一些受 ar71xx 支持的设备还未受 ath79 支持:这需要社区一起努力。希望你能够帮助我们将这些设备移植到 ath79,使其在未来的版本中受支持。
  • 设备支持: 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 设备支持: 对应的,一些只有 4MB 存储空间的设备的镜像将不再编译
  • 设备支持: 部分使用了atheros交换机的ath79设备(如TL-WR841N)的以太网连接可能会出现不稳定: FS#2216, FS#2730
  • LuCI 管理界面: 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复

也可以查看: openwrt-19.07 的活动BUG报告

升级至 OpenWrt 19.07.4

可以使用 sysupgrade 将 OpenWrt 19.07.x 升级: 从网页界面升级从命令行升级

使用系统升级页面可以在保留原有配置的情况下顺利的将 OpenWrt 18.06 升级到 OpenWrt 19.07。 但是无论如何,我们还是建议在升级到 OpenWrt 19.07 之前,创建一个配置文件的备份以防万一。

OpenWrt 19.07 功能亮点

在这个版本中,OpenWrt 项目将所有的设备的内核都升级到了统一的版本。这个内核还将持续的完善中,为更多的设备带来支持。 这个版本引入了对 ath79 系列设备的支持,以及对 WPA3 协议的支持。

从 ar71xx 系列向 ath79 系列转移

此版本为 ar71xx 系列的基于设备树的继任者——ath79 系列——提供了初始支持。在 19.07 版本中,两个版本都会将继续构建,但我们建议在可能的情况下,切换到新的 ath79 系列。后续的 OpenWrt 可能会放弃对 ar71xx 的支持。

请在升级前阅读下面的已知问题章节。

WPA3 支持

19.07 版本带来了初始的 WPA3 支持,但在默认情况不启用。若需要启用 WPA3 功能,需要安装下面的软件包:对于一个 WPA3 接入点 (AP),需要安装 hostapd-openssl 软件包;对于一个 WPA3 路由器(Station),需要安装 wpa-supplicant-openssl(仅Station模式)或 wpad-openssl (AP + station)。因这些软件包的体积过大,无法默认安装,并且也不可能在存储空间小于8MB的设备上安装。

注意,许多现存的设备可能永远不会支持 WPA3,某些支持 WPA2 的设备也可能无法连接到一个配置为 WPA2 + WPA3 混合模式的接入点。如果你需要报告关于 WPA3 的问题,请先确保这些问题不是客户端导致的。

要将你的设备配置为 WPA3 接入点,请参考 wpa_modes

LuCI 网页界面的客户端渲染模式

OpenWrt 内置的新版本的 LuCI,实现了名为“客户端渲染”的技术。这项技术将部分渲染代码从服务端(Lua代码)移动到浏览器(JS代码),能够提高路由器的性能。

但 LuCI 生态系统非常复杂,不是所有的 LuCI 软件都能够兼容此项改动。如果你遇到了因 cbi.lua 缺失造成的崩溃,请尝试安装 luci-compat 软件包。

如果 LuCI 加载十分缓慢,请尝试安装 ​uhttpd-mod-ubus 软件包,关闭并重新打开管理页面。

通过这项技术,LuCI 内的 Lua 代码量减少了,LuCI 的性能也在没有完全重写的情况下接近 LuCI2 的性能。

已知问题

这里列出了一些 19.07.0 中的一些已知问题:

  • ar71xx 系列和 ath79 系列的相互升级当前不受官方支持,建议为所有被 ar71xxath79 支持的设备手工重新安装。
  • 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复
  • 可能的 5GHz Wi-Fi 信号问题。如果你遇到了这类问题,请查看现有的 BUG 报告 (FS#2679, FS#2563, FS#2682) 或 新增一个BUG报告。请确保这些问题不是由 WPA3 导致的。如果你正在使用 WPA3 并出现了问题,请尝试恢复到升级 19.07 之前的配置。
This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
zh/releases/19.07/notes-19.07.4.txt · Last modified: 2020/09/20 00:47 by jiangming1399