User Tools

Site Tools


zh:releases:19.07:notes-19.07.3

OpenWrt 19.07.3 - 服务版本 - 2020 年 5 月 20 日

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------

OpenWrt社区在此非常自豪地宣布 OpenWrt 19.07 的第三个服务版本的发行。

关于 OpenWrt

OpenWrt是一个为嵌入式设备设计的一款Linux操作系统,它可以用于替换庞大数量的无线路由器 以及非网络设备的原厂固件。查看硬件支持表格获取更多 关于硬件支持的信息。如果你想知道更多关于OpenWrt项目的细节,可以查看 关于OpenWrt的页面

你可以在此下载到 OpenWrt 固件: https://downloads.openwrt.org/releases/

自 OpenWrt 19.07.2 的变更

仅在下面列出重要变更,详细的变更请参见 changelog-19.07.3

安全更新

提示: 软件包相关的安全修复可以直接升级对应的软件包,而不必重新安装新的固件。你可以直接使用网页界面或输入 opkg update; opkg upgrade the_package_name 升级对应软件包。

尽管如此,我们希望所有的用户在可能的情况下将设备升级至 OpenWrt 19.07.3。

缺陷修复

  • opkg: 降低了内存占用。这修复了在运行 opkg update 出现的内存不足的问题,参见 FS#2734
  • Services:rpcd 停止或崩溃后自动重启
  • Services: 修正 dnsmasq 中处理 DNSSEC+NTP 相互依赖的变通方法

设备支持

新设备

  • 为 Luxul XAP-1610 和 Luxul XWR-3150 添加支持
  • 为更多设备提供 ath79 支持: TP-Link TL-WR740N v5, TP-Link Archer C60 v3, TP-Link WDR3500 v1, TP-Link TL-WA850RE v1, TP-Link TL-WA860RE v1, TP-Link TL-WDR4310 v1

现存设备

  • 修复下列设备的 ar71xx 至 ath79 系统更新: TP-Link TL-WA901ND v2, TP-Link TL-WDR4900 v2, TP-Link TL-WR810N v1/v2, TP-Link TL-WR842N/ND v1, TP-Link TL-WR740N v1/v2/v3/v4/v5, TP-Link TL-WR741N/ND v1/v2, TP-Link TL-WR743ND v1, TP-Link TL-WR841N/ND v5/v6, TP-Link TL-WR941N/ND v2/v3/v4
  • 下列设备的修复和增强: AVM FRITZ Repeater 450E, TP-Link Archer C7, TP-Link Archer C60 v1/v2, TP-Link TL-MR3040 v2, GL.iNet GL-AR750S, Mikrotik RB951G-2HnD, ZyXEL Keenetic, Embedded Wireless Dorin, Traverse LS1043, SolidRun ClearFog
  • 修正在部分 mvebu (Marvell Armada 370 CPU) 和 tegra2 设备上出现的 “Illegal instruction” 问题: Globalscale Mirabox, CompuLab TrimSlice, 以及其他可能的设备
  • 修正华硕部分 bcm53xx 设备系统镜像的问题
  • 修正 OXNAS 设备在重启后死机的问题
  • 修正使用 ar8229/ar8236 交换机芯片的设备中,多播数据没有正确到达CPU的问题 (FS#2848)
  • 修正 ZBT MT7621 系列 256M 设备的支持
  • 增强 Mikrotik 设备的无线校准数据 (ath9k/ath10k) 提取过程
  • 优化 bcm53xx 上的系统更新步骤以节约 tmpfs 上的空间

其他修复增强

  • 服务: 为 dnsmasq 添加了 scriptarp 选项,允许在 arp-addarp-del 事件发生时运行存放于 /etc/hotplug.d/neigh/ 的脚本
  • 内核: 为非以太网设备向后移植了内存用尽的修复
  • 构建: 修正使用 GCC 10 构建的问题

查看 此页面 获取完整的修复列表。

LuCI 管理界面

  • 大幅度提升了 LuCI 使用 HTTPS 的性能 (查看 uhttpd 提交获取详细信息)
  • 允许将 Wi-Fi 设置为 WPA3 模式 (#3363)
  • 为翻译引入了复数形式和上下文支持,提高了翻译质量
  • weblate 更新翻译
  • 更多修正和变更……

核心部件

  • 将 Linux 内核从 4.14.171 更新至 4.14.180
  • 将 mac80211 更新至 4.19.120
  • mt76 Wi-Fi 驱动更新至最新版本
  • 更新 wireless-regdb
  • 将 fstools 更新至最新版本
  • 将 openssl 更新至 1.1.1g
  • 将 mbedtls 更新至 2.16.6

降级

  • libubox 降级: procd 可能因libnbox降级而无法启动或重新启动某些服务 (相关帖子)

已知问题

  • 迁移至 ath79: 一些受 ar71xx 支持的设备还未受 ath79 支持:这需要社区一起努力。希望你能够帮助我们将这些设备移植到 ath79,使其在未来的版本中受支持。
  • 设备支持: 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 设备支持: 部分使用了atheros交换机的ath79设备(如TL-WR841N)的以太网连接可能会出现不稳定: FS#2216, FS#2730
  • LuCI 管理界面: 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复
  • LuCI 管理界面: 由于菜单渲染方式的变更,在添加新的菜单项后可能需要重新登出/登录管理界面或重启设备才能正常显示 (参见 GH#4077)

也可以查看: openwrt-19.07 的活动BUG报告

升级至 OpenWrt 19.07.3

可以使用 sysupgrade 将 OpenWrt 19.07.x 升级: 从网页界面升级从命令行升级

使用系统升级页面可以在保留原有配置的情况下顺利的将 OpenWrt 18.06 升级到 OpenWrt 19.07。 但是无论如何,我们还是建议在升级到 OpenWrt 19.07 之前,创建一个配置文件的备份以防万一。

OpenWrt 19.07 功能亮点

在这个版本中,OpenWrt 项目将所有的设备的内核都升级到了统一的版本。这个内核还将持续的完善中,为更多的设备带来支持。 这个版本引入了对 ath79 系列设备的支持,以及对 WPA3 协议的支持。

从 ar71xx 系列向 ath79 系列转移

此版本为 ar71xx 系列的基于设备树的继任者——ath79 系列——提供了初始支持。在 19.07 版本中,两个版本都会将继续构建,但我们建议在可能的情况下,切换到新的 ath79 系列。后续的 OpenWrt 可能会放弃对 ar71xx 的支持。

请在升级前阅读下面的已知问题章节。

WPA3 支持

19.07 版本带来了初始的 WPA3 支持,但在默认情况不启用。若需要启用 WPA3 功能,需要安装下面的软件包:对于一个 WPA3 接入点 (AP),需要安装 hostapd-openssl 软件包;对于一个 WPA3 路由器(Station),需要安装 wpa-supplicant-openssl(仅Station模式)或 wpad-openssl (AP + station)。因这些软件包的体积过大,无法默认安装,并且也不可能在存储空间小于8MB的设备上安装。

注意,许多现存的设备可能永远不会支持 WPA3,某些支持 WPA2 的设备也可能无法连接到一个配置为 WPA2 + WPA3 混合模式的接入点。如果你需要报告关于 WPA3 的问题,请先确保这些问题不是客户端导致的。

要将你的设备配置为 WPA3 接入点,请参考 wpa_modes

LuCI 网页界面的客户端渲染模式

OpenWrt 内置的新版本的 LuCI,实现了名为“客户端渲染”的技术。这项技术将部分渲染代码从服务端(Lua代码)移动到浏览器(JS代码),能够提高路由器的性能。

但 LuCI 生态系统非常复杂,不是所有的 LuCI 软件都能够兼容此项改动。如果你遇到了因 cbi.lua 缺失造成的崩溃,请尝试安装 luci-compat 软件包。

如果 LuCI 加载十分缓慢,请尝试安装 ​uhttpd-mod-ubus 软件包,关闭并重新打开管理页面。

通过这项技术,LuCI 内的 Lua 代码量减少了,LuCI 的性能也在没有完全重写的情况下接近 LuCI2 的性能。

已知问题

这里列出了一些 19.07.0 中的一些已知问题:

  • ar71xx 系列和 ath79 系列的相互升级当前不受官方支持,建议为所有被 ar71xxath79 支持的设备手工重新安装。
  • 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复
  • 可能的 5GHz Wi-Fi 信号问题。如果你遇到了这类问题,请查看现有的 BUG 报告 (FS#2679, FS#2563, FS#2682) 或 新增一个BUG报告。请确保这些问题不是由 WPA3 导致的。如果你正在使用 WPA3 并出现了问题,请尝试恢复到升级 19.07 之前的配置。
This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
zh/releases/19.07/notes-19.07.3.txt · Last modified: 2020/06/25 11:31 by jiangming1399