User Tools

Site Tools


zh:releases:19.07:notes-19.07.2

OpenWrt 19.07.2 - 服务版本 - 2020 年 3 月 6 日

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------

OpenWrt社区在此非常自豪地宣布 OpenWrt 19.07 的第二个服务版本的发行。 此版本着重于安全修复和新增设备支持。主要修复了 ppp 中的安全问题,以及为ar71xx 向 ath79 设备迁移提供了更好的支持。

关于 OpenWrt

OpenWrt是一个为嵌入式设备设计的一款Linux操作系统,它可以用于替换庞大数量的无线路由器 以及非网络设备的原厂固件。查看硬件支持表格获取更多 关于硬件支持的信息。如果你想知道更多关于OpenWrt项目的细节,可以查看 关于OpenWrt的页面

你可以在此下载到 OpenWrt 固件: https://downloads.openwrt.org/releases/

自 OpenWrt 19.07.1 的变更

仅在下面列出重要变更,详细的变更请参见 changelog-19.07.2

安全更新

缺陷修复和增强

设备支持

  • 修复下列设备的 ar71xx 至 ath79 系统更新: fritz300e
  • 为所有的 ar93xx/qca95xx 设备在 ar71xx 至 ath79 迁移过程中保存无线网络配置
  • 为下列设备添加了 ath79 的支持: Ubiquiti Nanostation Loco M (XM & XW), Picostation M (XM)
  • 为 Luxul ABR-4500 和 XBR-4500 添加了支持
  • 修复了 ipq806x 中的 CPU 性能问题
  • 重新为 D-Link DIR-645 启用镜像生成
  • 下列设备的修复和增强: TP-Link TL-MR3020 v3, TL-WA801ND v5, TL-WR841N/ND v8, TL-WR842N v2, WDR3600/WDR4300, Mikrotik RB912UAG-5HPnD r2, Netis WF-2881

LuCI 管理界面

  • uhttpd: 提高了在HTTPS高负载情况下的稳定性(可能未修复完成)
  • 修复了 nginx 的支持
  • weblate 更新翻译

核心部件

  • 将 Linux 内核从 4.14.167 更新至 4.14.171
  • brcmmac80211 升级到最新的 5.6

已知问题

  • 迁移至 ath79: 一些受 ar71xx 支持的设备还未受 ath79 支持:这需要社区一起努力。希望你能够帮助我们将这些设备移植到 ath79,使其在未来的版本中受支持。
  • 设备支持: 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 设备支持: 部分使用了atheros交换机的ath79设备(如TL-WR841N)的以太网连接可能会出现不稳定: FS#2216, FS#2730
  • LuCI 管理界面: 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复

也可以查看: openwrt-19.07 的活动BUG报告

升级至 OpenWrt 19.07.2

可以使用 sysupgrade 将 OpenWrt 19.07.x 升级: 从网页界面升级从命令行升级

使用系统升级页面可以在保留原有配置的情况下顺利的将 OpenWrt 18.06 升级到 OpenWrt 19.07。 但是无论如何,我们还是建议在升级到 OpenWrt 19.07 之前,创建一个配置文件的备份以防万一。

OpenWrt 19.07 功能亮点

在这个版本中,OpenWrt 项目将所有的设备的内核都升级到了统一的版本。这个内核还将持续的完善中,为更多的设备带来支持。 这个版本引入了对 ath79 系列设备的支持,以及对 WPA3 协议的支持。

从 ar71xx 系列向 ath79 系列转移

此版本为 ar71xx 系列的基于设备树的继任者——ath79 系列——提供了初始支持。在 19.07 版本中,两个版本都会将继续构建,但我们建议在可能的情况下,切换到新的 ath79 系列。后续的 OpenWrt 可能会放弃对 ar71xx 的支持。

请在升级前阅读下面的已知问题章节。

WPA3 支持

19.07 版本带来了初始的 WPA3 支持,但在默认情况不启用。若需要启用 WPA3 功能,需要安装下面的软件包:对于一个 WPA3 接入点 (AP),需要安装 hostapd-openssl 软件包;对于一个 WPA3 路由器(Station),需要安装 wpa-supplicant-openssl(仅Station模式)或 wpad-openssl (AP + station)。因这些软件包的体积过大,无法默认安装,并且也不可能在存储空间小于8MB的设备上安装。

注意,许多现存的设备可能永远不会支持 WPA3,某些支持 WPA2 的设备也可能无法连接到一个配置为 WPA2 + WPA3 混合模式的接入点。如果你需要报告关于 WPA3 的问题,请先确保这些问题不是客户端导致的。

要将你的设备配置为 WPA3 接入点,请参考 wpa_modes

LuCI 网页界面的客户端渲染模式

OpenWrt 内置的新版本的 LuCI,实现了名为“客户端渲染”的技术。这项技术将部分渲染代码从服务端(Lua代码)移动到浏览器(JS代码),能够提高路由器的性能。

但 LuCI 生态系统非常复杂,不是所有的 LuCI 软件都能够兼容此项改动。如果你遇到了因 cbi.lua 缺失造成的崩溃,请尝试安装 luci-compat 软件包。

如果 LuCI 加载十分缓慢,请尝试安装 ​uhttpd-mod-ubus 软件包,关闭并重新打开管理页面。

通过这项技术,LuCI 内的 Lua 代码量减少了,LuCI 的性能也在没有完全重写的情况下接近 LuCI2 的性能。

已知问题

这里列出了一些 19.07.0 中的一些已知问题:

  • ar71xx 系列和 ath79 系列的相互升级当前不受官方支持,建议为所有被 ar71xxath79 支持的设备手工重新安装。
  • 某些设备的镜像过大,以至于无法保存 Overlay 分区的数据,这些设备的配置会在重启后丢失。如果你遇到了此类问题,请在这个贴子汇报你的设备型号,并考虑降级到 OpenWrt 18.06 或使用 Image Builder 构建一个较小的镜像。
  • 一些的 GUI 软件包可能出现丢失 “cbi.lua” 的问题,安装 luci-compat 软件包可以修复
  • 可能的 5GHz Wi-Fi 信号问题。如果你遇到了这类问题,请查看现有的 BUG 报告 (FS#2679, FS#2563, FS#2682) 或 新增一个BUG报告。请确保这些问题不是由 WPA3 导致的。如果你正在使用 WPA3 并出现了问题,请尝试恢复到升级 19.07 之前的配置。
This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
zh/releases/19.07/notes-19.07.2.txt · Last modified: 2020/03/12 01:03 by jiangming1399