ZyXEL NBG6617

This page is a work in progress.

The NBG6617 is an entry-level two-stream 802.11ac device and can be easily flashed with OpenWrt from stock firmware.

So far, there is only one hardware revision of the ZyXEL NBG6617.

Version Notes Links
v1 Support was introduced with commit 82618062cf. OpenWrt SoC documentation
Ver CPU Ram Flash Network Wireless USB 3.0 Serial JTag Wiki FCC
v1 Qualcomm IPQ4018 4x 638 MHz 256 MiB 32 MiB QCA8075 1 WAN + 4x LAN (GBit) IPQ4018 [bgn 2×2:2] + IPQ4018 [an+ac 2×2:2] Yes Yes ? here here

Only stable releases are listed in the datatable. The links to the binaries built off the master tree below can be removed once 19.0x gets released.

Install OpenWrt (generic explanation)

The OpenWrt factory image can be flashed through the ZyXEL web interface. There is no need to rename the binary.

Note: The OpenWrt snapshot comes without a preinstalled web interface. You'll have to connect with ssh to the device for administration and to install the web interface if required.

  • Download current OpenWrt snapshot factory firmware from the download section
  • Open web interface of the router (http://192.168.1.1) and login
  • Click Expert Mode, Maintenance, Firmware Upgrade
  • Select Choose File and upload the previously downloaded OpenWrt firmware
  • Wait for the reboot (some minutes)
  • Ssh to root@192.168.1.1

See generic TFTP flashing instructions for general information. The git commit message contains the necessary information specific to the NBG6617.

  • Set your computer to a static 192.168.1.99 IP.
  • Configure a TFTP server as per the instructions above.
  • Place the factory image in the TFTP server root directory and name it 'ras.bin'.
  • Boot the device while holding the WPS button on the top for 30 seconds.
  • The flash will take its time so give your device some time.
  • Once the USB and WPS LEDs start flashing, reboot the NBG6617 so it can boot into OpenWrt.

Specific values needed for tftp

FIXME Enter values for “FILL-IN” below

Bootloader TFTP server IPv4 address 192.168.1.99
Firmware tftp image Needs to be named 'ras.bin.'
TFTP transfer window FILL-IN seconds
TFTP window start approximately FILL-IN seconds after power on

generic.sysupgrade

FIXME These are generic instructions. Update with your router's specifics.

  • Browse to http://192.168.1.1/cgi-bin/luci/mini/system/upgrade/ LuCI Upgrade URL
  • Upload image file for sysupgrade to LuCI
  • Wait for reboot

If you don't have a GUI (LuCI) available, you can alternatively upgrade via the command line. There are two command line methods for upgrading:

  • sysupgrade
  • mtd

Note: It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

sysupgrade

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

mtd

If sysupgrade does not support this router, use mtd.

  • Login as root via SSH on 192.168.1.1, then enter the following commands:
cd /tmp
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
mtd write /tmp/xxx.abc linux && reboot

generic.debrick

failsafe_and_factory_reset

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN & WiFi 192.168.1.1/24
eth0 LAN ports (1 to 4) 192.168.1.1/24
eth1 WAN port DHCP
wlan0 WiFi b/g/n Disabled
wlan1 WiFi a/n/ac Disabled

Note: The switch port numbers are inverted compared to what's printed on the ports outside. WAN is on eth1. The CPU is on switch port 0 and is untagged by default.

Port Switch port (internal)
LAN 1 4
LAN 2 3
LAN 3 2
LAN 4 1
CPU 0

eth1 is “hard wired” to port 5 with vid 2. To get multiple vlans working we need to declare vlan 2 in /etc/config/network containing '0t 5' ports. Then we can e.g. bridge a LAN port to WAN. Note that using eth0.2, eth0.1, won't work. Bridging in vlan setup is sufficient.

Example: LAN 4 bridged to WAN

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 5'

hardware.button on howto use and configure the hardware button(s). Here, we merely name the buttons, so we can use them in the above Howto.

The ZyXEL NBG6617 has the following buttons:

BUTTON Event
Reset reset
WPS wps
Wi-Fi switch rfkill

FIXME Find out flash layout, then add the flash layout table here (copy, paste, modify the example).

Please check out the article Flash layout. It contains examples and explanations that describe how to document the flash layout.

Front:
Insert photo of front of the casing

Back:
Insert photo of back of the casing

Backside label:
Insert photo of backside label

Note: This will void your warranty!

- 1. Remove the 4 rubber feet at the back
- 2. Unscrew the 4 screws
- 3. Pry apart the upper side of the case, start at the upper side of the device eg. between the antenna and the usb port

Main PCB:
https://i.imgur.com/D9gwHmb.jpg

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device:

Photo of PCB with markings for serial port: https://i.imgur.com/3zND1hW.png

Serial connection parameters
for ZyXEL NBG6617
115200, 8N1

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device:
Insert photo of PCB with markings for JTAG port

COPY HERE THE BOOTLOG WITH THE ORIGINAL FIRMWARE


[ 0.000000] Booting Linux on physical CPU 0x0 [ 0.000000] Linux version 4.14.94 (builder@buster) (gcc version 7.4.0 (OpenWrt GCC 7.4.0 r9086+30-8c9b182db6)) #0 SMP Mon Jan 21 17:56:39 2019 [ 0.000000] CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d [ 0.000000] CPU: div instructions available: patching division code [ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache [ 0.000000] OF: fdt: Machine model: ZyXEL NBG6617 [ 0.000000] Memory policy: Data cache writealloc [ 0.000000] On node 0 totalpages: 65024 [ 0.000000] free_area_init_node: node 0, pgdat c0b2e240, node_mem_map cfdf9000 [ 0.000000] Normal zone: 512 pages used for memmap [ 0.000000] Normal zone: 0 pages reserved [ 0.000000] Normal zone: 65024 pages, LIFO batch:15 [ 0.000000] random: get_random_bytes called from start_kernel+0x8c/0x3d4 with crng_init=0 [ 0.000000] percpu: Embedded 15 pages/cpu @cfdad000 s30312 r8192 d22936 u61440 [ 0.000000] pcpu-alloc: s30312 r8192 d22936 u61440 alloc=15*4096 [ 0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 [ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 64512 [ 0.000000] Kernel command line: board=NBG6617 root=mtd:rootfs zld_ver=2.03 mtdparts=spi0.0:0x60000@0x60000(0:QSEE)ro,0x80000@0xE0000(u-boot)ro,0x10000(env)ro,0x10000(0:ART)ro,0x400000(HLOS),0x10000(dualflag),0x10000(header),0x100000(romd),0x100000(rootfs_data),0x1860000(rootfs) mtdparts= root=31:13 [ 0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes) [ 0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes) [ 0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes) [ 0.000000] Memory: 241652K/260096K available (4662K kernel code, 186K rwdata, 1884K rodata, 1024K init, 7438K bss, 18444K reserved, 0K cma-reserved, 0K highmem) [ 0.000000] Virtual kernel memory layout:

                 vector  : 0xffff0000 - 0xffff1000   (   4 kB)
                 fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
                 vmalloc : 0xd0800000 - 0xff800000   ( 752 MB)
                 lowmem  : 0xc0000000 - 0xd0000000   ( 256 MB)
                 pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
                 modules : 0xbf000000 - 0xbfe00000   (  14 MB)
                   .text : 0xc0208000 - 0xc078d978   (5655 kB)
                   .init : 0xc0a00000 - 0xc0b00000   (1024 kB)
                   .data : 0xc0b00000 - 0xc0b2ebc0   ( 187 kB)
                    .bss : 0xc0b30000 - 0xc1273988   (7439 kB)

[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1 [ 0.000000] Running RCU self tests [ 0.000000] Hierarchical RCU implementation. [ 0.000000] RCU lockdep checking is enabled. [ 0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16 [ 0.000000] arch_timer: cp15 timer(s) running at 48.00MHz (virt). [ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0xb11fd3bfb, max_idle_ns: 440795203732 ns [ 0.000009] sched_clock: 56 bits at 48MHz, resolution 20ns, wraps every 4398046511096ns [ 0.000035] Switching to timer-based delay loop, resolution 20ns [ 0.000346] Lock dependency validator: Copyright © 2006 Red Hat, Inc., Ingo Molnar [ 0.000400] ... MAX_LOCKDEP_SUBCLASSES: 8 [ 0.000419] ... MAX_LOCK_DEPTH: 48 [ 0.000438] ... MAX_LOCKDEP_KEYS: 8191 [ 0.000457] ... CLASSHASH_SIZE: 4096 [ 0.000476] ... MAX_LOCKDEP_ENTRIES: 32768 [ 0.000496] ... MAX_LOCKDEP_CHAINS: 65536 [ 0.000514] ... CHAINHASH_SIZE: 32768 [ 0.000534] memory used by lock dependency info: 4655 kB [ 0.000553] per task-struct memory footprint: 1536 bytes [ 0.000624] Calibrating delay loop (skipped), value calculated using timer frequency.. 96.00 BogoMIPS (lpj=480000) [ 0.000662] pid_max: default: 32768 minimum: 301 [ 0.000978] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.001008] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.003443] CPU: Testing write buffer coherency: ok [ 0.006103] Setting up static identity map for 0x80300000 - 0x80300060 [ 0.006644] Hierarchical SRCU implementation. [ 0.008405] smp: Bringing up secondary CPUs ... [ 0.015278] smp: Brought up 1 node, 4 CPUs [ 0.015314] SMP: Total of 4 processors activated (384.00 BogoMIPS). [ 0.015335] CPU: All CPU(s) started in SVC mode. [ 0.029035] VFP support v0.3: implementor 41 architecture 2 part 30 variant 7 rev 5 [ 0.031292] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns [ 0.031368] futex hash table entries: 1024 (order: 4, 65536 bytes) [ 0.031841] pinctrl core: initialized pinctrl subsystem [ 0.036035] NET: Registered protocol family 16 [ 0.036809] DMA: preallocated 256 KiB pool for atomic coherent allocations [ 0.039511] cpuidle: using governor ladder [ 0.039721] cpuidle: using governor menu [ 0.085392] usbcore: registered new interface driver usbfs [ 0.085604] usbcore: registered new interface driver hub [ 0.085845] usbcore: registered new device driver usb [ 0.085946] pps_core: LinuxPPS API ver. 1 registered [ 0.085969] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti giometti@linux.it [ 0.086025] PTP clock support registered [ 0.089632] clocksource: Switched to clocksource arch_sys_counter [ 0.092722] NET: Registered protocol family 2 [ 0.094177] TCP established hash table entries: 2048 (order: 1, 8192 bytes) [ 0.094256] TCP bind hash table entries: 2048 (order: 4, 73728 bytes) [ 0.094580] TCP: Hash tables configured (established 2048 bind 2048) [ 0.095039] UDP hash table entries: 256 (order: 2, 20480 bytes) [ 0.095171] UDP-Lite hash table entries: 256 (order: 2, 20480 bytes) [ 0.095701] NET: Registered protocol family 1 [ 0.095785] PCI: CLS 0 bytes, default 64 [ 0.099137] No memory allocated for crashlog [ 0.099540] workingset: timestamp_bits=30 max_order=16 bucket_order=0 [ 0.109660] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.109694] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc. [ 0.121826] io scheduler noop registered [ 0.121864] io scheduler deadline registered (default) [ 0.128424] bam-dma-engine 8e04000.dma: num-channels unspecified in dt [ 0.128479] bam-dma-engine 8e04000.dma: num-ees unspecified in dt [ 0.130303] tcsr 1949000.tcsr: setting wifi_glb_cfg = 41000000 [ 0.130502] tcsr 194b000.tcsr: setting usb hs phy mode select = e700e7 [ 0.130685] tcsr 1953000.ess_tcsr: setting ess interface select = 0 [ 0.130866] tcsr 1957000.tcsr: setting wifi_noc_memtype_m0_m2 = 2222222 [ 0.131516] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled [ 0.133324] msm_serial 78af000.serial: msm_serial: detected port #0 [ 0.133421] msm_serial 78af000.serial: uartclk = 1843200 [ 0.133656] 78af000.serial: ttyMSM0 at MMIO 0x78af000 (irq = 25, base_baud = 115200) is a MSM [ 0.133918] msm_serial: console setup on port #0 [ 0.719601] console [ttyMSM0] enabled [ 0.724623] msm_serial: driver initialized [ 0.739622] loop: module loaded [ 0.742382] spi_qup 78b5000.spi: IN:block:16, fifo:64, OUT:block:16, fifo:64 [ 0.748104] m25p80 spi0.0: mx25l25635f (32768 Kbytes) [ 0.749090] mtd: no mtd-id [ 0.754156] 14 fixed-partitions partitions found on MTD device spi0.0 [ 0.756433] Creating 14 MTD partitions on “spi0.0”: [ 0.762997] 0x000000000000-0x000000040000 : “SBL1” [ 0.770841] 0x000000040000-0x000000060000 : “MIBIB” [ 0.774053] 0x000000060000-0x0000000c0000 : “QSEE” [ 0.778804] 0x0000000c0000-0x0000000d0000 : “CDT” [ 0.783753] 0x0000000d0000-0x0000000e0000 : “DDRPARAMS” [ 0.788445] 0x0000000e0000-0x000000160000 : “APPSBL” [ 0.793533] 0x000000160000-0x000000170000 : “APPSBLENV” [ 0.798726] 0x000000170000-0x000000180000 : “ART” [ 0.803706] 0x000000180000-0x000000580000 : “kernel” [ 0.808438] 0x000000580000-0x000000590000 : “dualflag” [ 0.813603] 0x000000590000-0x0000005a0000 : “header” [ 0.818451] 0x0000005a0000-0x0000006a0000 : “romd” [ 0.823727] 0x0000006a0000-0x0000007a0000 : “not_root_data” [ 0.828175] 0x0000007a0000-0x000002000000 : “rootfs” [ 0.833676] mtd: device 13 (rootfs) set to be root filesystem [ 0.838212] 1 squashfs-split partitions found on MTD device rootfs [ 0.843061] 0x000000d90000-0x000002000000 : “rootfs_data” [ 0.852876] libphy: ipq40xx_mdio: probed [ 0.890589] ESS reset ok! [ 0.923617] ESS reset ok! [ 1.360510] libphy: Fixed MDIO Bus: probed [ 1.364631] EDMA using MAC@ - using [ 1.364656] 02:cb:a4:bf:97:1a [ 1.471100] i2c /dev entries driver [ 1.505321] NET: Registered protocol family 10 [ 1.509771] Segment Routing with IPv6 [ 1.510002] NET: Registered protocol family 17 [ 1.513930] 8021q: 802.1Q VLAN Support v1.8 [ 1.517099] Registering SWP/SWPB emulation handler [ 1.566164] hctosys: unable to open rtc device (rtc0) [ 1.582501] VFS: Mounted root (squashfs filesystem) readonly on device 31:13. [ 1.585683] Freeing unused kernel memory: 1024K [ 1.719642] random: fast init done [ 2.526487] init: Console is alive [ 2.527464] init: - watchdog - [ 5.253283] kmodloader: loading kernel modules from /etc/modules-boot.d/* [ 5.767756] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller [ 5.768370] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1 [ 5.772790] xhci-hcd xhci-hcd.0.auto: hcc params 0x0228f665 hci version 0x100 quirks 0x0000000002010010 [ 5.779899] xhci-hcd xhci-hcd.0.auto: irq 95, io mem 0x08a00000 [ 5.793062] hub 1-0:1.0: USB hub found [ 5.795364] hub 1-0:1.0: 1 port detected [ 5.800986] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller [ 5.802923] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2 [ 5.808202] xhci-hcd xhci-hcd.0.auto: Host supports USB 3.0 SuperSpeed [ 5.816339] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM. [ 5.824406] hub 2-0:1.0: USB hub found [ 5.830939] hub 2-0:1.0: 1 port detected [ 5.835307] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller [ 5.838353] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 3 [ 5.844094] xhci-hcd xhci-hcd.1.auto: hcc params 0x0220f665 hci version 0x100 quirks 0x0000000002010010 [ 5.851341] xhci-hcd xhci-hcd.1.auto: irq 96, io mem 0x06000000 [ 5.862181] hub 3-0:1.0: USB hub found [ 5.866560] hub 3-0:1.0: 1 port detected [ 5.871125] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller [ 5.874361] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 4 [ 5.879684] xhci-hcd xhci-hcd.1.auto: Host supports USB 3.0 SuperSpeed [ 5.887477] usb usb4: We don't know the algorithms for LPM for this host, disabling LPM. [ 5.895260] hub 4-0:1.0: USB hub found [ 5.902251] hub 4-0:1.0: config failed, hub doesn't have any ports! (err -19) [ 5.911540] kmodloader: done loading kernel modules from /etc/modules-boot.d/* [ 5.920400] init: - preinit - [ 7.063244] random: procd: uninitialized urandom read (4 bytes read) [ 10.398354] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000 [ 10.403061] jffs2_build_filesystem(): unlocking the mtd device... [ 10.403085] done. [ 10.412554] jffs2_build_filesystem(): erasing all blocks after the end marker... [ 11.322996] random: crng init done [ 99.448918] done. [ 99.449614] jffs2: notice: (154) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found. [ 99.462428] mount_root: overlay filesystem has not been fully initialized yet [ 99.491925] mount_root: switching to jffs2 overlay [ 99.553406] overlayfs: upper fs does not support tmpfile. [ 101.222754] urandom-seed: Seed file not found (/etc/urandom.seed) [ 101.427216] procd: - early - [ 101.427410] procd: - watchdog - [ 102.161835] procd: - watchdog - [ 102.172385] procd: - ubus - [ 102.387979] procd: - init - [ 103.165987] kmodloader: loading kernel modules from /etc/modules.d/* [ 103.253148] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 103.267281] Netfilter messages via NETLINK v0.30. [ 103.271316] ip_set: protocol 6 [ 103.325232] u32 classifier [ 103.325275] input device check on [ 103.326845] Actions configured [ 103.334488] Mirror/redirect action on [ 103.372893] nf_conntrack version 0.5.0 (4096 buckets, 16384 max) [ 103.381239] Loading modules backported from Linux version v4.19.7-0-g61c68f2a2af0 [ 103.381294] Backport generated by backports.git v4.19.7-1-0-g148b072d [ 103.393216] ip_tables: (C) 2000-2006 Netfilter Core Team [ 103.467351] wireguard: WireGuard 0.0.20181218 loaded. See www.wireguard.com for information. [ 103.467412] wireguard: Copyright (C) 2015-2018 Jason A. Donenfeld Jason@zx2c4.com. All Rights Reserved. [ 103.523853] xt_time: kernel timezone is -0000 [ 103.525910] usbcore: registered new interface driver cdc_ether [ 103.628405] PPP generic driver version 2.4.2 [ 103.632981] NET: Registered protocol family 24 [ 103.636700] usbcore: registered new interface driver rndis_host [ 103.848380] ath10k_ahb a000000.wifi: Direct firmware load for ath10k/fwcfg-ahb-a000000.wifi.txt failed with error -2 [ 103.848643] ath10k_ahb a000000.wifi: Falling back to user helper [ 104.748863] firmware ath10k!fwcfg-ahb-a000000.wifi.txt: firmware_loading_store: map pages failed [ 104.751546] ath10k_ahb a000000.wifi: Direct firmware load for ath10k/pre-cal-ahb-a000000.wifi.bin failed with error -2 [ 104.756973] ath10k_ahb a000000.wifi: Falling back to user helper [ 156.175299] ath10k_ahb a000000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/ct-firmware-5.bin failed with error -2 [ 156.175369] ath10k_ahb a000000.wifi: Falling back to user helper [ 156.268078] firmware ath10k!QCA4019!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed [ 156.272498] ath10k_ahb a000000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/ct-firmware-2.bin failed with error -2 [ 156.276347] ath10k_ahb a000000.wifi: Falling back to user helper [ 156.384307] firmware ath10k!QCA4019!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed [ 156.385336] ath10k_ahb a000000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/firmware-6.bin failed with error -2 [ 156.392987] ath10k_ahb a000000.wifi: Falling back to user helper [ 156.510581] firmware ath10k!QCA4019!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed [ 158.439055] ath10k_ahb a000000.wifi: qca4019 hw1.0 target 0x01000000 chip_id 0x003b00ff sub 0000:0000 [ 158.439123] ath10k_ahb a000000.wifi: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0 [ 158.452155] ath10k_ahb a000000.wifi: firmware ver 10.4b-ct-4019-fW-012-81e1edd5 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT crc32 adeedaac [ 158.536231] ath10k_ahb a000000.wifi: board_file api 2 bmi_id 0:16 crc32 bcebe54c [ 159.850817] ath10k_ahb a000000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 159.851170] ath10k_ahb a000000.wifi: msdu-desc: 2500 skid: 32 [ 159.899449] ath10k_ahb a000000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 159.904821] ath10k_ahb a000000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 160.076340] ath10k_ahb a000000.wifi: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 32 raw 0 hwcrypto 1 [ 160.250748] ath: EEPROM regdomain: 0x0 [ 160.250966] ath: EEPROM indicates default country code should be used [ 160.251139] ath: doing EEPROM country→regdmn map search [ 160.251354] ath: country maps to regdmn code: 0x3a [ 160.251535] ath: Country alpha2 being used: US [ 160.251706] ath: Regpair used: 0x3a [ 160.604493] ath10k_ahb a800000.wifi: Direct firmware load for ath10k/fwcfg-ahb-a800000.wifi.txt failed with error -2 [ 160.604558] ath10k_ahb a800000.wifi: Falling back to user helper [ 161.546866] firmware ath10k!fwcfg-ahb-a800000.wifi.txt: firmware_loading_store: map pages failed [ 161.547618] ath10k_ahb a800000.wifi: Direct firmware load for ath10k/pre-cal-ahb-a800000.wifi.bin failed with error -2 [ 161.554948] ath10k_ahb a800000.wifi: Falling back to user helper [ 213.678366] ath10k_ahb a800000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/ct-firmware-5.bin failed with error -2 [ 213.678445] ath10k_ahb a800000.wifi: Falling back to user helper [ 213.784387] firmware ath10k!QCA4019!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed [ 213.785018] ath10k_ahb a800000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/ct-firmware-2.bin failed with error -2 [ 213.792724] ath10k_ahb a800000.wifi: Falling back to user helper [ 213.887430] firmware ath10k!QCA4019!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed [ 213.888161] ath10k_ahb a800000.wifi: Direct firmware load for ath10k/QCA4019/hw1.0/firmware-6.bin failed with error -2 [ 213.895841] ath10k_ahb a800000.wifi: Falling back to user helper [ 214.003089] firmware ath10k!QCA4019!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed [ 214.003729] ath10k_ahb a800000.wifi: qca4019 hw1.0 target 0x01000000 chip_id 0x003b00ff sub 0000:0000 [ 214.011502] ath10k_ahb a800000.wifi: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0 [ 214.031753] ath10k_ahb a800000.wifi: firmware ver 10.4b-ct-4019-fW-012-81e1edd5 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT crc32 adeedaac [ 214.077530] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17 crc32 bcebe54c [ 215.391527] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 215.391593] ath10k_ahb a800000.wifi: msdu-desc: 2500 skid: 32 [ 215.438962] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 215.441403] ath10k_ahb a800000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 215.603562] ath10k_ahb a800000.wifi: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 32 raw 0 hwcrypto 1 [ 215.687935] ath: EEPROM regdomain: 0x0 [ 215.687958] ath: EEPROM indicates default country code should be used [ 215.687971] ath: doing EEPROM country→regdmn map search [ 215.687987] ath: country maps to regdmn code: 0x3a [ 215.688000] ath: Country alpha2 being used: US [ 215.688012] ath: Regpair used: 0x3a [ 215.702302] kmodloader: done loading kernel modules from /etc/modules.d/* [ 227.854297] br-lan: port 1(eth0) entered blocking state [ 227.854592] br-lan: port 1(eth0) entered disabled state [ 227.860687] device eth0 entered promiscuous mode [ 227.871476] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready [ 227.906117] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready [ 228.892011] br-lan: port 1(eth0) entered blocking state [ 228.892376] br-lan: port 1(eth0) entered forwarding state [ 228.897974] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready [ 836.417783] ath10k_ahb a000000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 836.417985] ath10k_ahb a000000.wifi: msdu-desc: 2500 skid: 32 [ 836.465603] ath10k_ahb a000000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 836.467576] ath10k_ahb a000000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 836.821115] ath10k_ahb a000000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4 [ 836.821983] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 837.414297] ath10k_ahb a000000.wifi: NOTE: Firmware DBGLOG output disabled in debug_mask: 0x10000000 [ 838.315034] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 838.315098] ath10k_ahb a800000.wifi: msdu-desc: 2500 skid: 32 [ 838.362450] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 838.365421] ath10k_ahb a800000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 838.681766] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4 [ 838.682261] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready [ 838.692133] br-lan: port 2(wlan0) entered blocking state [ 838.697662] br-lan: port 2(wlan0) entered disabled state [ 838.704242] device wlan0 entered promiscuous mode [ 838.708921] br-lan: port 3(wlan1) entered blocking state [ 838.713072] br-lan: port 3(wlan1) entered disabled state [ 838.719173] device wlan1 entered promiscuous mode [ 838.724251] br-lan: port 3(wlan1) entered blocking state [ 838.728297] br-lan: port 3(wlan1) entered forwarding state [ 838.734410] br-lan: port 3(wlan1) entered disabled state [ 839.161739] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 839.162527] br-lan: port 2(wlan0) entered blocking state [ 839.167294] br-lan: port 2(wlan0) entered forwarding state [ 839.575376] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready [ 839.575935] br-lan: port 3(wlan1) entered blocking state [ 839.580834] br-lan: port 3(wlan1) entered forwarding state [ 849.384092] device wlan0 left promiscuous mode [ 849.385123] br-lan: port 2(wlan0) entered disabled state [ 849.483810] ath10k_ahb a000000.wifi: peer-unmap-event: unknown peer id 0 [ 849.484148] ath10k_ahb a000000.wifi: peer-unmap-event: unknown peer id 0 [ 849.803295] device wlan1 left promiscuous mode [ 849.803714] br-lan: port 3(wlan1) entered disabled state [ 849.899584] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0 [ 849.899671] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0 [ 851.616888] ath10k_ahb a000000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 851.616955] ath10k_ahb a000000.wifi: msdu-desc: 2500 skid: 32 [ 851.663814] ath10k_ahb a000000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 851.664819] ath10k_ahb a000000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 852.019897] ath10k_ahb a000000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4 [ 852.020555] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 852.040206] br-lan: port 2(wlan0) entered blocking state [ 852.040296] br-lan: port 2(wlan0) entered disabled state [ 852.045572] device wlan0 entered promiscuous mode [ 852.493357] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 852.493937] br-lan: port 2(wlan0) entered blocking state [ 852.498827] br-lan: port 2(wlan0) entered forwarding state [ 854.041377] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16 peers: 48 tid: 96 [ 854.041442] ath10k_ahb a800000.wifi: msdu-desc: 2500 skid: 32 [ 854.089276] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186 msdu-desc: 2500 sw-crypt: 0 ct-sta: 0' [ 854.096165] ath10k_ahb a800000.wifi: wmi print 'free: 58060 iram: 22488 sram: 35968' [ 854.391323] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4 [ 854.391988] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready [ 854.407934] br-lan: port 3(wlan1) entered blocking state [ 854.408014] br-lan: port 3(wlan1) entered disabled state [ 854.414166] device wlan1 entered promiscuous mode [ 855.143179] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready [ 855.143737] br-lan: port 3(wlan1) entered blocking state [ 855.148656] br-lan: port 3(wlan1) entered forwarding state


Space for additional notes, links to forum threads or other resources.

  • ...
  1. Reports of ethernet controller cutting out on IPQ401x devices. OpenWrt forum - Jan 2020: caused by IPv6 on WAN.
  2. Ping spikes/latency issues with ipq401x devices. OpenWrt forum

FIXME Add tags below, then remove this fixme.

How to add tags

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2024/02/12 11:13
  • by 127.0.0.1