NuCom R5010UNv2

Devices with Broadcom WiFi chipsets have limited OpenWrt supportability (due to limited FLOSS driver availability for Broadcom chips). Consider this when choosing a device to buy, or when deciding to flash OpenWrt on your device because it is listed as supported. See Broadcom WiFi for details.

DSL will not work at all on devices with BCM63xx DSL chipset (due to unavailability of FLOSS driver for Broadcom chips). Consider this when choosing a device to buy, or when deciding to flash OpenWrt on your device because it is listed as supported.
See Broadcom DSL, Unsupported: DSL modem and Broadcom BCM63xx for details.

Install OpenWrt (generic explanation)

Version link notes
dummy CFE-R5010UNv2-mod-dummy_firmware.bin only for upgrading CFE, void firmware

The dummy firmware for upgrading CFE is only required if OpenWrt can't save changes or other troubles with the flash chip. Beware a bad flashing of CFE can brick your router.

Flashing ANY Firmware

With this procedure you will flash the firmware using the bootloader web interface (foolproof)

  1. Set a static IP on your computer, use 192.168.1.35 (or any compatible), and connect an ethernet cable from the computer to the router.
  2. Unplug the router's power cord
  3. Press the button labeled as RESET, don't release it yet!
  4. Plug the power cord
  5. Wait 12 seconds or more
  6. Release the RESET button
  7. Browse to http://192.168.1.1, you should see this screen:
  8. Select .bin firmware
  9. Press Update Software to start the firmware update process
  10. Wait for it to reboot
  11. Telnet or ssh to 192.168.1.1 and set a root password, or browse to http://192.168.1.1 if LuCI is installed.

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN & WiFi 192.168.1.1/24
eth0 LAN ports (0 to 3) bridged
wlan0 WiFi bridged (disabled)

This is an example to configure the switch: numbers 0-2 will be lan, labeled as Ports LAN1X, LAN2X, LAN3X on the unit, number 3 (LAN4X) will be the Internet (WAN), 8 is the internal connection to the router itself. Don't be fooled: vlan1 = eth0.1, vlan2 = eth0.2 and so on.

Port Switch port Mode
LAN1X 0 lan
LAN2X 1 lan
LAN3X 2 lan
LAN4X 3 Internet (WAN)
# 
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda5:ace8:376d::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        
config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 8t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '3 8t'
Instruction set MIPS
Vendor Broadcom
bootloader cfe
Board ID 96328ang
System-On-Chip Broadcom BCM6328
CPU @Frq BMIPS4350 V7.5 @320 MHz
Flash-Chip MX25L12835FMI or FL128SAIF00 (SPI) / 64KB block size x 256 main blocks
Flash size 16 MiB
RAM-Chip DDR2-800
RAM size 64 MiB
Wireless BCM43217 802.11b/g/n (onboard)
Ethernet Internal BRCM6328 Switch, 4x 100M + ADSL2+
USB 1x 2.0
Serial Yes
JTAG No

BCM43217 802.11b/g/n onboard wifi, 2x non-detachable external antennas.

No physical EEPROM at the board, nor partition reserverd for this data at the flash chip. In theory, in the original firmware, the EEPROM is taken from the file /etc/wlan/bcm43227_map.bin

In OpenWrt the kmod-b43 driver should be used, therefore N mode isn't available. kmod-bcmsmac could support N mode but isn't still supported for the BCM43217 wifi.

port.jtag general information about the JTAG port, JTAG cable, etc.

N/A

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device:

Read: System configuration: Leds to configure the leds

GPIO Label Led color Active
1 inet green Low
2 inet-fail red Low
3 dsl green Low
4 power green Low
5 power-fail red Low
10 wps green Low
11 usb green Low
25 (PINMUX_EPHY0_ACT_LED) lan1 green Low
26 (PINMUX_EPHY1_ACT_LED) lan2 green Low
27 (PINMUX_EPHY2_ACT_LED) lan3 green Low
28 (PINMUX_EPHY3_ACT_LED) lan4 green Low

hardware.button on howto use and configure the hardware button(s).

GPIO Label Active
23 Reset Low
24 WPS Low

HELO CPUI L1CI DRAM ---- PHYS ZQDN PHYE DINT LSYN USYN MSYN LMBE PASS ---- ZBSS CODE DATA L12F MAIN CFE version 1.0.37-106.5 for BCM96328 (32bit,SP,BE) Build Date: 2013年 09月 09日 星期一 12:55:22 HKT (root@s54) Copyright (C) 2000-2009 Broadcom Corporation. clock=40000000 flash=S25FL128 size=16MB id=0x12018 sector=64k HS Serial flash device: name S25FL128, id 0x12018 size 16384KB Total Flash size: 16384K with 256 sectors Chip ID: BCM6328B0, MIPS: 320MHz, DDR: 320MHz, Bus: 160MHz Main Thread: TP0 Memory Test Passed Total Memory: 67108864 bytes (64MB) Boot Address: 0xb8000000 Board IP address : 192.168.1.1:ffffff00 Host IP address : 192.168.1.100 Gateway IP address : Run from flash/host (f/h) : f Default host run file name : vmlinux Default host flash file name : bcm963xx_fs_kernel Boot delay (0-9 seconds) : 1 Board Id (0-2) : 96328ang Number of MAC Addresses (1-32) : 11 Base MAC Address : fa:ba:da:fa:ba:da PSI Size (1-64) KBytes : 32 Enable Backup PSI [0|1] : 1 System Log Size (0-256) KBytes : 0 Main Thread Number [0|1] : 0 send udp message finished. Not response, auto boot ... Linux version 2.6.30 (root@s54) (gcc version 4.4.2 (Buildroot 2010.02-git) ) #2 Mon Sep 9 14:09:37 HKT 2013 clock=40000000 flash=S25FL128 size=16MB id=0x12018 sector=64k HS Serial flash device: name S25FL128, id 0x12018 size 16384KB 96328ang prom init CPU revision is: 0002a075 (Broadcom4350) Determined physical RAM map: memory: 03f00000 @ 00000000 (usable) Zone PFN ranges: DMA 0x00000000 -> 0x00001000 Normal 0x00001000 -> 0x00003f00 Movable zone start PFN for each node early_node_map[1] active PFN ranges 0: 0x00000000 -> 0x00003f00 On node 0 totalpages: 16128 free_area_init_node: node 0, pgdat 80331ac0, node_mem_map 81000000 DMA zone: 32 pages used for memmap DMA zone: 0 pages reserved DMA zone: 4064 pages, LIFO batch:0 Normal zone: 94 pages used for memmap Normal zone: 11938 pages, LIFO batch:1 Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16002 Kernel command line: root=31:0 ro noinitrd console=ttyS0,115200 wait instruction: enabled Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes. Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes RCU-based detection of stalled CPUs is enabled. NR_IRQS:128 PID hash table entries: 256 (order: 8, 1024 bytes) console [ttyS0] enabled Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) Memory: 60300k/64512k available (2762k kernel code, 4192k reserved, 451k data, 128k init, 0k highmem) Calibrating delay loop... 319.48 BogoMIPS (lpj=159744) Mount-cache hash table entries: 512 net_namespace: 760 bytes NET: Registered protocol family 16 Total Flash size: 16384K with 256 sectors registering PCI controller with io_map_base unset registering PCI controller with io_map_base unset bio: create slab <bio-0> at 0 SCSI subsystem initialized usbcore: registered new interface driver usbfs usbcore: registered new interface driver hub usbcore: registered new device driver usb pci 0000:00:09.0: reg 10 32bit mmio: [0x10002600-0x100026ff] pci 0000:00:0a.0: reg 10 32bit mmio: [0x10002500-0x100025ff] pci 0000:01:00.0: PME# supported from D0 D3hot pci 0000:01:00.0: PME# disabled pci 0000:02:00.0: reg 10 64bit mmio: [0x000000-0x007fff] pci 0000:02:00.0: supports D1 D2 pci 0000:01:00.0: PCI bridge, secondary bus 0000:02 pci 0000:01:00.0: IO window: disabled pci 0000:01:00.0: MEM window: 0x10f00000-0x10ffffff pci 0000:01:00.0: PREFETCH window: disabled PCI: Enabling device 0000:01:00.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:01:00.0 to 64 BLOG v3.0 Initialized NET: Registered protocol family 8 NET: Registered protocol family 20 NET: Registered protocol family 2 IP route cache hash table entries: 1024 (order: 0, 4096 bytes) TCP established hash table entries: 2048 (order: 2, 16384 bytes) TCP bind hash table entries: 2048 (order: 1, 8192 bytes) TCP: Hash tables configured (established 2048 bind 2048) TCP reno registered NET: Registered protocol family 1 squashfs: version 4.0 (2009/01/31) Phillip Lougher squashfs: version 4.0 with LZMA457 ported by BRCM fuse init (API version 7.11) msgmni has been set to 117 io scheduler noop registered (default) pcieport-driver 0000:01:00.0: device [14e4:6328] has invalid IRQ; check vendor BIOS PCI: Setting latency timer of device 0000:01:00.0 to 64 Driver 'sd' needs updating - please use bus_type methods PPP generic driver version 2.4.2 PPP Deflate Compression module registered PPP BSD Compression module registered NET: Registered protocol family 24 bcm963xx_mtd driver v1.0 File system address: 0xb8010100 ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver PCI: Enabling device 0000:00:0a.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:00:0a.0 to 64 ehci_hcd 0000:00:0a.0: EHCI Host Controller ehci_hcd 0000:00:0a.0: new USB bus registered, assigned bus number 1 ehci_hcd 0000:00:0a.0: Enabling legacy PCI PM ehci_hcd 0000:00:0a.0: irq 50, io mem 0x10002500 ehci_hcd 0000:00:0a.0: USB f.f started, EHCI 1.00 usb usb1: configuration #1 chosen from 1 choice hub 1-0:1.0: USB hub found hub 1-0:1.0: 1 port detected ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver PCI: Enabling device 0000:00:09.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:00:09.0 to 64 ohci_hcd 0000:00:09.0: OHCI Host Controller ohci_hcd 0000:00:09.0: new USB bus registered, assigned bus number 2 ohci_hcd 0000:00:09.0: irq 49, io mem 0x10002600 usb usb2: configuration #1 chosen from 1 choice hub 2-0:1.0: USB hub found hub 2-0:1.0: 1 port detected usbcore: registered new interface driver usblp Initializing USB Mass Storage driver... usbcore: registered new interface driver usb-storage USB Mass Storage support registered. brcmboard: brcm_board_init entry SES: LED GPIO 0x800a is enabled Serial: BCM63XX driver $Revision: 3.00 $ ttyS0 at MMIO 0xb0000100 (irq = 36) is a BCM63XX ttyS1 at MMIO 0xb0000120 (irq = 36) is a BCM63XX bcmxtmrt: Broadcom BCM6328B0 ATM/PTM Network Device v0.3 Sep 9 2013 12:40:50 bcmxtmcfg: bcmxtmcfg_init entry adsl: adsl_init entry Broadcom BCM6328B0 Ethernet Network Device v0.1 Sep 9 2013 12:39:05 ETH Init: 180 tx BDs at 0xa391d000 ETH Init: 400 rx BDs at 0xa3938000 ETH Init: 400 rx BDs at 0xa393a000 dgasp: kerSysRegisterDyingGaspHandler: bcmsw registered eth0: MAC Address: FA:BA:DA:FA:BA:DA eth1: MAC Address: FA:BA:DA:FA:BA:DA eth2: MAC Address: FA:BA:DA:FA:BA:DA eth3: MAC Address: FA:BA:DA:FA:BA:DA Broadcom Logger v0.1 Sep 9 2013 12:38:58 Broadcom 802.1Q VLAN Interface, v0.1 Mirror/redirect action on u32 classifier input device check on Actions configured TCP cubic registered NET: Registered protocol family 10 ADDRCONF(NETDEV_UP): bcmsw: link is not ready IPv6 over IPv4 tunneling driver NET: Registered protocol family 17 Initializing MCPD Module Ebtables v2.0 registered ebt_time registered ebt_ftos registered ebt_wmm_mark registered VFS: Mounted root (squashfs filesystem) readonly on device 31:0. Freeing unused kernel memory: 128k freed pktflow: module license 'Proprietary' taints kernel. Disabling lock debugging due to kernel taint Initialized fcache state Broadcom Packet Flow Cache Char Driver v2.2 Nov 16 2010 15:04:32 Registered<242> Created Proc FS /procfs/fcache Broadcom Packet Flow Cache registered with netdev chain Broadcom Packet Flow Cache learning via BLOG enabled. Constructed Broadcom Packet Flow Cache v2.2 Nov 16 2010 15:04:32 wl: high_wmark_tot=400 PCI: Enabling device 0000:02:00.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:02:00.0 to 64 wl: napimode=1 wl0: allocskbmode=1 currallocskbsz=256 otp_read_pci: bad crc Neither SPROM nor OTP has valid image wl:srom/otp not programmed, using main memory mapped srom info(wombo board) wl:loading /etc/wlan/bcm43227_vars.bin Failed to open srom image from '/etc/wlan/bcm43227_vars.bin'. wl:loading /etc/wlan/bcm43227_map.bin wl0: Broadcom BCMa8db 802.11 Wireless Controller 5.100.138.2001.cpe4.406.3 dgasp: kerSysRegisterDyingGaspHandler: wl0 registered unprotect_e253protect.<6>ip_tables: (C) 2000-2006 Netfilter Core Team Netfilter messages via NETLINK v0.30. nf_conntrack version 0.5.0 (1008 buckets, 4032 max) device eth0 entered promiscuous mode ADDRCONF(NETDEV_UP): eth0: link is not ready device eth1 entered promiscuous mode ADDRCONF(NETDEV_UP): eth1: link is not ready device eth2 entered promiscuous mode ADDRCONF(NETDEV_UP): eth2: link is not ready device eth3 entered promiscuous mode ADDRCONF(NETDEV_UP): eth3: link is not ready BcmAdsl_Initialize=0x801A6BF4, g_pFnNotifyCallback=0x80329CF4 pSdramPHY=0xA3FFFFF8, 0x1002000 0x60800000 *** XfaceOffset: 0x21F90 => 0x21F90 *** *** PhySdramSize got adjusted: 0x8339C => 0x98D48 *** AdslCoreSharedMemInit: shareMemAvailable=422544 AdslCoreHwReset: pLocSbSta=83160000 bkupThreshold=1600 AdslCoreHwReset: AdslOemDataAddr = 0xA3F783D4 dgasp: kerSysRegisterDyingGaspHandler: dsl0 registered XTM Init: 400 rx BDs at 0xa3108000 XTM Init: 100 rx BDs at 0xa32c9000 ###reset_nf_conntrack_net_ops;540;### ###reset_nf_conntrack_net_ops;540;### ###reset_nf_conntrack_net_ops;540;### monitor task is initialized pid= 228 br0: port 1(eth0) entering disabled state br0: port 2(eth1) entering disabled state br0: port 3(eth2) entering disabled state br0: port 4(eth3) entering disabled state unprotect_e254protect.<2>eth3 Link UP 100 mbps full duplex br0: port 4(eth3) entering forwarding state device wl0 entered promiscuous mode device wl0.1 entered promiscuous mode device wl0.2 entered promiscuous mode device wl0.3 entered promiscuous mode br0: port 5(wl0) entering forwarding state clear g_wps_status eth3 Link DOWN. br0: port 4(eth3) entering disabled state br0: port 4(eth3) entering disabled state eth3 Link UP 100 mbps full duplex br0: port 4(eth3) entering forwarding state dhcpd uses obsolete (PF_INET,SOCK_PACKET)


HELO CPUI L1CI DRAM ---- PHYS ZQDN PHYE DINT LSYN USYN MSYN LMBE PASS ---- ZBSS CODE DATA L12F MAIN CFE version 2.0.3 for BCM96328 (32bit,SP,BE) Build Date: Thu Nov 26 15:09:04 CET 2015 (dani@tool) Copyright (C) 2000-2009 Broadcom Corporation. HS Serial flash device: name S25FL128, id 0x0118 size 16384KB Total Flash size: 16384K with 256 sectors ** HELLO ** Chip ID: BCM6328B0, MIPS: 320MHz, DDR: 320MHz, Bus: 160MHz Main Thread: TP0 Memory Test Passed Total Memory: 67108864 bytes (64MB) Boot Address: 0xb8000000 Board IP address : 192.168.1.1:ffffff00 Host IP address : 192.168.1.100 Gateway IP address : Run from flash/host (f/h) : f Default host run file name : vmlinux Default host flash file name : bcm963xx_fs_kernel Boot delay (0-9 seconds) : 1 Board Id (0-5) : 96328ang Number of MAC Addresses (1-32) : 11 Base MAC Address : 00:11:22:33:44:55 PSI Size (1-64) KBytes : 32 Enable Backup PSI [0|1] : 0 System Log Size (0-256) KBytes : 0 Main Thread Number [0|1] : 0 Voice Board Configuration (0-11) : LE88276 *** Press any key to stop auto run (1 seconds) *** Auto run second count down: 0 *** Press any key to stop auto run (1 seconds) *** Auto run second count down: 0 Booting from only image (0xb8010000) ... Code Address: 0x80A00000, Entry Address: 0x80a00000 LZMA: Prossible old LZMA format, trying to decompress.. Decompression OK! Entry at 0x80a00000 Closing network. Disabling Switch ports. Flushing Receive Buffers... 7 buffers found. Closing DMA Channels. Starting program at 0x80a00000 [ 0.000000] Linux version 4.1.11 (dani@tool) (gcc version 5.2.0 (OpenWrt GCC 5.2.0 r47603) ) #4 Thu Nov 26 19:50:03 CET 2015 [ 0.000000] Detected Broadcom 0x6328 CPU revision b0 [ 0.000000] CPU frequency is 320 MHz [ 0.000000] 64MB of RAM installed [ 0.000000] board_bcm963xx: Boot address 0xb8000000 [ 0.000000] board_bcm963xx: CFE version: 1.0.37-106.24 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 0002a075 (Broadcom BMIPS4350) [ 0.000000] board: board name: 96328ang [ 0.000000] MIPS: machine is NuCom R5010UN v2 [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 04000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes. [ 0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256 [ 0.000000] Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200 [ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes) [ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) [ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) [ 0.000000] Memory: 59652K/65536K available (2974K kernel code, 140K rwdata, 604K rodata, 1264K init, 193K bss, 5884K reserved , 0K cma-reserved) [ 0.000000] NR_IRQS:256 [ 0.000000] clocksource MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 11945377789 ns [ 0.000019] sched_clock: 32 bits at 160MHz, resolution 6ns, wraps every 13421772796ns [ 0.008683] Calibrating delay loop... 319.74 BogoMIPS (lpj=639488) [ 0.051004] pid_max: default: 32768 minimum: 301 [ 0.056427] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.063224] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.078432] clocksource jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns [ 0.090162] NET: Registered protocol family 16 [ 0.331380] registering PCI controller with io_map_base unset [ 0.362797] PCI host bridge to bus 0000:00 [ 0.367050] pci_bus 0000:00: root bus resource [mem 0x10f00000-0x10ffffff] [ 0.374116] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0] [ 0.381099] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0] [ 0.388087] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff] [ 0.396931] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring [ 0.406383] pci 0000:00:00.0: BAR 8: assigned [mem 0x10f00000-0x10ffffff] [ 0.413401] pci 0000:01:00.0: BAR 0: assigned [mem 0x10f00000-0x10f07fff 64bit] [ 0.420934] pci 0000:00:00.0: PCI bridge to [bus 01] [ 0.426022] pci 0000:00:00.0: bridge window [mem 0x10f00000-0x10ffffff] [ 0.434671] Switched to clocksource MIPS [ 0.442082] PCI: Enabling device 0000:00:00.0 (0000 -> 0002) [ 0.447961] PCI: Enabling device 0000:01:00.0 (0000 -> 0002) [ 0.453808] bcma: bus0: Found chip with id 43227, rev 0x01 and package 0x09 [ 0.461010] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x27, class 0x0) [ 0.469828] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x1E, class 0x0) [ 0.478750] bcma: bus0: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x14, class 0x0) [ 0.502965] bcma: bus0: Bus registered [ 0.507477] NET: Registered protocol family 2 [ 0.514207] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.521493] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.528079] TCP: Hash tables configured (established 1024 bind 1024) [ 0.535106] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.541209] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.548423] NET: Registered protocol family 1 [ 0.555450] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.566304] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.572367] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.586103] io scheduler noop registered [ 0.590199] io scheduler deadline registered (default) [ 0.597518] bcm63xx_uart.0: ttyS0 at MMIO 0xb0000100 (irq = 36, base_baud = 1562500) is a bcm63xx_uart [ 0.607184] console [ttyS0] enabled [ 0.607184] console [ttyS0] enabled [ 0.614339] bootconsole [early0] disabled [ 0.614339] bootconsole [early0] disabled [ 0.631988] m25p80 spi1.0: found s25fl128s, expected m25p80 [ 0.637764] m25p80 spi1.0: s25fl128s (16384 Kbytes) [ 0.643181] bcm63xxpart: CFE boot tag found with version 6 and board type 96328ang [ 0.651071] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000 [ 0.657709] bcm63xxpart: Partition 1 is kernel offset 10100 and length 13bf64 [ 0.665045] bcm63xxpart: Partition 2 is rootfs offset 14c064 and length ea3f9c [ 0.672473] bcm63xxpart: Partition 3 is nvram offset ff0000 and length 10000 [ 0.679727] bcm63xxpart: Partition 4 is linux offset 10000 and length fe0000 [ 0.686984] 5 bcm63xxpart partitions found on MTD device spi1.0 [ 0.693074] Creating 5 MTD partitions on "spi1.0": [ 0.698020] 0x000000000000-0x000000010000 : "CFE" [ 0.704748] 0x000000010100-0x00000014c064 : "kernel" [ 0.711659] 0x00000014c064-0x000000ff0000 : "rootfs" [ 0.718479] mtd: device 2 (rootfs) set to be root filesystem [ 0.728207] 1 squashfs-split partitions found on MTD device rootfs [ 0.734632] 0x000000390000-0x000000ff0000 : "rootfs_data" [ 0.742013] 0x000000ff0000-0x000001000000 : "nvram" [ 0.748836] 0x000000010000-0x000000ff0000 : "linux" [ 0.791918] b53_common: found switch: BCM63xx, rev 0 [ 0.797581] bcm63xx-wdt bcm63xx-wdt: started, timer margin: 30 sec [ 0.807619] NET: Registered protocol family 10 [ 0.819596] NET: Registered protocol family 17 [ 0.824350] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this. [ 0.837384] 8021q: 802.1Q VLAN Support v1.8 [ 0.852615] VFS: Mounted root (squashfs filesystem) readonly on device 31:2. [ 0.876976] Freeing unused kernel memory: 1264K (803b4000 - 804f0000) [ 2.733134] init: Console is alive [ 2.736985] init: - watchdog - [ 4.555866] usbcore: registered new interface driver usbfs [ 4.561800] usbcore: registered new interface driver hub [ 4.567538] usbcore: registered new device driver usb [ 4.587110] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver [ 4.596622] ehci-platform: EHCI generic platform driver [ 4.702724] ehci-platform ehci-platform: EHCI Host Controller [ 4.708706] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1 [ 4.717238] ehci-platform ehci-platform: irq 50, io mem 0xb0002500 [ 4.734711] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00, overcurrent ignored [ 4.744865] hub 1-0:1.0: USB hub found [ 4.749369] hub 1-0:1.0: 1 port detected [ 4.761075] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver [ 4.770350] ohci-platform: OHCI generic platform driver [ 4.775988] ohci-platform ohci-platform: Generic Platform OHCI controller [ 4.783050] ohci-platform ohci-platform: new USB bus registered, assigned bus number 2 [ 4.791361] ohci-platform ohci-platform: irq 49, io mem 0xb0002600 [ 4.856666] hub 2-0:1.0: USB hub found [ 4.861159] hub 2-0:1.0: 1 port detected [ 4.874907] init: - preinit - [ 5.615452] random: procd urandom read with 105 bits of entropy available Press the [f] key and hit [enter] to enter failsafe mode Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level [ 9.139500] random: nonblocking pool is initialized [ 9.178858] jffs2: notice: (248) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 o rphan) and 0 of xref (0 dead, 0 orphan) found. [ 9.198327] mount_root: switching to jffs2 overlay ifconfig: SIOCGIFFLAGS: No such device [ 9.248282] procd: - early - [ 9.251602] procd: - watchdog - [ 10.243553] procd: - ubus - [ 11.256970] procd: - init - Please press Enter to activate this console. [ 12.590794] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 12.623723] Loading modules backported from Linux version master-2015-10-26-0-g28c26cb [ 12.631907] Backport generated by backports.git backports-20150903-4-g12cf266 [ 12.645620] ip_tables: (C) 2000-2006 Netfilter Core Team [ 12.672738] nf_conntrack version 0.5.0 (951 buckets, 3804 max) [ 12.749019] xt_time: kernel timezone is -0000 [ 12.801178] cfg80211: World regulatory domain updated: [ 12.806499] cfg80211: DFS Master region: unset [ 12.810953] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 12.821004] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 12.829245] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 12.837480] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A) [ 12.845726] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A) [ 12.855493] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) [ 12.865256] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s) [ 12.873599] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A) [ 12.881830] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A) [ 13.017080] PPP generic driver version 2.4.2 [ 13.026636] NET: Registered protocol family 24 [ 13.084898] b43-phy0: Broadcom 43227 WLAN found (core revision 30) [ 13.092117] b43-phy0: Found PHY: Analog 9, Type 4 (N), Revision 17 [ 13.098510] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2057, Revision 14, Version 0 [ 13.107157] Broadcom 43xx driver loaded [ Features: PNL ] [ 18.439030] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex [ 26.155025] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex [ 26.178914] device eth0.1 entered promiscuous mode [ 26.183866] device eth0 entered promiscuous mode [ 26.204395] br-lan: port 1(eth0.1) entered forwarding state [ 26.210206] br-lan: port 1(eth0.1) entered forwarding state [ 27.531980] cfg80211: Regulatory domain changed to country: JP [ 27.538197] cfg80211: DFS Master region: JP [ 27.542418] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 27.552436] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 27.560671] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A) [ 27.568911] cfg80211: (4910000 KHz - 4990000 KHz @ 40000 KHz), (N/A, 2300 mBm), (N/A) [ 27.577154] cfg80211: (5030000 KHz - 5090000 KHz @ 40000 KHz), (N/A, 2300 mBm), (N/A) [ 27.585402] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A) [ 27.595170] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) [ 27.604932] cfg80211: (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2300 mBm), (0 s) [ 27.613262] cfg80211: (59000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 1000 mBm), (N/A) [ 28.210748] br-lan: port 1(eth0.1) entered forwarding state [ 29.738720] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07) [ 29.874100] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 29.909183] device wlan0 entered promiscuous mode [ 31.419394] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 31.426288] br-lan: port 2(wlan0) entered forwarding state [ 31.432011] br-lan: port 2(wlan0) entered forwarding state [ 33.434693] br-lan: port 2(wlan0) entered forwarding state BusyBox v1.24.1 (2015-11-24 12:42:11 CET) built-in shell (ash) _______ ________ __ | |.-----.-----.-----.| | | |.----.| |_ | - || _ | -__| || | | || _|| _| |_______|| __|_____|__|__||________||__| |____| |__| W I R E L E S S F R E E D O M ----------------------------------------------------- DESIGNATED DRIVER (Bleeding Edge, r47603) ----------------------------------------------------- * 2 oz. Orange Juice Combine all juices in a * 2 oz. Pineapple Juice tall glass filled with * 2 oz. Grapefruit Juice ice, stir well. * 2 oz. Cranberry Juice ----------------------------------------------------- root@OpenWrt:/#


This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2024/02/12 08:58
  • by 127.0.0.1