User Tools

Site Tools


toh:mikrotik:rb750_r2

Mikrotik RouterBoard RB750r2 (hEX lite)

hEX Lite

Supported versions

Hardware Highlights

Installation

Downloads

Version Release date firmware link Notes
OpenWrt Trunk/Snapshot 2017 https://downloads.openwrt.org/snapshots/trunk/ar71xx/mikrotik/openwrt-ar71xx-mikrotik-vmlinux-initramfs.elf OpenWrt Trunk/Snapshot builds mikrotik-vmlinux-initramfs.elf
LEDE Trunk/Snapshot 2017 https://downloads.lede-project.org/snapshots/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-rb-nor-flash-16M-initramfs-kernel.bin LEDE Development Version, Working, Port 1 WAN, 2-5 port LAN, All Working
LEDE Trunk/Snapshot 2017 https://downloads.lede-project.org/snapshots/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin LEDE Development Version, flash-16M-squashfs-sysupgrade.bin

Note for LEDE Development version, Yes is working as of r4049-9412fc2 but may contain bugs! No LuCI/Web interface is included so please wait for LEDE or OpenWrt newer release if you need this Stable! https://lede-project.org/docs/guide-quick-start/developmentinstallation#installing_a_lede_snapshot

LEDE Stable 17.01.1 (2017-04-18) LANs are NOT WORKING again only the snapshot builds are working with LEDE!

Flash u-boot (optional)

Procedure is similar to RB750Gr3 because RouterBoard uses same flash chip.

Boot over ethernet (using DHCP PXE)

Enable DHCP PXE on RouterBoard

Method 1 (using Winbox)

Download Winbox from Mikrotik webpage https://download2.mikrotik.com/routeros/winbox/3.11/winbox.exe

Boot up the RB750r2, connect your DHCP client to any of the ports 2 to 5 but not the Internet labled port (Port 1)

Open up Winbox, IP Address 192.168.88.1, If a password has been set put this in if not the Default is just Blank

Go to:

  System → Routerboard → Settings → Boot device: Try ethernet once then NAND
  System → Routerboard → Settings → Boot protocol: DHCP
  System → Routerboard → Settings → Force Backup Booter: Checked (if supported by your routerboard - !IMPORTANT)
  System → Shutdown

Connect the LAN port on Internet labled port and reboot the RB750r2, Connect the computers LAN port on Internet

Method 2 (TFTP with Telnet)

Please note that the aforementioned mechanism is not properly working on some boards. Don't worry, boot up the mikrotik board, connect your DHCP client to port 1. An address from 192.168.88.0/24 must be obtained. You can now telnet to the board, and configure it for TFTPboot.

Telnet user is admin, leave the password empty.

telnet 192.168.88.1
system routerboard settings set boot-device=try-ethernet-once-then-nand 
system routerboard settings set boot-protocol=dhcp 

Now reboot the board, it should boot from the labled “Internet” port now.

Boot openwrt kernel over ethernet using tftpd32

For Windows 7 SP1 x64 (XP/Vista should be ok)

Download http://tftpd32.jounin.net/tftpd32_download.html (i used tftpd64 portable edition) and the mikrotik-rb-nor-flash-16M-initramfs-kernel.bin and mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin from Downloads above and then save them in the same tftpd32 folder IMPORTANT

Extract the tftpd32 folder and make sure mikrotik-rb-nor-flash-16M-initramfs-kernel.bin is there and open up tftp32 config file and match theses settings i have (worked for me)

[DHCP]

 4C:5E:0C:XX:XX:XX=192.168.1.250  (Should be the same ETH1 MAC Address)
 BootFile=lede-ar71xx-mikrotik-rb-nor-flash-16M-initramfs-kernel.bin
 Lease_NumLeases=2
 IP_Pool=192.168.1.2
 PoolSize=4
 Mask=255.255.255.0
 Gateway=192.168.1.1
 Lease (minutes)=90

Save!

Open up tftpd64.exe and the go to Settings > GLOBEL and make sure, TFTP server and DHCP are ticked, everything else untick, Save and Exit and then reopen tftpd64.exe for the saved changes!

Set a static IP on your Windows computer LAN port with the following

 192.168.1.2  (Keep this to 192.168.1.2 or tftpd wont work **IMPORTANT**)
 255.255.255.0 (**IMPORTANT**)
 192.168.1.1 (**IMPORTANT**)

Follow method 1 to enable TFTP, Once done keep the LAN on port 1 (interent port) and then you should see something transferring and then the RB750r2 will boot into LEDE, Unplug the LAN port from Internet port 1 and set a DHCP on your Windows machine and then plugin the LAN port into any port 2-5 and the Internet port for a Cable Modem? Switch? Router? something that has internet access to it if you want to keep the LEDE on as this is in RAM mode and wont save any changes!

Write openwrt to flash using sysupgrade

Now, If you want to erase you RouterOS then follow theses steps;

Log into SSH 192.168.1.1 with just root and password been blank (press enter)

cd /tmp
wget http://downloads.lede-project.org/snapshots/targets/ar71xx/mikrotik/lede-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin
sysupgrade lede-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin

Snapshot dated 28/04/2017, Maybe fixed in a Stable release? I got this error but all seems to be working fine! https://forum.openwrt.org/viewtopic.php?pid=357278#p357278

Web Upgrade

  1. Go to System > Backup/Flash Firmware
  2. Untick Keep settings
  3. Click the Browse button and select the upgrade lede-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin image
  4. Click the Flash Image button

Hardware

Info

Architecture MIPS
Vendor MediaTek
Bootloader U-Boot (flashed over RouterBOOT)
System-On-Chip Qualcomm Atheros QCA9533 (MIPS 24Kc)
CPU/Speed 850MHz
Flash-Chip Winbond 25Q128FVSG
Flash size 16 MiB
RAM 256 MiB DDR3
Ethernet 10/100 Mbit/s w/ vlan support
USB not populated, unsupported by SoC ?
Serial Yes
JTAG ?

Flash Layout

Layer0 m25p80 spi0.0: w25q128 (16384 KiB)
Layer1 mtd0
routerboot
0x000000000000-0x00000000e000
54 KiB
mtd1
hard_config
0x00000000e000-0x00000000f000
4 KiB
mtd2
bios
0x00000000f000-0x000000010000
4 KiB
mtd3
routerboot2
0x000000010000-0x00000001f000
60 KiB
mtd4
soft_config
0x00000001f000-0x000000020000
4 KiB
mtd5
firmware
0x000000020000-0x000001000000
16256 KiB
Layer2 mtd6
kernel (uimage-fw)
0x000000020000-0x0000001b0000
1600 KiB
mtd7
rootfs (uimage-fw)
0x0000001b0000-0x000001000000
14656 KiB
Layer3 mtd8
rootfs_data (squashfs-split)
0x0000003a0000-0x000001000000
12672 KiB

Photos

hEX Lite hEX Lite hEX Lite hEX Lite hEX Lite

hEX Lite hEX Lite hEX Lite hEX Lite

Opening the case

Case is held together by plastic clips on the bottom of case. To open, using screwdriver push clips in slots outwards, this will release bottom panel.

Switch Ports (for VLANs)

Ports 2-5 directly correspond to ports 2-5 as labeled on the unit, port 1 is the Internet (WAN) on the unit, 0 is the internal connection to the CPU.

Port Switch port
CPU 0
Internet (WAN) 1
LAN 1 2
LAN 2 3
LAN 3 4
LAN 4 5

Bootlogs

OEM bootlog

OpenWrt bootlog

[ 0.000000] Linux version 4.9.109 (buildbot@slashdirt-02) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7270-c49ae68) ) #0 Mon Jun 18 21:23:30 2018 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 00019374 (MIPS 24Kc) [ 0.000000] SoC: Qualcomm Atheros QCA9533 ver 2 rev 0 [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 04000000 @ 00000000 (usable) [ 0.000000] User-defined physical RAM map: [ 0.000000] memory: 04000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. [ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] On node 0 totalpages: 16384 [ 0.000000] free_area_init_node: node 0, pgdat 804d9674, node_mem_map 81000020 [ 0.000000] Normal zone: 128 pages used for memmap [ 0.000000] Normal zone: 0 pages reserved [ 0.000000] Normal zone: 16384 pages, LIFO batch:3 [ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768 [ 0.000000] pcpu-alloc: [0] 0 [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256 [ 0.000000] Kernel command line: no-uart no-nand parts=1 boot_part_size=16777216 gpio=0 HZ=425000000 mem=64M kmac=64:D1:54:74:9A:2D board=750-hb board=750-hb ver=3.36 hw_opt=00084001 boot=1 mlc=10 console=ttyS0,115200 rootfstype=squashfs noinitrd [ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes) [ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) [ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) [ 0.000000] Writing ErrCtl register=00000000 [ 0.000000] Readback ErrCtl register=00000000 [ 0.000000] Memory: 59508K/65536K available (3583K kernel code, 156K rwdata, 844K rodata, 208K init, 217K bss, 6028K reserved, 0K cma-reserved) [ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 [ 0.000000] NR_IRQS:51 [ 0.000000] Clocks: CPU:850.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz [ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4497083404 ns [ 0.000008] sched_clock: 32 bits at 425MHz, resolution 2ns, wraps every 5052902398ns [ 0.008885] Calibrating delay loop... 566.06 BogoMIPS (lpj=2830336) [ 0.071940] pid_max: default: 32768 minimum: 301 [ 0.077275] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.084783] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.095519] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns [ 0.106721] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.114866] NET: Registered protocol family 16 [ 0.124563] MIPS: machine is MikroTik RouterBOARD 750 r2 [ 0.625937] clocksource: Switched to clocksource MIPS [ 0.632746] NET: Registered protocol family 2 [ 0.638598] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.646579] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.653798] TCP: Hash tables configured (established 1024 bind 1024) [ 0.661130] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.667808] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.675208] NET: Registered protocol family 1 [ 0.680231] PCI: CLS 0 bytes, default 32 [ 0.683767] Crashlog allocated RAM at address 0x3f00000 [ 0.690742] workingset: timestamp_bits=30 max_order=14 bucket_order=0 [ 0.704140] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.710804] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.730731] io scheduler noop registered [ 0.735179] io scheduler deadline registered (default) [ 0.741484] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled [ 0.751011] console [ttyS0] disabled [ 0.775225] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A [ 0.785022] console [ttyS0] enabled [ 0.792568] bootconsole [early0] disabled [ 0.807241] m25p80 spi0.0: found w25q128, expected m25p80 [ 0.823712] m25p80 spi0.0: w25q128 (16384 Kbytes) [ 0.829064] Creating 6 MTD partitions on "spi0.0": [ 0.834025] 0x000000000000-0x00000000e000 : "routerboot" [ 0.840971] 0x00000000e000-0x00000000f000 : "hard_config" [ 0.848179] 0x00000000f000-0x000000010000 : "bios" [ 0.854651] 0x000000010000-0x00000001f000 : "routerboot2" [ 0.861876] 0x00000001f000-0x000000020000 : "soft_config" [ 0.869106] 0x000000020000-0x000001000000 : "firmware" [ 0.876509] 2 minor-fw partitions found on MTD device firmware [ 0.882552] 0x000000020000-0x0000001b0000 : "kernel" [ 0.889291] 0x0000001b0000-0x000001000000 : "rootfs" [ 0.896006] mtd: device 7 (rootfs) set to be root filesystem [ 0.901896] 1 squashfs-split partitions found on MTD device rootfs [ 0.908296] 0x0000003a0000-0x000001000000 : "rootfs_data" [ 0.916371] libphy: Fixed MDIO Bus: probed [ 0.938694] libphy: ag71xx_mdio: probed [ 1.568527] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd042, driver=Generic PHY] [ 1.578610] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII [ 2.208486] ag71xx-mdio.1: Found an AR934X built-in switch [ 2.261750] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:GMII [ 2.271649] NET: Registered protocol family 10 [ 2.279229] NET: Registered protocol family 17 [ 2.283885] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this. [ 2.297322] 8021q: 802.1Q VLAN Support v1.8 [ 2.310280] VFS: Mounted root (squashfs filesystem) readonly on device 31:7. [ 2.319035] Freeing unused kernel memory: 208K [ 2.323618] This architecture does not have kernel memory protection. [ 2.545948] random: fast init done [ 2.926049] init: Console is alive [ 2.929827] init: - watchdog - [ 3.710174] kmodloader: loading kernel modules from /etc/modules-boot.d/* [ 3.751672] kmodloader: done loading kernel modules from /etc/modules-boot.d/* [ 3.760327] init: - preinit - [ 4.304878] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 4.332651] random: procd: uninitialized urandom read (4 bytes read) [ 6.419512] eth0: link up (100Mbps/Full duplex) [ 6.424241] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 7.614045] jffs2: notice: (376) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found. [ 7.631869] mount_root: switching to jffs2 overlay [ 7.664131] urandom-seed: Seeding with /etc/urandom.seed [ 7.811428] eth0: link down [ 7.828649] procd: - early - [ 7.831729] procd: - watchdog - [ 8.442568] procd: - watchdog - [ 8.446249] procd: - ubus - [ 8.483977] random: ubusd: uninitialized urandom read (4 bytes read) [ 8.531648] random: ubusd: uninitialized urandom read (4 bytes read) [ 8.538768] random: ubusd: uninitialized urandom read (4 bytes read) [ 8.546200] procd: - init - [ 8.812440] kmodloader: loading kernel modules from /etc/modules.d/* [ 8.823379] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 8.841573] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180 [ 8.849929] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d [ 8.860399] ip_tables: (C) 2000-2006 Netfilter Core Team [ 8.874149] nf_conntrack version 0.5.0 (1024 buckets, 4096 max) [ 8.935840] xt_time: kernel timezone is -0000 [ 8.996422] PPP generic driver version 2.4.2 [ 9.003192] NET: Registered protocol family 24 [ 9.045518] kmodloader: done loading kernel modules from /etc/modules.d/* [ 10.514260] urandom_read: 5 callbacks suppressed [ 10.514268] random: jshn: uninitialized urandom read (4 bytes read) [ 16.392922] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready [ 16.442617] br-lan: port 1(eth1.1) entered blocking state [ 16.448284] br-lan: port 1(eth1.1) entered disabled state [ 16.454235] device eth1.1 entered promiscuous mode [ 16.459237] device eth1 entered promiscuous mode [ 16.495132] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready [ 16.559455] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 18.406305] eth1: link up (1000Mbps/Full duplex) [ 18.440959] eth0: link up (100Mbps/Full duplex) [ 18.536042] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready [ 18.542965] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 18.636163] br-lan: port 1(eth1.1) entered blocking state [ 18.641757] br-lan: port 1(eth1.1) entered forwarding state [ 18.750975] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready


Notes

  • the bootloader installed (Routerboot) is not loading the kernel properly, needs to be reflashed
  • the bootloader is not initializing the serial PINs so the serial console wont work (until bootloader reflash)

Tags

toh/mikrotik/rb750_r2.txt · Last modified: 2018/06/25 18:15 by tmomas