Edimax WAP1750

A Wireless Access Point. See wifi_pro_1750e

It appears to be identical hardware, yet with newer firmware.

Supported via hardware flashing. 19 and 21 tested.

By default, only one ethernet port is working (WAN). This allows for use as an Access Point only. The device has 802.1af POE on WAN.

Put simply, device original firmware is copied with hardware tool such as flashrom and RPI (for backup). Sysupgrade is written into the appropriate place on the existing firmware image, and then the new image is flashed onto the device. UART is required for initial access. Document that explains this here: https://web.archive.org/web/https://git.steakelectronics.com/adminguy/Electronics_Projects_2020/raw/branch/master/Edimax_WAP1750/docs/10.tex

A detailed list of the required steps is the following:

  1. Teardown enclosure
  2. Remove flash chip by desoldering with hot air
  3. Solder onto breakout board
  4. Read firmware with appropriate tool (Flashrom, TL866A).
  5. Patch existing image sysupgrade for Devolo 1700 series.
  6. Write new image
  7. Resolder chip to board
  8. Access board via FTDI / USB-Serial chip

In order to be successful with such a process, experience with soldering, flashrom, and general electronics principles may be necessary.

Patching the ROM is based on: https://forum.openwrt.org/t/debricking-tl-wr1043nd-v4-hard-way-by-external-flashing-solved/7675/6

sudo dd if=lede-17.01.4-ar71xx-generic-tl-wr1043nd-v4-squashfs-sysupgrade.bin of=dump.bin bs=1seek=$((0x20000)) conv=notrunc

Except that here, you will use 0x70000 or whatever your bootlog says. Thanks to the partition map at the devolo page, the bootlog, and also the partitions page here which explains all this:

https://openwrt.org/docs/techref/flash.layout

Another interesting, but not required reading:

https://openwrt.org/docs/techref/flash

If properly connected to the flash chip, flashrom will detect one of two possible chips, and prompt for the correct one. At that point, you should be able to read the chip. Read it multiple times, and verify they are identical with md5sum. If you get unreliable readings, make sure cables to RPI from breakout board are short as possible. Soldering experience may be required. Experience with flashrom may be required.

Since this device has only 1 working ethernet port, you will probably want to configure it to be WAN after logging in and confirming everything works. Here's a config for 21.02 illustrating this:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd8:dd71:9ca7::/48'

config device
        option name 'br-lan'
        option type 'bridge'
#       list ports 'eth0' #note that eth0 is removed from lan ports.
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0'
        option macaddr 'yourmacaddr'
#per changes on notes 21.02 highlights page which
#explains that ifname is now name in device and some other quirks.
#note that list ports is only for bridge type. here you just specify name with ifname...

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

Insert photo of front of the casing

Insert photo of back of the casing

Insert photo of backside label

Insert photo of PCB

Remove four screws on bottom, antenna, and antenna nuts, then:

Hard but no scratch way: plastic spudger to sides, carefully unclipping. Takes 3-5 minutes.

Easy way: screwdriver to side of case. Wedge in, and pry open like you work in a scrapyard doing this all day. Should instantly pop open. Clips may or may not break. Pick the side that is opposite the ethernet ports.

Prepopulated. Not labeled. Recommended that you use a marker to label the pins.

Identical to wifi_pro_1750e

115200, 8N1

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device:
Insert photo of PCB with markings for JTAG port

Once openwrt is installed, you can press the reset button while the device is booting. Watching the serial output, the button can be pressed when it asks for failsafe mode. Connect to the WAN port, and configure an ip in the 192.168.1.0/24 subnet to connect to the WAP at 192.168.1.1.

Default UBoot has no delay, and can't easily be accessed for tftp.

U-Boot 1.1.4-g0695759d-dirty (Apr 24 2014 - 15:57:16) 7479PLC - Scorpion 1.0DRAM: sri Scorpion 1.0 ath_ddr_initial_config(178): (32bit) ddr2 init tap = 0x00000003 Tap (low, high) = (0x6, 0x1d) Tap values = (0x11, 0x11, 0x11, 0x11) 128 MB Flash Manuf Id 0xc2, DeviceId0 0x20, DeviceId1 0x18 Flash [MX25L12845E] sectors: 256 Flash: 16 MB In: serial Out: serial Err: serial Net: ath_gmac_enet_initialize... athrs_sgmii_res_cal: cal value = 0xe Fetching MAC Address from 0x87fed3ec Fetching MAC Address from 0x87fed3ec ath_gmac_enet_initialize: reset mask:c02200 athr_mgmt_init ::done Scorpion ---->8033 PHY* AR8033 PHY init athrs_ar8033_reg_init: Done ffff Max resets limit reached exiting... athr_gmac_sgmii_setup SGMII done : cfg1 0x800c0000 cfg2 0x7214 eth1: 00:aa:bb:cc:dd:01 eth1 up eth1 Setting 0x18116290 to 0x458ba14f Please choose the operation: 1: Load system code to SDRAM via TFTP. 3: Boot system code via Flash (default). 4: Entr boot command line interface. You choosed 3 0 3: System Boot system code via Flash. ## Booting image at 9f070000 ... Image Name: Linux Kernel Image Created: 2020-04-06 7:33:54 UTC Image Type: MIPS Linux Kernel Image (lzma compressed) Data Size: 1656856 Bytes = 1.6 MB Load Address: 80002000 Entry Point: 802d1d30 Verifying Checksum at 0x9f070040 ...OK Uncompressing Kernel Image ... OK Starting kernel ... Linux version 3.2.9 (root@adams-pc) (gcc version 4.3.6 (Buildroot 2013.05) ) #3 Mon Apr 6 15:33:50 CST 2020 bootconsole [early0] enabled CPU revision is: 00019750 (MIPS 74Kc) SoC: QCA955x Clocks: CPU:720.000MHz, DDR:600.000MHz, AHB:200.000MHz, Ref:40.000MHz Determined physical RAM map: memory: 08000000 @ 00000000 (usable) Initrd not found or empty - disabling initrd Zone PFN ranges: Normal 0x00000000 -> 0x00008000 Movable zone start PFN for each node early_node_map[1] active PFN ranges 0: 0x00000000 -> 0x00008000 Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512 Kernel command line: console=ttyS0,115200 root=/dev/ram0 rootfstype=squashfs,jffs2 PID hash table entries: 512 (order: -1, 2048 bytes) Dentry cache hash table entries: 16384 (order: 4, 65536 bytes) Inode-cache hash table entries: 8192 (order: 3, 32768 bytes) Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes Writing ErrCtl register=00000000 Readback ErrCtl register=00000000 Memory: 124864k/131072k available (2915k kernel code, 6208k reserved, 700k data, 1312k init, 0k highmem) SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 NR_IRQS:51 Calibrating delay loop... 359.42 BogoMIPS (lpj=718848) pid_max: default: 32768 minimum: 301 Mount-cache hash table entries: 512 NET: Registered protocol family 16 MIPS: machine is QCA AP registering PCI controller with io_map_base unset ar724x-pci ar724x-pci.1: PCIe link is down registering PCI controller with io_map_base unset bio: create slab <bio-0> at 0 vgaarb: loaded SCSI subsystem initialized usbcore: registered new interface driver usbfs usbcore: registered new interface driver hub usbcore: registered new device driver usb pci 0000:00:00.0: fixup device configuration pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x101fffff 64bit] pci 0000:00:00.0: BAR 0: set to [mem 0x10000000-0x101fffff 64bit] (PCI address [0x10000000-0x101fffff]) pci 0000:00:00.0: BAR 6: assigned [mem 0x10200000-0x1020ffff pref] pci 0000:00:00.0: using irq 40 for pin 1 Switching to clocksource MIPS NET: Registered protocol family 2 IP route cache hash table entries: 1024 (order: 0, 4096 bytes) TCP established hash table entries: 4096 (order: 3, 32768 bytes) TCP bind hash table entries: 4096 (order: 2, 16384 bytes) TCP: Hash tables configured (established 4096 bind 4096) TCP reno registered UDP hash table entries: 256 (order: 0, 4096 bytes) UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) NET: Registered protocol family 1 squashfs: version 4.0 (2009/01/31) Phillip Lougher JFFS2 version 2.2 (NAND) (SUMMARY) (ZLIB) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. msgmni has been set to 243 io scheduler noop registered io scheduler deadline registered io scheduler cfq registered (default) step 0x54e scale 0x8 for 115200 Serial: Atheros High-Speed UART (115200) Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A console [ttyS0] enabled, bootconsole disabled console [ttyS0] enabled, bootconsole disabled loop: module loaded Flash0 Manuf Id 0xc2, DeviceId0 0x20, DeviceId1 0x18 Flash0 MX25L12845E(c2 2018c200) (16384 Kbytes) mtd .name = ath-nor0, .size = 0x01000000 (16M) .erasesize = 0x00010000 (64K) .numeraseregions = 0 Creating 11 MTD partitions on "ath-nor0": 0x000000000000-0x000001000000 : "ALL" 0x000000000000-0x000000040000 : "Bootloader" 0x000000040000-0x000000050000 : "Config" 0x000000050000-0x000000060000 : "ART" 0x000000060000-0x000000070000 : "ART2" 0x000000070000-0x000000c70000 : "Kernel" 0x000000210000-0x000000c70000 : "user" 0x000000c70000-0x000000e70000 : "nms_data" 0x000000e70000-0x000000f70000 : "manufacture" 0x000000f70000-0x000000f80000 : "backup" 0x000000f80000-0x000001000000 : "storage" IMQ driver loaded successfully. (numdevs = 2, numqueues = 1) Hooking IMQ after NAT on PREROUTING. Hooking IMQ before NAT on POSTROUTING. usbcore: registered new interface driver asix usbcore: registered new interface driver cdc_ether usbcore: registered new interface driver net1080 usbcore: registered new interface driver cdc_subset usbcore: registered new interface driver zaurus usbcore: registered new interface driver MOSCHIP usb-ethernet driver cdc_ncm: 04-Aug-2011 usbcore: registered new interface driver cdc_ncm ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver Port Status 1c000004 ath-ehci ath-ehci.0: ATH EHCI ath-ehci ath-ehci.0: new USB bus registered, assigned bus number 1 ath-ehci ath-ehci.0: irq 48, io mem 0x1b000000 ath-ehci ath-ehci.0: USB 2.0 started, EHCI 1.00 usb usb1: New USB device found, idVendor=1d6b, idProduct=0002 usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1 usb usb1: Product: ATH EHCI usb usb1: Manufacturer: Linux 3.2.9 ehci_hcd usb usb1: SerialNumber: platform hub 1-0:1.0: USB hub found hub 1-0:1.0: 1 port detected Port Status 1c000004 ath-ehci1 ath-ehci1.1: ATH EHCI ath-ehci1 ath-ehci1.1: new USB bus registered, assigned bus number 2 ath-ehci1 ath-ehci1.1: irq 49, io mem 0x1b400000 ath-ehci1 ath-ehci1.1: USB 2.0 started, EHCI 1.00 usb usb2: New USB device found, idVendor=1d6b, idProduct=0002 usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1 usb usb2: Product: ATH EHCI usb usb2: Manufacturer: Linux 3.2.9 ehci_hcd usb usb2: SerialNumber: platform hub 2-0:1.0: USB hub found hub 2-0:1.0: 1 port detected ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver uhci_hcd: USB Universal Host Controller Interface driver Initializing USB Mass Storage driver... usbcore: registered new interface driver usb-storage USB Mass Storage support registered. ath_usb_init: ID: 1130 Registered button device:usb1_over, gpio:20,code:257,index:1 Registered button device:reset, gpio:18,code:408,index:10 Registered button device:wps, gpio:16,code:529,index:12 Registered button device:usb_eject, gpio:19,code:256,index:0 u32 classifier Performance counters on Actions configured Netfilter messages via NETLINK v0.30. nf_conntrack version 0.5.0 (256 buckets, 2048 max) ctnetlink v0.93: registering with nfnetlink. xt_time: kernel timezone is -0000 ip_tables: (C) 2000-2006 Netfilter Core Team TCP westwood registered NET: Registered protocol family 10 NET: Registered protocol family 17 NET: Registered protocol family 2 8021q: 802.1Q VLAN Support v1.8


Starting kernel ... [ 0.000000] Linux version 4.14.195 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11208-ce6496d796)) #0 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 00019750 (MIPS 74Kc) [ 0.000000] MIPS: machine is devolo WiFi pro 1750e [ 0.000000] SoC: Qualcomm Atheros QCA9558 ver 1 rev 0 [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 08000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes. [ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x0000000000000000-0x0000000007ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000007ffffff] [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff] [ 0.000000] random: get_random_bytes called from 0x804ff740 with crng_init=0 [ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 32512 [ 0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2 [ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes) [ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes) [ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes) [ 0.000000] Writing ErrCtl register=00000000 [ 0.000000] Readback ErrCtl register=00000000 [ 0.000000] Memory: 123300K/131072K available (4031K kernel code, 160K rwdata, 532K rodata, 1220K init, 212K bss, ) [ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 [ 0.000000] NR_IRQS: 51 [ 0.000000] CPU clock: 720.000 MHz [ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 5309056796 ns [ 0.000008] sched_clock: 32 bits at 360MHz, resolution 2ns, wraps every 5965232126ns [ 0.008303] Calibrating delay loop... 358.80 BogoMIPS (lpj=1794048) [ 0.074992] pid_max: default: 32768 minimum: 301 [ 0.080074] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.087111] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.098188] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns [ 0.108690] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.115230] pinctrl core: initialized pinctrl subsystem [ 0.122654] NET: Registered protocol family 16 [ 0.130211] PCI host bridge /ahb/pcie-controller@180c0000 ranges: [ 0.136742] MEM 0x0000000010000000..0x0000000011ffffff [ 0.142296] IO 0x0000000000000000..0x0000000000000000 [ 0.162181] PCI host bridge to bus 0000:00 [ 0.166547] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff] [ 0.173897] pci_bus 0000:00: root bus resource [io 0x0000] [ 0.179820] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0] [ 0.187051] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff] [ 0.195892] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x101fffff 64bit] [ 0.203719] pci 0000:00:00.0: BAR 6: assigned [mem 0x10200000-0x1020ffff pref] [ 0.213922] clocksource: Switched to clocksource MIPS [ 0.220105] NET: Registered protocol family 2 [ 0.225495] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.232913] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.239723] TCP: Hash tables configured (established 1024 bind 1024) [ 0.246611] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.252836] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.259740] NET: Registered protocol family 1 [ 0.267109] Crashlog allocated RAM at address 0x3f00000 [ 0.273702] workingset: timestamp_bits=30 max_order=15 bucket_order=0 [ 0.284764] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.290965] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.308993] io scheduler noop registered [ 0.313167] io scheduler deadline registered (default) [ 0.318964] ar7200-usb-phy 18030000.usb-phy0: phy reset is missing [ 0.327210] pinctrl-single 1804002c.pinmux: 544 pins at pa b804002c size 68 [ 0.335076] gpio-export gpio_export: 1 gpio(s) exported [ 0.341357] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled [ 0.350126] console [ttyS0] disabled [ 0.353994] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 2500000) is a 16550A [ 0.363164] console [ttyS0] enabled [ 0.363164] console [ttyS0] enabled [ 0.370597] bootconsole [early0] disabled [ 0.370597] bootconsole [early0] disabled [ 0.386548] m25p80 spi0.0: mx25l12805d (16384 Kbytes) [ 0.391715] 5 fixed-partitions partitions found on MTD device spi0.0 [ 0.398197] Creating 5 MTD partitions on "spi0.0": [ 0.403061] 0x000000000000-0x000000040000 : "u-boot" [ 0.408772] 0x000000040000-0x000000050000 : "u-boot-env" [ 0.414802] 0x000000050000-0x000000060000 : "art" [ 0.420170] 0x000000060000-0x000000070000 : "art_bak" [ 0.425975] 0x000000070000-0x000001000000 : "firmware" [ 0.434945] 2 uimage-fw partitions found on MTD device firmware [ 0.440956] Creating 2 MTD partitions on "firmware": [ 0.446030] 0x000000000000-0x000000190000 : "kernel" [ 0.451672] 0x000000190000-0x000000f90000 : "rootfs" [ 0.457309] mtd: device 6 (rootfs) set to be root filesystem [ 0.463090] 1 squashfs-split partitions found on MTD device rootfs [ 0.469402] 0x000000450000-0x000000f90000 : "rootfs_data" [ 0.476460] libphy: Fixed MDIO Bus: probed [ 0.815625] libphy: ag71xx_mdio: probed [ 0.914430] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:04 [uid=004dd072, driver=Atheros 8035 ethernet] [ 0.925198] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: rgmii [ 1.265618] libphy: ag71xx_mdio: probed [ 1.269622] mdio_bus mdio-bus.1: MDIO device at address 1 is missing. [ 1.276254] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe. [ 1.284338] ath79-wdt 18060008.wdt: unable to register misc device, err=-16 [ 1.291413] ath79-wdt: probe of 18060008.wdt failed with error -16 [ 1.299082] NET: Registered protocol family 10 [ 1.307020] Segment Routing with IPv6 [ 1.310816] NET: Registered protocol family 17 [ 1.315409] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load . [ 1.328566] 8021q: 802.1Q VLAN Support v1.8 [ 1.675025] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe. [ 1.682794] hctosys: unable to open rtc device (rtc0) [ 1.694037] VFS: Mounted root (squashfs filesystem) readonly on device 31:6. [ 1.705588] Freeing unused kernel memory: 1220K [ 1.710189] This architecture does not have kernel memory protection. [ 2.418326] init: Console is alive [ 2.421960] init: - watchdog - [ 2.553968] random: fast init done [ 3.611596] kmodloader: loading kernel modules from /etc/modules-boot.d/* [ 3.879039] usbcore: registered new interface driver usbfs [ 3.884726] usbcore: registered new interface driver hub [ 3.890191] usbcore: registered new device driver usb [ 3.900939] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver [ 3.908931] ehci-platform: EHCI generic platform driver [ 3.914492] ehci-platform 1b000000.usb: EHCI Host Controller [ 3.920273] ehci-platform 1b000000.usb: new USB bus registered, assigned bus number 1 [ 3.928310] ehci-platform 1b000000.usb: irq 14, io mem 0x1b000000 [ 3.964003] ehci-platform 1b000000.usb: USB 2.0 started, EHCI 1.00 [ 3.970987] hub 1-0:1.0: USB hub found [ 3.975123] hub 1-0:1.0: 1 port detected [ 3.980054] kmodloader: done loading kernel modules from /etc/modules-boot.d/* [ 3.997794] init: - preinit - [ 4.443960] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe. [ 4.815157] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe. [ 5.178151] random: jshn: uninitialized urandom read (4 bytes read) [ 5.423681] random: jshn: uninitialized urandom read (4 bytes read) [ 5.457059] random: jshn: uninitialized urandom read (4 bytes read) [ 5.622586] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready Press the [f] key and hit [enter] to enter failsafe mode Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level [ 8.927997] jffs2: notice: (478) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 un. [ 8.945820] mount_root: switching to jffs2 overlay [ 8.972678] overlayfs: upper fs does not support tmpfile. [ 8.983615] urandom-seed: Seeding with /etc/urandom.seed [ 9.094559] procd: - early - [ 9.097567] procd: - watchdog - [ 9.766775] procd: - watchdog - [ 9.770225] procd: - ubus - [ 9.832408] urandom_read: 5 callbacks suppressed [ 9.832415] random: ubusd: uninitialized urandom read (4 bytes read) [ 9.960933] random: ubusd: uninitialized urandom read (4 bytes read) [ 9.968514] procd: - init - Please press Enter to activate this console. [ 10.828233] kmodloader: loading kernel modules from /etc/modules.d/* [ 10.849136] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 10.870725] Loading modules backported from Linux version v4.19.137-0-gc076c79e03c6 [ 10.878536] Backport generated by backports.git v4.19.137-1-0-g60c3a249 [ 10.905875] ip_tables: (C) 2000-2006 Netfilter Core Team [ 10.930622] nf_conntrack version 0.5.0 (2048 buckets, 8192 max) [ 11.027637] xt_time: kernel timezone is -0000 [ 11.071285] urngd: v1.0.2 started. [ 11.126101] PPP generic driver version 2.4.2 [ 11.134759] NET: Registered protocol family 24 [ 11.186532] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x3c. [ 11.214666] PCI: Enabling device 0000:00:00.0 (0000 -> 0002) [ 11.220572] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0 [ 11.311789] random: crng init done [ 11.534319] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error 2 [ 11.545027] ath10k_pci 0000:00:00.0: Falling back to user helper [ 11.838987] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed [ 11.848185] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with erro2 [ 11.859073] ath10k_pci 0000:00:00.0: Falling back to user helper [ 12.233100] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed [ 12.243665] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with e2 [ 12.254825] ath10k_pci 0000:00:00.0: Falling back to user helper [ 12.629070] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed [ 12.638696] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with e2 [ 12.649841] ath10k_pci 0000:00:00.0: Falling back to user helper [ 12.921285] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed [ 12.930912] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with erro2 [ 12.941800] ath10k_pci 0000:00:00.0: Falling back to user helper [ 13.124335] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed [ 13.133653] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with erro2 [ 13.144539] ath10k_pci 0000:00:00.0: Falling back to user helper [ 13.324356] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed [ 13.333676] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with erro2 [ 13.344563] ath10k_pci 0000:00:00.0: Falling back to user helper [ 13.526489] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed [ 13.535860] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with erro2 [ 13.546746] ath10k_pci 0000:00:00.0: Falling back to user helper [ 13.728451] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed [ 13.941773] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000 [ 13.951179] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0 [ 13.963616] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-538f0906 api 2 features wmi-10.x,has-wmi-mgm4 [ 14.016038] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2 [ 14.026646] ath10k_pci 0000:00:00.0: Falling back to user helper [ 14.119630] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed [ 14.128890] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08 [ 15.071823] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256 [ 15.088593] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410' [ 15.094936] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0' [ 15.103064] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20984 iram: 25656' [ 15.152909] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1 [ 15.165817] ath10k_pci 0000:00:00.0: NOTE: Firmware DBGLOG output disabled in debug_mask: 0x10000000 [ 15.399065] ieee80211 phy1: Atheros AR9550 Rev:0 mem=0xb8100000, irq=13 [ 15.482638] kmodloader: done loading kernel modules from /etc/modules.d/* [ 15.709431] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe. [ 16.055093] ag71xx 1a000000.eth: Could not connect to PHY device. Deferring probe.


Additional footprint for SOIC8 is underneath the main 16-pin footprint for MX25L12845E.

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2024/02/12 08:58
  • by 127.0.0.1