User Tools

Site Tools


toh:comtrend:ar5315u

Comtrend AR-5315u

Supported Versions

DSL will not work at all on devices with BCM63xx DSL chipset (due to unavailability of FLOSS driver for Broadcom chips). Consider this when chosing a device to buy, or when deciding to flash OpenWrt on your device because it is listed as supported.
See broadcom_dsl, dsl_modem and soc.broadcom.bcm63xx for details.

Devices with Broadcom WiFi chipsets have limited OpenWrt supportability (due to limited FLOSS driver availability for Broadcom chips). Consider this when chosing a device to buy, or when deciding to flash OpenWrt on your device because it is listed as supported. See broadcom_wifi for details.

Hardware Highlights

ModelVersionSoCCPU MHzFlash MBRAM MBWLAN HardwareWLAN2.4WLAN5.0100M portsGbit portsModemUSB
AR-5315uBroadcom BCM63183331664Broadcom BCM43217b/g/n-4-ADSL1x 2.0

Installation

OEM easy install

Use the router's web interface, look for firmware upgrade page, select the *-AR5315u-squashfs-cfe.bin firmware and proceed.

Flashing via bootloader web

With this procedure you will flash the firmware using the bootloader web interface (foolproof)

  • Set a static IP on your computer, use 192.168.1.35 (or any compatible), and connect the ethernet cable to the router.
  • Unplug the router's power cord
  • Press the button labeled as RESET, don't release it yet!
  • Plug the power cord
  • Wait 6 seconds or more until the power LED stays red fixed
  • Release the RESET button
  • Browse to http://192.168.1.1 and you should see this screen:
  • Select .bin firmware
  • Press Update Software to start the firmware update process
  • Wait for it to reboot
  • Telnet / ssh to 192.168.1.1 and set a root password, or browse to http://192.168.1.1 if LuCI is installed.

Specific Configuration

Interfaces

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN & WiFi 192.168.1.1/24
eth0 LAN ports (0 to 3) bridged
wlan0 WiFi bridged (disabled)

Switch Ports (for VLANs)

This is an example to configure the switch: numbers 0-2 will be lan, labeled as Ports LAN2, LAN3, LAN4, on the unit, LAN1 will be the Internet (WAN), 8 is the internal connection to the router itself. Don't be fooled: vlan1 = eth0.1, vlan2 = eth0.2 and so on.

Port Switch port Mode
LAN1 3 lan
LAN2 2 lan
LAN3 1 lan
LAN4 0 Internet (WAN)
# 
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda5:ace8:376d::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        
config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 8t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '3 8t'

Hardware

Info

Instruction set: MIPS
Vendor: Broadcom
bootloader: cfe
Board ID: 96318A-1441N1
System-On-Chip: Broadcom BCM6318
CPU @Frq BMIPS3300 V3.3 @333 MHz
Flash-Chip: Winbond W25Q128FVFG (SPI) / 64KB block size x 256 main blocks
Flash size 16 MiB
RAM-Chip EtronTech EM6AB160TSD-5G / DDR-400
RAM size 64 MiB
Wireless BCM43217 802.11b/g/n (onboard)
Switch: Internal BRCM6318 Switch, 4x 100M
USB 1x 2.0
PSU 12V DC 1A / F12W-120100SPAV / ITE PU120485-5FC
Serial: Yes
JTAG: ?

Photos

Photo of front and back of the casing:

Opening the case

Note: This will void your warranty!

  • Describe how to open the cover.

Main PCB:

Wifi

BCM43217 802.11b/g/n onboard wifi, 2x external non-detachable antennas.

In OpenWrt the kmod-b43 driver should be used, therefore N mode isn't available. kmod-bcmsmac could support N mode but isn't still supported for the BCM43217 wifi.

No physical EEPROM at the board, nor partition reserverd for this data at the flash chip. In theory, in the original firmware, the EEPROM is taken from the file /etc/wlan/bcm43217_map.bin, although some bytes differ when comparing with wlctl dumps.

Dumps from the OEM firmware:

# wlctl revinfo vendorid 0x14e4 deviceid 0x43a9 radiorev 0xe2057000 chipnum 0xa8d1 chiprev 0x1 chippackage 0x9 corerev 0x1e boardid 0x5e9 boardvendor 0x14e4 boardrev P255 driverrev 0x61e6607 ucoderev 0x3100002 bus 0x1 phytype 0x4 phyrev 0x11 anarev 0x0 # wlctl srdump srom[000]: 0x2801 0x0000 0x05e9 0x14e4 0x0070 0xedbe 0x1c00 0x2bc4 srom[008]: 0x2a64 0x2964 0x2c64 0x3ce7 0x46ff 0x47ff 0x0c00 0x0820 srom[016]: 0x0030 0x1002 0x9f28 0x5d44 0x8080 0x1d8f 0x0032 0x0100 srom[024]: 0xdf00 0x71f5 0x8400 0x0083 0x8500 0x2010 0x0001 0x0000 srom[032]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[040]: 0x0000 0x0000 0x1008 0x0305 0x0000 0x0000 0x0000 0x0000 srom[048]: 0x43a9 0x8000 0x0002 0x0000 0x1f30 0x1800 0x0000 0x0000 srom[056]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[064]: 0x5372 0x1255 0x0200 0x0000 0x9800 0x0000 0x0000 0x0000 srom[072]: 0x0000 0x0000 0x0003 0xffff 0x88ff 0xffff 0x0003 0x0202 srom[080]: 0xffff 0x0033 0x0000 0x0000 0x0000 0x0000 0x0000 0x0415 srom[088]: 0x0000 0x7800 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[096]: 0x204c 0xfe55 0x171d 0xfa42 0x0000 0x0000 0x0000 0x0000 srom[104]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[112]: 0x204c 0xfeb7 0x18cd 0xfa4f 0x0000 0x0000 0x0000 0x0000 srom[120]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[128]: 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff srom[136]: 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff srom[144]: 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff srom[152]: 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff srom[160]: 0x0000 0x4444 0x6444 0x0000 0x0000 0x0000 0x0000 0x0000 srom[168]: 0x0000 0x4444 0x6444 0x4444 0x6444 0x6666 0x6666 0x6666 srom[176]: 0x6666 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[184]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[192]: 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 srom[200]: 0x0000 0x0000 0x0000 0x0000 0x0000 0xffff 0xffff 0xffff srom[208]: 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff 0xffff srom[216]: 0xffff 0xffff 0xffff 0x7a08 # # wlctl nvram_dump sromrev=8 boardrev=0x1255 boardflags=0x200 boardflags2=0x9800 boardtype=0x5e9 subvid=0x14e4 boardnum=0 regrev=3 ledbh3=136 pa0b0=0xfe55 pa0b1=0x171d pa0b2=0xfa42 pa0itssit=32 pa0maxpwr=76 opo=68 aa2g=3 aa5g=0 ag0=2 ag1=2 ag2=255 ag3=255 pa1b0=0x0 pa1b1=0x0 pa1b2=0x0 pa1lob0=0x0 pa1lob1=0x0 pa1lob2=0x0 pa1hib0=0x0 pa1hib1=0x0 pa1hib2=0x0 pa1itssit=0 pa1maxpwr=0 pa1lomaxpwr=0 pa1himaxpwr=0 bxa2g=0 rssisav2g=0 rssismc2g=0 rssismf2g=0 bxa5g=0 rssisav5g=0 rssismc5g=0 rssismf5g=0 tri2g=0 tri5g=0 tri5gl=0 tri5gh=0 rxpo2g=0 rxpo5g=0 txchain=3 rxchain=3 antswitch=0 tssipos2g=1 extpagain2g=2 pdetrange2g=2 triso2g=4 antswctl2g=0 tssipos5g=0 extpagain5g=0 pdetrange5g=0 triso5g=0 antswctl5g=0 ccode= macaddr=d8:b6:b7:00:a3:2c tempthresh=120 tempoffset=0 rawtempsense=0x0 measpower=0x0 tempsense_slope=0x0 tempcorrx=0x0 tempsense_option=0x0 freqoffset_corr=0x0 iqcal_swp_dis=0x0 hw_iqcal_en=0x0 elna2g=0 elna5g=0 phycal_tempdelta=0 temps_period=0 temps_hysteresis=0 measpower1=0x0 measpower2=0x0 cck2gpo=0 ofdm2gpo=1682195524 ofdm5gpo=0 ofdm5glpo=0 ofdm5ghpo=0 mcs2gpo0=17476 mcs2gpo1=25668 mcs2gpo2=17476 mcs2gpo3=25668 mcs2gpo4=26214 mcs2gpo5=26214 mcs2gpo6=26214 mcs2gpo7=26214 mcs5gpo0=0 mcs5gpo1=0 mcs5gpo2=0 mcs5gpo3=0 mcs5gpo4=0 mcs5gpo5=0 mcs5gpo6=0 mcs5gpo7=0 mcs5glpo0=0 mcs5glpo1=0 mcs5glpo2=0 mcs5glpo3=0 mcs5glpo4=0 mcs5glpo5=0 mcs5glpo6=0 mcs5glpo7=0 mcs5ghpo0=0 mcs5ghpo1=0 mcs5ghpo2=0 mcs5ghpo3=0 mcs5ghpo4=0 mcs5ghpo5=0 mcs5ghpo6=0 mcs5ghpo7=0 cddpo=0 stbcpo=0 bw40po=0 bwduppo=0 pcieingress_war=15 rxgainerr2ga0=63 rxgainerr2ga1=31 rxgainerr2ga2=31 rxgainerr5gla0=63 rxgainerr5gla1=31 rxgainerr5gla2=31 rxgainerr5gma0=63 rxgainerr5gma1=31 rxgainerr5gma2=31 rxgainerr5gha0=63 rxgainerr5gha1=31 rxgainerr5gha2=31 rxgainerr5gua0=63 rxgainerr5gua1=31 rxgainerr5gua2=31 noiselvl2ga0=31 noiselvl2ga1=31 noiselvl2ga2=31 noiselvl5gla0=31 noiselvl5gla1=31 noiselvl5gla2=31 noiselvl5gma0=31 noiselvl5gma1=31 noiselvl5gma2=31 noiselvl5gha0=31 noiselvl5gha1=31 noiselvl5gha2=31 noiselvl5gua0=31 noiselvl5gua1=31 noiselvl5gua2=31 subband5gver=7 maxp2ga0=76 itt2ga0=32 itt5ga0=0 pa2gw0a0=0xfe55 pa2gw1a0=0x171d pa2gw2a0=0xfa42 maxp5ga0=0 maxp5gha0=0 maxp5gla0=0 pa5gw0a0=0x0 pa5gw1a0=0x0 pa5gw2a0=0x0 pa5glw0a0=0x0 pa5glw1a0=0x0 pa5glw2a0=0x0 pa5ghw0a0=0x0 pa5ghw1a0=0x0 pa5ghw2a0=0x0 maxp2ga1=76 itt2ga1=32 itt5ga1=0 pa2gw0a1=0xfeb7 pa2gw1a1=0x18cd pa2gw2a1=0xfa4f maxp5ga1=0 maxp5gha1=0 maxp5gla1=0 pa5gw0a1=0x0 pa5gw1a1=0x0 pa5gw2a1=0x0 pa5glw0a1=0x0 pa5glw1a1=0x0 pa5glw2a1=0x0 pa5ghw0a1=0x0 pa5ghw1a1=0x0 pa5ghw2a1=0x0 maxp2ga2=255 itt2ga2=255 itt5ga2=255 pa2gw0a2=0xffff pa2gw1a2=0xffff pa2gw2a2=0xffff maxp5ga2=255 maxp5gha2=255 maxp5gla2=255 pa5gw0a2=0xffff pa5gw1a2=0xffff pa5gw2a2=0xffff pa5glw0a2=0xffff pa5glw1a2=0xffff pa5glw2a2=0xffff pa5ghw0a2=0xffff pa5ghw1a2=0xffff pa5ghw2a2=0xffff maxp2ga3=255 itt2ga3=255 itt5ga3=255 pa2gw0a3=0xffff pa2gw1a3=0xffff pa2gw2a3=0xffff maxp5ga3=255 maxp5gha3=255 maxp5gla3=255 pa5gw0a3=0xffff pa5gw1a3=0xffff pa5gw2a3=0xffff pa5glw0a3=0xffff pa5glw1a3=0xffff pa5glw2a3=0xffff pa5ghw0a3=0xffff pa5ghw1a3=0xffff pa5ghw2a3=0xffff devid=0x43a9


JTAG

port.jtag general information about the JTAG port, JTAG cable, etc.

N/A

Serial

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device:

Only connect GND, TX and RX

Baud rate: 115200

GPIOs

GPIO Pin Description
0 LED WPS
1 LED POWER green
2 LED USB
3 BUTTON WPS
4 LED LAN4
5 LED LAN3
6 LED LAN2
7 LED LAN1
8 LED Internet green
9 LED Internet red
10 LED DSL
11 LED POWER red
33 BUTTON RESET

Bootlogs

OEM Bootlog

HELO CPUI L1CI DRAM ---- PHYS PHYE DDR1 333H SIZ3 RACE PASS ---- ZBSS CODE DATA L12F MAIN CFE version 1.0.38-112.118-15 for BCM96318 (32bit,SP,BE) Build Date: �� 11 21:08:50 CST 2013 (joba@SW1-BCM-02) Copyright (C) 2000-2011 Broadcom Corporation. HS Serial flash device: name ID_W25X128, id 0xef18 size 16384KB Total Flash size: 16384K with 4096 sectors Flash not used for Auxillary File System Chip ID: BCM6318B0, MIPS: 333MHz, DDR: 333MHz, Bus: 166MHz Main Thread: TP0 Total Memory: 67108864 bytes (64MB) Boot Address: 0xb8000000 ##checkForResetToDefaultHold:791## Board IP address : 192.168.1.1:ffffff00 Host IP address : 192.168.1.100 Gateway IP address : Run from flash/host (f/h) : f Default host run file name : vmlinux Default host flash file name : bcm963xx_fs_kernel Boot delay (0-9 seconds) : 1 Board Id (0-5) : 96318A-1441N1 Number of MAC Addresses (1-32) : 32 Base MAC Address : d8:b6:b7:00:de:ad PSI Size (1-64) KBytes : 24 Enable Backup PSI [0|1] : 1 System Log Size (0-256) KBytes : 0 Auxillary File System Size Percent: 0 Main Thread Number [0|1] : 0 WLAN Password : 4HykRJrxdeWpCUc3qDAc Serial Number : 1535315UXXF-BA009114 *** Press any key to stop auto run (1 seconds) *** Auto run second count down: 1 Port 3 link UP 0 Booting from only image (0xb8010000) ... Code Address: 0x80010000, Entry Address: 0x802a4580 Decompression OK! Entry at 0x802a4580 Closing network. Disabling Switch ports. Flushing Receive Buffers... 0 buffers found. Closing DMA Channels. Starting program at 0x802a4580 Linux version 2.6.30 (camille@SW1-BCM-01) (gcc version 4.4.2 (Buildroot 2010.02-git) ) #2 Fri Oct 3 09:40:51 CST 2014 HS Serial flash device: name ID_W25X128, id 0xef18 size 16384KB 96318A-1441N1 prom init CPU revision is: 00029033 (Broadcom BCM3302) DSL SDRAM reserved: 0xc0000 Determined physical RAM map: memory: 03f40000 @ 00000000 (usable) Zone PFN ranges: DMA 0x00000000 -> 0x00001000 Normal 0x00001000 -> 0x00003f40 Movable zone start PFN for each node early_node_map[1] active PFN ranges 0: 0x00000000 -> 0x00003f40 On node 0 totalpages: 16192 free_area_init_node: node 0, pgdat 80330dd0, node_mem_map 81000000 DMA zone: 32 pages used for memmap DMA zone: 0 pages reserved DMA zone: 4064 pages, LIFO batch:0 Normal zone: 95 pages used for memmap Normal zone: 12001 pages, LIFO batch:1 Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16065 Kernel command line: root=31:0 ro noinitrd console=ttyS0,115200 Primary instruction cache 64kB, VIPT, 4-way, linesize 16 bytes. Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes NR_IRQS:128 PID hash table entries: 256 (order: 8, 1024 bytes) console [ttyS0] enabled Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) Memory: 60568k/64768k available (2665k kernel code, 4180k reserved, 544k data, 124k init, 0k highmem) Calibrating delay loop... 331.77 BogoMIPS (lpj=165888) Mount-cache hash table entries: 512 --Kernel Config-- SMP=0 PREEMPT=0 DEBUG_SPINLOCK=0 DEBUG_MUTEXES=0 Broadcom Logger v0.1 Oct 2 2014 16:18:33 net_namespace: 816 bytes NET: Registered protocol family 16 Total Flash size: 16384K with 4096 sectors ==== chipRev b0 ==== registering PCI controller with io_map_base unset registering PCI controller with io_map_base unset bio: create slab <bio-0> at 0 SCSI subsystem initialized usbcore: registered new interface driver usbfs usbcore: registered new interface driver hub usbcore: registered new device driver usb pci 0000:00:09.0: reg 10 32bit mmio: [0x10005100-0x100051ff] pci 0000:00:0a.0: reg 10 32bit mmio: [0x10005000-0x100050ff] pci 0000:01:00.0: PME# supported from D0 D3hot pci 0000:01:00.0: PME# disabled pci 0000:02:00.0: reg 10 64bit mmio: [0x000000-0x007fff] pci 0000:02:00.0: supports D1 D2 pci 0000:01:00.0: PCI bridge, secondary bus 0000:02 pci 0000:01:00.0: IO window: disabled pci 0000:01:00.0: MEM window: 0x10200000-0x102fffff pci 0000:01:00.0: PREFETCH window: disabled PCI: Enabling device 0000:01:00.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:01:00.0 to 64 BLOG v3.0 Initialized BLOG Rule v1.0 Initialized Broadcom IQoS v0.1 Oct 2 2014 16:20:54 initialized Broadcom GBPM v0.1 Oct 2 2014 16:20:54 initialized NET: Registered protocol family 8 NET: Registered protocol family 20 NET: Registered protocol family 2 IP route cache hash table entries: 1024 (order: 0, 4096 bytes) TCP established hash table entries: 2048 (order: 2, 16384 bytes) TCP bind hash table entries: 2048 (order: 1, 8192 bytes) TCP: Hash tables configured (established 2048 bind 2048) TCP reno registered NET: Registered protocol family 1 squashfs: version 4.0 (2009/01/31) Phillip Lougher squashfs: version 4.0 with LZMA457 ported by BRCM fuse init (API version 7.11) msgmni has been set to 118 io scheduler noop registered (default) pcieport-driver 0000:01:00.0: device [14e4:6318] has invalid IRQ; check vendor BIOS PCI: Setting latency timer of device 0000:01:00.0 to 64 Driver 'sd' needs updating - please use bus_type methods Driver 'sr' needs updating - please use bus_type methods PPP generic driver version 2.4.2 PPP Deflate Compression module registered PPP BSD Compression module registered NET: Registered protocol family 24 bcm963xx_mtd driver v1.0 File system address: 0xb8010100 ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver PCI: Enabling device 0000:00:0a.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:00:0a.0 to 64 ehci_hcd 0000:00:0a.0: EHCI Host Controller ehci_hcd 0000:00:0a.0: new USB bus registered, assigned bus number 1 ehci_hcd 0000:00:0a.0: Enabling legacy PCI PM ehci_hcd 0000:00:0a.0: irq 50, io mem 0x10005000 ehci_hcd 0000:00:0a.0: USB f.f started, EHCI 1.00 usb usb1: configuration #1 chosen from 1 choice hub 1-0:1.0: USB hub found hub 1-0:1.0: 1 port detected @@@@@ hub_power_on:541 @@@@@ ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver PCI: Enabling device 0000:00:09.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:00:09.0 to 64 ohci_hcd 0000:00:09.0: OHCI Host Controller ohci_hcd 0000:00:09.0: new USB bus registered, assigned bus number 2 ohci_hcd 0000:00:09.0: irq 49, io mem 0x10005100 usb usb2: configuration #1 chosen from 1 choice hub 2-0:1.0: USB hub found hub 2-0:1.0: 1 port detected @@@@@ hub_power_on:541 @@@@@ usbcore: registered new interface driver usblp Initializing USB Mass Storage driver... usbcore: registered new interface driver usb-storage USB Mass Storage support registered. brcmboard: brcm_board_init entry SES: Button Polling is enabled on gpio 8003 SES: LED GPIO 0x8000 is enabled Serial: BCM63XX driver $Revision: 3.00 $ Magic SysRq enabled (type ^ h for list of supported commands) ttyS0 at MMIO 0xb0000100 (irq = 36) is a BCM63XX Total # RxBds=2698 bcmPktDmaBds_init: Broadcom Packet DMA BDs initialized bcmxtmrt: Broadcom BCM6318B0 ATM/PTM Network Device v0.4 Oct 2 2014 16:20:40 GACT probability NOT on Mirror/redirect action on u32 classifier input device check on Actions configured TCP cubic registered Initializing XFRM netlink socket NET: Registered protocol family 17 NET: Registered protocol family 15 Initializing MCPD Module Ebtables v2.0 registered ebt_time registered ebt_ftos registered ebt_wmm_mark registered 802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com> All bugs added by David S. Miller <davem@redhat.com> VFS: Mounted root (squashfs filesystem) readonly on device 31:0. Freeing unused kernel memory: 124k freed init started: BusyBox v1.17.2 (2014-10-02 16:23:31 CST) starting pid 192, tty '': '/etc/init.d/rcS' usbfs: unrecognised mount option "defaults" or missing value usbfs: mount parameter error. mount: mounting /dev/sda1 on /mnt failed: No such device or address starting pid 201, tty '': '-/bin/sh' BusyBox v1.17.2 (2014-10-02 16:23:31 CST) built-in shell (ash) Enter 'help' for a list of built-in commands. Loading drivers and kernel modules... -/bin/sh: ct_hotplug_monitor: not found chipinfo: module license 'proprietary' taints kernel. Disabling lock debugging due to kernel taint brcmchipinfo: brcm_chipinfo_init entry BPM: tot_mem_size=67108864B (64MB), buf_mem_size=10066320B (9MB), num of buffers=4766, buf size=2112 Broadcom BPM Module Char Driver v0.1 Oct 2 2014 16:18:53 Registered<244> [NTC bpm] bpm_set_status: BPM status : enabled NBUFF v1.0 Initialized Initialized fcache state Broadcom Packet Flow Cache Char Driver v2.2 Oct 2 2014 16:18:53 Registered<242> Created Proc FS /procfs/fcache Broadcom Packet Flow Cache registered with netdev chain Broadcom Packet Flow Cache learning via BLOG enabled. Constructed Broadcom Packet Flow Cache v2.2 Oct 2 2014 16:18:53 bcmxtmcfg: bcmxtmcfg_init entry adsl: adsl_init entry Broadcom BCM6318B0 Ethernet Network Device v0.1 Oct 2 2014 16:20:35 ETH Init: Ch:0 - 200 tx BDs at 0xa394b000 ETH Init: Ch:1 - 200 tx BDs at 0xa3ba6000 ETH Init: Ch:0 - 1906 rx BDs at 0xa3894000 ETH Init: Ch:1 - 100 rx BDs at 0xa2999400 dgasp: kerSysRegisterDyingGaspHandler: bcmsw registered eth3: MAC Address: D8:B6:B7:00:DE:AD eth2: MAC Address: D8:B6:B7:00:DE:AD eth1: MAC Address: D8:B6:B7:00:DE:AD eth0: MAC Address: D8:B6:B7:00:DE:AD [NTC arl] arlEnable : Enabled ARL binding to Flow Cache Broadcom Adress Resolution Logic Processor (ARL) Char Driver v0.1 Oct 2 2014 16:18:52 Registered <245> wl: dsl_tx_pkt_flush_len=338 wl: high_wmark_tot=3097 PCI: Enabling device 0000:02:00.0 (0000 -> 0002) PCI: Setting latency timer of device 0000:02:00.0 to 64 wl: passivemode=1 wl: napimode=0 wl0: allocskbmode=1 currallocskbsz=256 Neither SPROM nor OTP has valid image wl:srom/otp not programmed, using main memory mapped srom info(wombo board) wl:loading /etc/wlan/bcm43217_map.bin srom rev:8 wl: reading /etc/wlan/bcmcmn_nvramvars.bin, file size=16 wl0: Broadcom BCMa8db 802.11 Wireless Controller 6.30.102.7.cpe4.12L06B.1 dgasp: kerSysRegisterDyingGaspHandler: wl0 registered eth0 Link UP 100 mbps full duplex message received before monitor task is initialized kerSysSendtoMonitorTask Broadcom 802.1Q VLAN Interface, v0.1 /proc/vlanctl_data created usbcore: registered new interface driver usbserial USB Serial support registered for generic usbcore: registered new interface driver usbserial_generic usbserial: USB Serial Driver core USB Serial support registered for GSM modem (1-port) usbcore: registered new interface driver option option: v0.7.2:USB Driver for GSM modems hso_init - tty_register_driver failed(-16) insmod: can't insert '/lib/modules/2.6.30/kernel/drivers/usb/serial/hso.ko': Device or resource busy ===== Comtrend Release Version UC31-412JAZ-C01_R05 ===== Done. Done. Done. killall: syslogd: no process killed wait instruction: enabled Energy Efficient Ethernet is disabled Adaptive Voltage Scaling is now enabled smtpEnblSsl 0 BcmPwrMngtEnableAvs: AVS_START, 0x8391e4c8 eth0 Link DOWN. message received before monitor task is initialized kerSysSendtoMonitorTask ip_tables: (C) 2000-2006 Netfilter Core Team Auto-negotiation enabled. The autonegotiated media type is 100baseTx-FD. Link is up device eth0 entered promiscuous mode eth0 Link UP 100 mbps full duplex message received before monitor task is initialized kerSysSendtoMonitorTask br0: port 1(eth0) entering forwarding state Auto-negotiation enabled. Link is down device eth1 entered promiscuous mode Auto-negotiation enabled. Link is down device eth2 entered promiscuous mode Auto-negotiation enabled. Link is down device eth3 entered promiscuous mode device wl0 entered promiscuous mode br0: port 5(wl0) entering forwarding state *** dslThread dslPid=651 BcmAdsl_Initialize=0xC00FC258, g_pFnNotifyCallback=0xC0127964 WLmngr Daemon is running optarg=0 shmId=0 pSdramPHY=0xA3FFFFF8, 0x78A65 0xDEADBEEF *** XfaceOffset: 0x1C790 => 0x1C790 *** wlevt is ready for new msg... *** PhySdramSize got adjusted: 0x90B90 => 0xA6C5C *** AdslCoreSharedMemInit: shareMemSize=103293(103296) AdslCoreHwReset: pLocSbSta=81b10000 bkupThreshold=1600 AdslCoreHwReset: AdslOemDataAddr = 0xA3FC563C ***BcmDiagsMgrRegisterClient: 0 *** dgasp: kerSysRegisterDyingGaspHandler: dsl0 registered XTM Init: Ch:0 - 476 rx BDs at 0xa1e1a000 XTM Init: Ch:1 - 16 rx BDs at 0xa1e53c80 bcmxtmrt: PTM/ATM Non-Bonding Mode configured in system bcmxtmcfg: gulBondDslMonitorValid = 1 Register interface ppp0.1 !! Register interface ppp0.2 !! monitor task is initialized pid= 308 There is no Predefined DevicePin in CFE WPS Device PIN = 18811728 br0: port 5(wl0) entering disabled state device wl0 left promiscuous mode br0: port 5(wl0) entering disabled state device wl0 entered promiscuous mode br0: port 5(wl0) entering forwarding state br0: port 5(wl0) entering disabled state Setting SSID: "JAZZTEL_A32C" Setting SSID: "wl0_Guest1" Setting SSID: "wl0_Guest2" Setting SSID: "wl0_Guest3" wlctl: Unsupported device wl0 left promiscuous mode br0: port 5(wl0) entering disabled state device wl0 entered promiscuous mode br0: port 5(wl0) entering forwarding state acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: scan in progress ... acsd: selected channel spec: 0x1006 BCM96318 Broadband Router Login: admin Password: > ping echo $(/bin/sh > /dev/tty) BusyBox v1.17.2 (2014-10-02 16:23:31 CST) built-in shell (ash) Enter 'help' for a list of built-in commands. # cat /proc/cpuinfo system type : 96318A-1441N1 processor : 0 cpu model : Broadcom BCM3302 V3.3 BogoMIPS : 331.77 wait instruction : yes microsecond timers : yes tlb_entries : 32 extra interrupt vector : no hardware watchpoint : no ASEs implemented : shadow register sets : 1 core : 0 VCED exceptions : not available VCEI exceptions : not available unaligned exceptions : 252 #


OpenWrt

HELO CPUI L1CI DRAM ---- PHYS PHYE DDR1 333H SIZ3 RACE PASS ---- ZBSS CODE DATA L12F MAIN CFE version 1.0.38-112.118-15 for BCM96318 (32bit,SP,BE) Build Date: �� 11 21:08:50 CST 2013 (joba@SW1-BCM-02) Copyright (C) 2000-2011 Broadcom Corporation. HS Serial flash device: name ID_W25X128, id 0xef18 size 16384KB Total Flash size: 16384K with 4096 sectors Flash not used for Auxillary File System Chip ID: BCM6318B0, MIPS: 333MHz, DDR: 333MHz, Bus: 166MHz Main Thread: TP0 Total Memory: 67108864 bytes (64MB) Boot Address: 0xb8000000 ##checkForResetToDefaultHold:791## Board IP address : 192.168.1.1:ffffff00 Host IP address : 192.168.1.100 Gateway IP address : Run from flash/host (f/h) : f Default host run file name : vmlinux Default host flash file name : bcm963xx_fs_kernel Boot delay (0-9 seconds) : 1 Board Id (0-5) : 96318A-1441N1 Number of MAC Addresses (1-32) : 32 Base MAC Address : d8:b6:b7:00:de:ad PSI Size (1-64) KBytes : 24 Enable Backup PSI [0|1] : 1 System Log Size (0-256) KBytes : 0 Auxillary File System Size Percent: 0 Main Thread Number [0|1] : 0 WLAN Password : 4HykRJrxdeWpCUc3qDAc Serial Number : 1535315UXXF-BA009114 *** Press any key to stop auto run (1 seconds) *** Auto run second count down: 1 Port 3 link UP 0 Booting from only image (0xb8010000) ... Code Address: 0x80A00000, Entry Address: 0x80a00000 LZMA: Prossible old LZMA format, trying to decompress.. Decompression OK! Entry at 0x80a00000 Closing network. Disabling Switch ports. Flushing Receive Buffers... 6 buffers found. Closing DMA Channels. Starting program at 0x80a00000 [ 0.000000] Linux version 4.4.50 (dani@tool) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3615-a732f69) ) #0 Thu Mar 2 13:03:55 2017 [ 0.000000] strap_override_bus = fffdffff [ 0.000000] Detected Broadcom 0x6318 CPU revision b0 [ 0.000000] CPU frequency is 333 MHz [ 0.000000] 64MB of RAM installed [ 0.000000] board_bcm963xx: Boot address 0xb8000000 [ 0.000000] board_bcm963xx: CFE version: 1.0.38-112.118-15 [ 0.000000] bootconsole [early0] enabled [ 0.000000] CPU0 revision is: 00029033 (Broadcom BMIPS3300) [ 0.000000] board: board name: 96318A-1441N1 [ 0.000000] MIPS: machine is Comtrend AR-5315u [ 0.000000] Determined physical RAM map: [ 0.000000] memory: 04000000 @ 00000000 (usable) [ 0.000000] Initrd not found or empty - disabling initrd [ 0.000000] Zone ranges: [ 0.000000] Normal [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Movable zone start for each node [ 0.000000] Early memory node ranges [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff] [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 16 bytes. [ 0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256 [ 0.000000] Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200 [ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes) [ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes) [ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes) [ 0.000000] Memory: 59456K/65536K available (3018K kernel code, 151K rwdata, 744K rodata, 1264K init, 197K bss, 6080K reserved, 0K cma-reserved) [ 0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=1 [ 0.000000] NR_IRQS:256 [ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 11479041721 ns [ 0.000022] sched_clock: 32 bits at 166MHz, resolution 6ns, wraps every 12897800188ns [ 0.008156] Calibrating delay loop... 332.54 BogoMIPS (lpj=665088) [ 0.042809] pid_max: default: 32768 minimum: 301 [ 0.047927] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.054736] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes) [ 0.072156] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns [ 0.084380] NET: Registered protocol family 16 [ 0.347713] registering PCI controller with io_map_base unset [ 0.378767] PCI host bridge to bus 0000:00 [ 0.383045] pci_bus 0000:00: root bus resource [mem 0x10200000-0x102fffff] [ 0.390107] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0] [ 0.397094] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0] [ 0.404092] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff] [ 0.413053] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring [ 0.422750] pci 0000:00:00.0: BAR 8: assigned [mem 0x10200000-0x102fffff] [ 0.429809] pci 0000:01:00.0: BAR 0: assigned [mem 0x10200000-0x10207fff 64bit] [ 0.437341] pci 0000:00:00.0: PCI bridge to [bus 01] [ 0.442432] pci 0000:00:00.0: bridge window [mem 0x10200000-0x102fffff] [ 0.451507] clocksource: Switched to clocksource MIPS [ 0.461250] NET: Registered protocol family 2 [ 0.468147] TCP established hash table entries: 1024 (order: 0, 4096 bytes) [ 0.475516] TCP bind hash table entries: 1024 (order: 0, 4096 bytes) [ 0.482139] TCP: Hash tables configured (established 1024 bind 1024) [ 0.488896] UDP hash table entries: 256 (order: 0, 4096 bytes) [ 0.495060] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes) [ 0.502417] NET: Registered protocol family 1 [ 0.522271] futex hash table entries: 256 (order: -1, 3072 bytes) [ 0.528922] Crashlog allocated RAM at address 0x3f00000 [ 0.577475] squashfs: version 4.0 (2009/01/31) Phillip Lougher [ 0.583613] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc. [ 0.602346] io scheduler noop registered [ 0.606484] io scheduler deadline registered (default) [ 0.613696] PCI: Enabling device 0000:00:00.0 (0000 -> 0002) [ 0.620831] bcm63xx_uart.0: ttyS0 at MMIO 0xb0000100 (irq = 36, base_baud = 1562500) is a bcm63xx_uart [ 0.630556] console [ttyS0] enabled [ 0.630556] console [ttyS0] enabled [ 0.637702] bootconsole [early0] disabled [ 0.637702] bootconsole [early0] disabled [ 0.659960] m25p80 spi1.0: found w25q128, expected m25p80 [ 0.665565] m25p80 spi1.0: w25q128 (16384 Kbytes) [ 0.671130] bcm63xxpart: CFE boot tag found with version 6 and board type 96318A-1441N1 [ 0.679588] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000 [ 0.686212] bcm63xxpart: Partition 1 is kernel offset 10100 and length 13ed4c [ 0.693555] bcm63xxpart: Partition 2 is rootfs offset 14ee4c and length ea11b4 [ 0.700997] bcm63xxpart: Partition 3 is nvram offset ff0000 and length 10000 [ 0.708264] bcm63xxpart: Partition 4 is linux offset 10000 and length fe0000 [ 0.715527] 5 bcm63xxpart partitions found on MTD device spi1.0 [ 0.721624] Creating 5 MTD partitions on "spi1.0": [ 0.726580] 0x000000000000-0x000000010000 : "CFE" [ 0.735342] 0x000000010100-0x00000014ee4c : "kernel" [ 0.745182] 0x00000014ee4c-0x000000ff0000 : "rootfs" [ 0.754860] mtd: device 2 (rootfs) set to be root filesystem [ 0.761975] 1 squashfs-split partitions found on MTD device rootfs [ 0.768413] 0x0000003c0000-0x000000ff0000 : "rootfs_data" [ 0.777775] 0x000000ff0000-0x000001000000 : "nvram" [ 0.787406] 0x000000010000-0x000000ff0000 : "linux" [ 0.836847] b53_common: found switch: BCM63xx, rev 0 [ 0.842736] bcm63xx-wdt bcm63xx-wdt: started, timer margin: 30 sec [ 0.852223] PCI: Enabling device 0000:01:00.0 (0000 -> 0002) [ 0.858155] bcma: bus0: Found chip with id 43217, rev 0x01 and package 0x09 [ 0.865394] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x27, class 0x0) [ 0.874240] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x1E, class 0x0) [ 0.883165] bcma: bus0: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x14, class 0x0) [ 0.905999] bcma: bus0: Bus registered [ 0.913627] NET: Registered protocol family 10 [ 0.927066] NET: Registered protocol family 17 [ 0.931957] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this. [ 0.945024] 8021q: 802.1Q VLAN Support v1.8 [ 0.964185] VFS: Mounted root (squashfs filesystem) readonly on device 31:2. [ 0.999089] Freeing unused kernel memory: 1264K (803e4000 - 80520000) [ 2.925967] init: Console is alive [ 2.929996] init: - watchdog - [ 4.968010] kmodloader: loading kernel modules from /etc/modules-boot.d/* [ 5.143040] usbcore: registered new interface driver usbfs [ 5.149101] usbcore: registered new interface driver hub [ 5.154899] usbcore: registered new device driver usb [ 5.198260] SCSI subsystem initialized [ 5.225641] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver [ 5.236270] ehci-platform: EHCI generic platform driver [ 5.343602] ehci-platform ehci-platform: EHCI Host Controller [ 5.349617] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1 [ 5.358256] ehci-platform ehci-platform: irq 50, io mem 0xb0005000 [ 5.375537] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00, overcurrent ignored [ 5.386209] hub 1-0:1.0: USB hub found [ 5.391075] hub 1-0:1.0: 1 port detected [ 5.406109] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver [ 5.416656] ohci-platform: OHCI generic platform driver [ 5.422420] ohci-platform ohci-platform: Generic Platform OHCI controller [ 5.429523] ohci-platform ohci-platform: new USB bus registered, assigned bus number 2 [ 5.437995] ohci-platform ohci-platform: irq 49, io mem 0xb0005100 [ 5.505882] hub 2-0:1.0: USB hub found [ 5.510780] hub 2-0:1.0: 1 port detected [ 5.530088] usbcore: registered new interface driver usb-storage [ 5.538021] kmodloader: done loading kernel modules from /etc/modules-boot.d/* [ 5.547928] init: - preinit - [ 6.621162] random: nonblocking pool is initialized [ 8.208171] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on LAN1, 100Mbps, full-duplex Press the [f] key and hit [enter] to enter failsafe mode Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level [ 10.877341] jffs2: notice: (359) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found. [ 10.898470] mount_root: switching to jffs2 overlay [ 10.967029] urandom-seed: Seeding with /etc/urandom.seed [ 11.240570] procd: - early - [ 11.243975] procd: - watchdog - [ 11.997546] procd: - ubus - [ 12.164970] procd: - init - Please press Enter to activate this console. [ 13.149896] kmodloader: loading kernel modules from /etc/modules.d/* [ 13.205987] ip6_tables: (C) 2000-2006 Netfilter Core Team [ 13.248453] Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f [ 13.256805] Backport generated by backports.git backports-20160324-13-g24da7d3c [ 13.272828] ip_tables: (C) 2000-2006 Netfilter Core Team [ 13.304663] nf_conntrack version 0.5.0 (948 buckets, 3792 max) [ 13.406994] usbcore: registered new interface driver ums-alauda [ 13.418678] usbcore: registered new interface driver ums-cypress [ 13.430678] usbcore: registered new interface driver ums-datafab [ 13.442075] usbcore: registered new interface driver ums-freecom [ 13.453975] usbcore: registered new interface driver ums-isd200 [ 13.465756] usbcore: registered new interface driver ums-jumpshot [ 13.477247] usbcore: registered new interface driver ums-karma [ 13.490297] usbcore: registered new interface driver ums-sddr09 [ 13.502190] usbcore: registered new interface driver ums-sddr55 [ 13.514710] usbcore: registered new interface driver ums-usbat [ 13.566811] xt_time: kernel timezone is -0000 [ 13.776640] PPP generic driver version 2.4.2 [ 13.787938] NET: Registered protocol family 24 [ 13.856781] b43-phy0: Broadcom 43217 WLAN found (core revision 30) [ 13.864503] b43-phy0: Found PHY: Analog 9, Type 4 (N), Revision 17 [ 13.870953] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2057, Revision 14, Version 0 [ 13.879820] Broadcom 43xx driver loaded [ Features: PNL ] [ 14.057013] kmodloader: done loading kernel modules from /etc/modules.d/* [ 26.476183] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on LAN1, 100Mbps, full-duplex [ 26.495934] device eth0.1 entered promiscuous mode [ 26.500926] device eth0 entered promiscuous mode [ 26.521979] br-lan: port 1(eth0.1) entered forwarding state [ 26.527871] br-lan: port 1(eth0.1) entered forwarding state [ 28.531642] br-lan: port 1(eth0.1) entered forwarding state [ 31.805780] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07) [ 31.937826] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 31.984041] device wlan0 entered promiscuous mode [ 32.032173] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 32.039159] br-lan: port 2(wlan0) entered forwarding state [ 32.044960] br-lan: port 2(wlan0) entered forwarding state [ 34.047522] br-lan: port 2(wlan0) entered forwarding state BusyBox v1.26.2 () built-in shell (ash) _________ / /\ _ ___ ___ ___ / LE / \ | | | __| \| __| / DE / \ | |__| _|| |) | _| /________/ LE \ |____|___|___/|___| lede-project.org \ \ DE / \ LE \ / ----------------------------------------------------------- \ DE \ / Reboot (SNAPSHOT, r3615+1-a732f69) \________\/ ----------------------------------------------------------- === WARNING! ===================]������j There is no root password defined on this device! Use the "passwd" command to set up a new password in order to prevent unauthorized SSH logins. -------------------------------------------------- root@LEDE:/#


Tags

toh/comtrend/ar5315u.txt · Last modified: 2018/11/12 10:36 by danitool