User Tools

Site Tools


ru:doc:howto:access.modem.through.nat

Доступ к модему

Некоторые DSL-/технологии docsis-модемы могут быть доступны конечному пользователю. Для этого необходимо узнать, какой IP-адрес имеет устройство и на каком порту используется протокол, к которому можно получить доступ. Иногда вам дополнительно нужно правильное имя пользователя и пароль, чтобы получить доступ или применить изменения.

После получения информации, вы подключите маршрутизатор непосредственно к компьютеру, дать вашему компьютеру IP-адрес из той же сети и получить доступ к нему с помощью соответствующей программы. Легкий. Все-таки удастся это сделать через NAT, следуйте инструкциям:

Подход “конфигурационный псевдоним” устаревшие, согласно примечанию на network configuration page. И соответствующие биты интерфейса нет в Barrier Breaker r38392. Если я узнаю, как еще это сделать, я добавлю его сюда. Possible resolution to configure from the GUI

Через NAT

Глобальной сети по DHCP или статический IP

Версия командной строки UCI

Следуйте этим инструкциям, если вы используете установку по умолчанию backfire и управляете брандмауэром через UCI

IP-адрес в той же сети, что и модем, должен быть назначен интерфейсу, который подключен к модему. Для этого мы создаем псевдоним, как показано ниже.

Для этого примера мы предполагаем две вещи: что IP модема “169.254.1.8”, и то, что интерфейс “WAN” мы добавляем алиас на интерфейс eth1.

Направляйтесь к/etc/config / network и добавьте эти строки.

config interface modem
	option ifname eth1
	option proto static
	option ipaddr 169.254.1.1
	option netmask 255.255.255.0

Чтобы освободить внутренний диапазон адресов модема от маскировки, добавьте выражение “masq_dest” в зону глобальной сети в файле / etc/config/firewall:

config zone
        option name             wan
        option network          'wan'
        option input            REJECT
        option output           ACCEPT 
        option forward          REJECT
        option masq             1
        # The firewall will resolve the expression "!modem" to 
        # "! -s 169.254.1.1/255.255.255.0" or whatever range 
        # was configured in the modem alias.
        option masq_dest        '!modem'
        option mtu_fix          1

:!: Если модем должен иметь IP-адрес, например “192.168.1.8”, вы не можете использовать сеть “192.168.1.0/24” для локальной сети и в то же время получить доступ к модему с помощью этого метода. Используйте любую другую сеть в этом случае, например, “192.168.0.0 / 24” или “192.168.33.0 / 24”.

Версия GUI

1. Добавить псевдоним

Перейдите на страницу администрирование → сеть → Интерфейсы → WAN и введите имя в поле “IP-псевдонимы” “добавить поле” и выберите “Добавить”.


В появившемся разделе псевдонима заполните поля IP-адреса и сетевой маски, подходящие для вашего модема, нажмите “Сохранить и применить”.
В моем случае модем можно через 192.168.100.1, поэтому я выбрал в качестве псевдонима адреса 192.168.100.10.
Через некоторое время префикс псевдонима появится на дисплее состояния интерфейса (подчеркнут красным цветом).


Перейдите на страницу администрирование →сеть→межсетевой экран и открываем WAN свойств зоны(обрамленные красной).\\

Перейдите на вкладку “Дополнительные настройки” и введите “!модем ” в поле ограничения десантирования, это скажет брандмауэра не нац трафик, направленный по адресу модем серии.
Нажмите “Сохранить и применить”, чтобы изменения вступили в силу.


На данный момент модем должен быть доступен с любого хоста в сети.

Необработанный вариант iptables (требуется для настройки PPPoE)

Давайте настроим исходный NAT. Это делается с помощью “iptables”, см.netfilter. Эти пользовательские правила можно добавить в файл /etc/firewall.пользователя или с помощью интерфейса Luci (Сеть > Брандмауэр > Пользовательские правила).

iptables -t nat -I postrouting_rule -s 192.168.1.0/24 -d 169.254.1.8 -j SNAT --to 169.254.1.1
iptables -I zone_lan_forward -s 192.168.1.0/24 -d 169.254.1.8 -j ACCEPT

Если вы изменили “сеть” по умолчанию маршрутизатор openwrt на “192.168.1.1”, вы будете иметь, чтобы заменить “192.168.1.0” с net вы выбрали.

Примечание: в зависимости от того, насколько ограничительным является брандмауэр и политика, может потребоваться выполнить следующее, а также разрешить поток (вышеуказанные правила только управлять SNAT):

iptables -I FORWARD -j ACCEPT -i br-lan -o eth0.2
iptables -I FORWARD -j ACCEPT -m state --state ESTABLISHED,RELATED

Это работает, потому что pppd (необходим для PPPoE) spawns pppoe-dsl, so eth0.2 остается свободно годный к употреблению. После тестирования изменений конфигурации добавьте все необходимые команды в /et/firewall.user. Теперь, например, вы можете использовать графический интерфейс программы, чтобы показать некоторую информацию о вашем DSL status:

- картинка не работает

https://images.duckduckgo.com/iu/?u=http%3A%2F%2Fxervice.com%2FSpeedmodem_200.png&f=1

NOTE: Не все модемы предлагают доступ! Выше изображение получается через программу (закрытый источник), написанную с целью получения графического обзора для различных модемов. Очень полезно отслеживать проблемы с подключением и следить за DSL-подключением. Но некоторые модем даже предлагают web-интерфейс, так Вы можете получить доступ к ним с помощью веб-браузера.

Опытный пользователь

Следуйте этим инструкциям, если вы не используете UCI для управления брандмауэром

Большая частьлегкая версия по-прежнему применяется. После назначения интерфейса модема адрес, вам придется исходных пакетов через NAT IP-адрес DSL-модема, добавив следующую строку пос MASQUERADE:

IF_LAN="br-lan"
NET_LAN="192.168.1.0/24"
iptables -t nat -A POSTROUTING -o eth0.2 -i $IF_LAN -s $NET_LAN -d 169.254.1.0/8 -j SNAT --to-source 169.254.1.1

WAN by PPPoE

Версия командной строки UCI

Следуйте этим инструкциям, если используется установка по умолчанию настройки отношения 12.09 и более поздних версий

В этом примере модем имеет “192.168.254.254” по умолчанию IP. Объявить новый интерфейс под названием “модем”. Псевдоним больше не нужен, так как несколько интерфейсов могут совместно использовать один и тот же ifname. Убедитесь, что используется другая сеть, чем существующая локальная сеть. Направляйтесь к /etc/config/network и добавьте следующие строки:

config interface 'modem'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.254.1'
        option netmask '255.255.255.0'

Заменить на eth1 с все PPPoE-интерфейс использует. например, для eth0.2

Проверьте, если ваш интерфейс с:

ifstatus modem

Модем теперь должны обмениваться информацией с вашего маршрутизатора. Поскольку переадресация между локальной сетью и eth1 ниже PPPoE-WAN запрещена, теперь просто вставьте новый интерфейс в зону глобальной сети, чтобы он был переадресован:

uci set firewall.@zone[1].network='wan modem'
uci commit firewall
fw reload

И это действительно все, что нужно сделать. Вы также можете создать новую зону под названием “модем” и сделать интерзон-переадресацию, но это больше работы, чтобы сделать.

DOCSIS

Со стандартами DOCSIS-модем, мы не используем PPPD и не порождать никаких дополнительных интерфейсов, поэтому SNAT-hook нужно перед MASQUERADING-hook. Также необходимо задать псевдоним интерфейса, с которым подключен кабельный модем.

Во-первых, дать интерфейса (в данном случае это даже виртуальный интерфейс), с которыми сталкивается Интернет второй IP-адрес:

ifconfig eth0.2:1 add 192.168.100.2

С UCI вы также можете добиться этого: network_interface_alias.

Затем источник нац пакеты на IP-адрес кабельного модема. Добавьте следующую строку перед MASQUERADE:

iptables -t nat -I POSTROUTING -o eth0.2:1 -i eth0.1 -s $NET_LAN -d 192.168.100.1 -j SNAT --to-source 192.168.100.2

NOTE: В зависимости от того, насколько ограничительным является брандмауэр и политика, может потребоваться выполнить следующие действия, чтобы разрешить поток (вышеуказанные правила управляют только SNAT):

iptables -I FORWARD -j ACCEPT -i $IF_LAN -o $IF_DSL
iptables -I FORWARD -j ACCEPT -m state --state ESTABLISHED,RELATED

Теперь доступ к вам кабельный модем с компьютера с помощью программы telnet или с помощью браузера:

Вставить рисунок

ru/doc/howto/access.modem.through.nat.txt · Last modified: 2018/06/08 20:39 by tmomas