OpenWrt 22.03.0-rc1 - First Release Candidate - 24 April 2021

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.0-rc1, r19302-df622768da
 -----------------------------------------------------

The OpenWrt Project is a Linux operating system targeting embedded devices. It is a complete replacement for the vendor-supplied firmware of a wide range of wireless routers and non-network devices. See the Table of Hardware for supported devices. For more information about OpenWrt project organization, see the About OpenWrt pages.

An upgrade from OpenWrt 21.02 to OpenWrt 22.03 is supported in many cases with the help of the sysupgrade utility which will also attempt to preserve the configuration. A configuration backup is advised nonetheless when upgrading to OpenWrt 22.03. (see “Upgrading” below).

This is just a release candidate and not the final release yet.

Get OpenWrt Firmware at: https://downloads.openwrt.org/releases/22.03.0-rc1/

The OpenWrt community is proud to announce the first release candidate of the upcoming OpenWrt 22.03 stable version series. It incorporates over 3400 commits since branching the previous OpenWrt 21.02 release and has been under development for about one year.

Firewall4 is used by default instead of firewall3 in the OpenWrt default images. Firewall4 uses nftables instead of iptables to configure the Linux netfilters.

Firewall4 uses the same UCI firewall configuration. Old firewall configurations should still work with firewall4, using nftables now. The extra option which allowed to add custom iptables commands does not work any more.

iptables is not included in the default images any more, it can be added with opkg or ImageBuilder if needed. iptables-nft, arptables-nft, ebtables-nft and xtables-nft provide the known command line interface from the old tools, but they will create nftables entries instead.

OpenWrt 22.03 supports over 1550 devices. Support for over 160 new devices was added in addition to the device support by OpenWrt 21.02. OpenWrt 22.03 supports more than 10 devices capable of Wifi 6 (IEEE 802.11ax) using the MediaTek MT7915 wifi chip.

  • The qoriq target for the NXP QorIQ (PowerPC) was added in OpenWrt 22.03.
  • The bmips target for the Boardcom MIPS BCM33xx, BCM63xx and BCM7xxx SoCs was added.

The following targets or boards were migrated from swconfig to DSA with OpenWrt 22.03 in addition to the systems already migrated with OpenWrt 21.02:

  • bcm53xx: All board using this target were converted to DSA
  • lantiq: All boards using the xrx200 / vr9 SoC
  • sunxi: Bananapi Lamobo R1 (only sunxi board with switch)

The LuCI bootstrap design supports a dark mode. The default design activates dark mode depending on the browser settings. Change it manually at “System” → “System” → “Language and Style”.

OpenWrt 22.03 uses musl 1.2.x, which changed the time_t type from 32 bit to 64 bit on 32 bit systems, on 64 bit system it was always 64 bit long. When a Unix time stamp is stored in a signed 32 bit integer it will overflow on 19 January 2038. With the change to 64 bit this will happen 292 billion years later. This is a change of the musl libc ABI and needs a recompilation of all user space applications linked against musl libc. For 64 bit systems this was done when the ABI was defined many years ago, the glibc ARC ABI already has a 64 bit time_t.

Core components have the following versions in 22.03.0-rc1:

  • Updated toolchain:
    • musl libc 1.2.3
    • glibc 2.34
    • gcc 11.2.0
    • binutils 2.37
  • Updated Linux kernel
    • 5.10.111 for all targets
  • Network:
    • hostapd 2.10, dnsmasq 2.86, dropbear 2022.82
    • cfg80211/mac80211 from kernel 5.15.33
  • System userland:
    • busybox 1.35.0

In addition to the listed applications, many others were also updated.

Sysupgrade can be used to upgrade a device from 21.02 to 22.03, and configuration will be preserved in most cases.

:!: Sysupgrade from 19.07 to 22.03 is not supported.

:!: There is no migration path for targets that switched from swconfig to DSA. In that case, sysupgrade will refuse to proceed with an appropriate error message:
Image version mismatch. image 1.1 device 1.0 Please wipe config during upgrade (force required) or reinstall. Config cannot be migrated from swconfig to DSA Image check failed

As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
  • Last modified: 2022/04/24 12:52
  • by hauke